X
點擊此處開啟此網站的行動版。

技術支援討論區

I can't drag and drop images from firefox to explorer (desktop or any explorer window).

已張貼

Before, I could always drag and drop images from firefox to the desktop, and now I can't! I've try without any module or to do a fresh installation, it doesn't change! I can still use right click save image as... But it's a very big loose of time for me!

When I try to drag and drop the image, when i reach the desktop, intead of a preview thumbnail of the image with the arrow of my mouse i have an interdiction sign as a cursor!

I have firefox 67.0b10 64bits, on windows 7 64bits install on a SSD!

Before, I could always drag and drop images from firefox to the desktop, and now I can't! I've try without any module or to do a fresh installation, it doesn't change! I can still use right click save image as... But it's a very big loose of time for me! When I try to drag and drop the image, when i reach the desktop, intead of a preview thumbnail of the image with the arrow of my mouse i have an interdiction sign as a cursor! I have firefox 67.0b10 64bits, on windows 7 64bits install on a SSD!

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

更多資訊

You4eea 0 個解決方法 3 個答案

Corro said

jscher2000 said
Thank you all for the feedback. A bug was filed for this earlier today. When I learn anything new, I'll update this thread. Until then: Does this still work on your Firefox:
  • right-click the image > Copy Image
  • right-click the Desktop > Paste
Or is the clipboard also not working correctly (possibly related issue)?

The copy past work, it's jsut the drag and drop that doesn't work anymore :/ !

Yes, This feature still worked for me even when drag and drop wasn't..

I posted on this thread that it is now working and what I did. As of now drag and drop is still working for me.

If it is helpful for bugs, before I posted here.. I did narrow down what I thought was a the problem addon (OpenLorem). So I would enable/disable as needed. but a few updates later, that was no longer working.

''Corro [[#answer-1236245|said]]'' <blockquote> ''jscher2000 [[#answer-1236191|said]]'' <blockquote> Thank you all for the feedback. A bug was filed for this earlier today. When I learn anything new, I'll update this thread. Until then: '''Does this still work on your Firefox:''' * right-click the image > Copy Image * right-click the Desktop > Paste Or is the clipboard also not working correctly (possibly related issue)? </blockquote> The copy past work, it's jsut the drag and drop that doesn't work anymore :/ ! </blockquote> <strong>Yes,</strong> This feature still worked for me even when drag and drop wasn't.. I posted on this thread that it is now working and what I did. As of now drag and drop is still working for me. If it is helpful for bugs, before I posted here.. I did narrow down what I thought was a the problem addon (OpenLorem). So I would enable/disable as needed. but a few updates later, that was no longer working.
jscher2000
  • Top 10 Contributor
8776 個解決方法 71744 個答案

You4eea said

I then performed the above steps you suggested, same behavior in the test profile also. BUT... When I went back to about:profiles and deleted that test profile I restarted firefox into my profile drag and drop worked Not sure if that is helpful for narrowing things down, but it is working now.

Thank you for the report.

I read some speculation that the new way Firefox handles profiles in Firefox 67 could possibly be a factor. However, since the way processes are isolated to allow multiple instances of Firefox is somewhat mysterious, I don't know how to investigate further.

''You4eea [[#answer-1236357|said]]'' <blockquote>I then performed the above steps you suggested, same behavior in the test profile also. BUT... When I went back to about:profiles and deleted that test profile I restarted firefox into my profile <strong>drag and drop worked</strong> Not sure if that is helpful for narrowing things down, but it is working now. </blockquote> Thank you for the report. I read some speculation that the new way Firefox handles profiles in Firefox 67 could possibly be a factor. However, since the way processes are isolated to allow multiple instances of Firefox is somewhat mysterious, I don't know how to investigate further.
Wag669 1 個解決方法 13 個答案

I'm not sure how to react right now.... Earlier today, dragging and dropping to desktop didn't work, I tried to drag and drop an url from ff to desktop, in order to check if creating a shortcut on desktop would work, and it worked

So, naturally, I tried to drag a picture from ff to my desktop and it worked....

I just called a priest, I think my PC is in need of an exorcism

I'm not sure how to react right now.... Earlier today, dragging and dropping to desktop didn't work, I tried to drag and drop an url from ff to desktop, in order to check if creating a shortcut on desktop would work, and it worked So, naturally, I tried to drag a picture from ff to my desktop and it worked.... I just called a priest, I think my PC is in need of an exorcism

由 Wag669 於 修改

Corro 0 個解決方法 7 個答案

Wag669 said

I'm not sure how to react right now.... Earlier today, dragging and dropping to desktop didn't work, I tried to drag and drop a url on desktop, in order to check if creating a shortcut on desktop would work. It worked So, naturally, I tried to drag a picture and it worked.... I just called a priest, I think my PC is in need of an exorcism

I tried that, but I can't even drag and drop a url either...

''Wag669 [[#answer-1236430|said]]'' <blockquote> I'm not sure how to react right now.... Earlier today, dragging and dropping to desktop didn't work, I tried to drag and drop a url on desktop, in order to check if creating a shortcut on desktop would work. It worked So, naturally, I tried to drag a picture and it worked.... I just called a priest, I think my PC is in need of an exorcism </blockquote> I tried that, but I can't even drag and drop a url either...
philipp
  • Top 25 Contributor
  • Moderator
5316 個解決方法 23478 個答案

有幫助的回覆

please also refer to this article in our kb: [[Running Windows as Administrator with Launcher Process Enabled Causes Drag and Drop Errors - How to Fix]]
Wag669 1 個解決方法 13 個答案

Corro said

I tried that, but I can't even drag and drop a url either...

The behavior you are experiencing is identical to that of Firefox Developer Edition 69.0b3 Which I use every time there is a bug in the stable version of FF

It is, as if FF runs in some kind of sandbox, that doesn't allow it to interact with the rest of the Windows OS Let;s hope they fix it soon

''Corro [[#answer-1236435|said]]'' <blockquote> I tried that, but I can't even drag and drop a url either... </blockquote> The behavior you are experiencing is identical to that of Firefox Developer Edition 69.0b3 Which I use every time there is a bug in the stable version of FF It is, as if FF runs in some kind of sandbox, that doesn't allow it to interact with the rest of the Windows OS Let;s hope they fix it soon

由 Wag669 於 修改

Corro 0 個解決方法 7 個答案

philipp said

please also refer to this article in our kb: Running Windows as Administrator with Launcher Process enabled in Firefox causes Drag and Drop errors - How to Fix

My UAC was already on default, it didn't change anything!

but trying tu run firefox in command line with "-no-deelevate".

unfortunately I wasn't able to add this command in the firefox shortcut, it doesn't allow me (or i don't have the right way to write it but i tried several).

So, what i did (to not launch firefox everytime in the command line) :

  • go to the "about:config" page
  • click on the "i take the risk" button
  • search for "launcher"
  • double click on it to set is default value to false
  • reload firefox

and now it works! thanks for that!

(I hope turning this launcher off won't creat me other problems in the future though).

''philipp [[#answer-1236438|said]]'' <blockquote> please also refer to this article in our kb: [[Running Windows as Administrator with Launcher Process Enabled Causes Drag and Drop Errors - How to Fix]] </blockquote> My UAC was already on default, it didn't change anything! but trying tu run firefox in command line with "-no-deelevate". unfortunately I wasn't able to add this command in the firefox shortcut, it doesn't allow me (or i don't have the right way to write it but i tried several). '''So, what i did (''to not launch firefox everytime in the command line'') :''' * go to the "about:config" page * click on the "i take the risk" button * search for "launcher" * double click on it to set is default value to false * reload firefox and now it works! thanks for that! (I hope turning this launcher off won't creat me other problems in the future though).
VK759 0 個解決方法 3 個答案

Corro said

philipp said
please also refer to this article in our kb: Running Windows as Administrator with Launcher Process enabled in Firefox causes Drag and Drop errors - How to Fix

(...)

but trying tu run firefox in command line with "-no-deelevate".

unfortunately I wasn't able to add this command in the firefox shortcut, it doesn't allow me (or i don't have the right way to write it but i tried several).

The -no-deelevate shortcut command did it for me. :) I was also having problems adding it but going into the Advanced... in that same tab and checking Run as administrator fixed it.

Thanks everyone for the help.

''Corro [[#answer-1236448|said]]'' <blockquote> ''philipp [[#answer-1236438|said]]'' <blockquote> please also refer to this article in our kb: [[Running Windows as Administrator with Launcher Process Enabled Causes Drag and Drop Errors - How to Fix]] </blockquote> (...) but trying tu run firefox in command line with "-no-deelevate". unfortunately I wasn't able to add this command in the firefox shortcut, it doesn't allow me (or i don't have the right way to write it but i tried several). </blockquote> The ''-no-deelevate'' shortcut command did it for me. :) I was also having problems adding it but going into the '''Advanced...''' in that same tab and checking '''Run as administrator''' fixed it. Thanks everyone for the help.

由 VK759 於 修改

Corro 0 個解決方法 7 個答案

Wag669 said

I rolled back to v67.0.4 and drag and drop works fine! Will wait for the bug to be fixed before upgrading I also noticed a strange issue when FF68 goes out of focus and back into focus for a couple of times, but can not replicate it. I just see the tab bar change colors (out of focus -> focus ->out of focus -> focus)

now that the main problem is fixed! I also see that I have that focus problem!

''Wag669 [[#answer-1236257|said]]'' <blockquote> I rolled back to v67.0.4 and drag and drop works fine! Will wait for the bug to be fixed before upgrading I also noticed a strange issue when FF68 goes out of focus and back into focus for a couple of times, but can not replicate it. I just see the tab bar change colors (''out of focus -> focus ->out of focus -> focus'') </blockquote> now that the main problem is fixed! I also see that I have that focus problem!
Wag669 1 個解決方法 13 個答案

Corro said

Wag669 said
I rolled back to v67.0.4 and drag and drop works fine! Will wait for the bug to be fixed before upgrading I also noticed a strange issue when FF68 goes out of focus and back into focus for a couple of times, but can not replicate it. I just see the tab bar change colors (out of focus -> focus ->out of focus -> focus)

now that the main problem is fixed! I also see that I have that focus problem!

This issue appears randomly after starting FF and I can not replicate it. Also the mouse pointer seems to be lagging some times. Especially if I move the cursor across a page with mixed content and it has to switch from default arrow, to pointer (finger) back to arrow, to I-beam pointer, back to arrow It appears to just stop momentarily, before switching to the new cursor.


bugs bugs bugs

''Corro [[#answer-1236472|said]]'' <blockquote> ''Wag669 [[#answer-1236257|said]]'' <blockquote> I rolled back to v67.0.4 and drag and drop works fine! Will wait for the bug to be fixed before upgrading I also noticed a strange issue when FF68 goes out of focus and back into focus for a couple of times, but can not replicate it. I just see the tab bar change colors (''out of focus -> focus ->out of focus -> focus'') </blockquote> now that the main problem is fixed! I also see that I have that focus problem! </blockquote> This issue appears randomly after starting FF and I can not replicate it. Also the mouse pointer seems to be lagging some times. Especially if I move the cursor across a page with mixed content and it has to switch from default arrow, to pointer (finger) back to arrow, to I-beam pointer, back to arrow It appears to just stop momentarily, before switching to the new cursor. bugs bugs bugs
Wag669 1 個解決方法 13 個答案

Now it just started Freezing and Crashing for no reason

Now it just started Freezing and Crashing for no reason