搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

disable autoplay?

more options

I've been a FF user for many years. downloaded and installed new firefox 66.0.3 (64-bit) at the prompting of an email touting "Block Autoplay" from Mozilla. went to youtube to test. set youtube autoplay to off and tried several videos on the home page. they all autoplay. have always hated autoplay. forum solutions seem to all be older solutions. do i need to make more changes in about:config? please help.

I've been a FF user for many years. downloaded and installed new firefox 66.0.3 (64-bit) at the prompting of an email touting "Block Autoplay" from Mozilla. went to youtube to test. set youtube autoplay to off and tried several videos on the home page. they all autoplay. have always hated autoplay. forum solutions seem to all be older solutions. do i need to make more changes in about:config? please help.

被選擇的解決方法

You can look at these prefs on the about:config page to see if these values work for you.

  • media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt]
  • media.autoplay.allow-muted = false
  • media.autoplay.enabled.user-gestures-needed = false

For user-gestures-needed you can try false and true to see what works for you. You can look at this extension.

從原來的回覆中察看解決方案 👍 0

所有回覆 (7)

more options

Hi, try the setting on the Options page mentioned in the following article: Allow or block media autoplay in Firefox.

Note that Firefox's feature only applies on the initial load of the page, so you are right that you also need to turn off YouTube's feature to continue down its playlist after the first video.

more options

Thanks for the prompt response. I have enabled blocking in Otpions and it did no good. As temporary fix I found an extension called Play that will work for now. It might be helpful to have all the correct values in about:config for "autoplay" search. Where can I get them for v66?

more options

You can search other recent threads. Users disagree on the best combination.

more options

選擇的解決方法

You can look at these prefs on the about:config page to see if these values work for you.

  • media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt]
  • media.autoplay.allow-muted = false
  • media.autoplay.enabled.user-gestures-needed = false

For user-gestures-needed you can try false and true to see what works for you. You can look at this extension.

more options

when searching the forum it would help to have a timeframe and a subject to search. when did v66 come out? what's the best search verbiage? thanks.

more options

thanks, cor-el.

more options

theloniusff said

when searching the forum it would help to have a timeframe and a subject to search. when did v66 come out? what's the best search verbiage? thanks.

Just for Firefox 66: "autoplay" post created after March 25, 2019