搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

firfox shows bad ssl certificate where other browsers don't

  • 6 回覆
  • 1 有這個問題
  • 519 次檢視
  • 最近回覆由 cor-el

more options

We use Chrome and IE, Edge and have no issues with the SSL certificate and it shows green and valid. When we use the Firefox browser it thinks the certificate is invalid when it is not.

https://cpmas-uccxdc01.cintas.com:8445/desktop/container/landing.jsp?locale=en_US

This is a site on our LAN at our corporation and we use a PKI Certificate environment on our network that has all the root and intermediate certificates added to the appropriate stores on the PC's and Laptop's.

被選擇的解決方法

You have to configure Firefox to see the Windows certificate store. Unfortunately, this isn't enabled by default.

Try the following:

  1. Type about:config in the Firefox address bar
  2. Bypass the warning
  3. Change the security.enterprise_roots.enabled value to true
  4. Restart Firefox

Hopefully this fixes the issue.

If you are deploying this on a network with multiple computers, once you have verified that the steps work, you may want to explore using an AutoConfig file to make the required changes to all systems on your network.

從原來的回覆中察看解決方案 👍 0

所有回覆 (6)

more options

Firefox can’t find the server at cpmas-uccxdc01.cintas.com.

Please explain the problem in detail. What happens? What is the exact error messages?


Separate Security Issue: Update your Flash Player or remove it using these links; Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link}

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version 32.0.0.156

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

This link works; https://www.cintas.com/ I had no problem with the website.

more options

This website is likely not accessible: This is a site on our LAN at our corporation.

Does Firefox provide any detail about the error (if necessary then click Advanced)?

more options

it is a local Cisco Finesse agent application on our lan. You cannot get to it externally just Internally. the local certificate works in IE, Edge and Chrome but we get an invalid certificate when using Firefox even though it is not an invalid certificate.

I have uploaded pics showing valid from chrome but invalid from Firefox.

more options

選擇的解決方法

You have to configure Firefox to see the Windows certificate store. Unfortunately, this isn't enabled by default.

Try the following:

  1. Type about:config in the Firefox address bar
  2. Bypass the warning
  3. Change the security.enterprise_roots.enabled value to true
  4. Restart Firefox

Hopefully this fixes the issue.

If you are deploying this on a network with multiple computers, once you have verified that the steps work, you may want to explore using an AutoConfig file to make the required changes to all systems on your network.

more options

The two screenshots you provided do not show an error message. Where do you see this error message? Is there a problem with the certificate chain or doesn't Firefox has the root certificate?

You can try to set this pref to true on the about:config page in case other software adds its root certificate to the Windows certificate store.

  • security.enterprise_roots.enabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.