X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox opens a blank bage instead of the homepage (start-up)

已張貼

I've tried a few things:

- I deleted the folder "sessionstore-backups" in my profile folder and restarted Firefox. - Refreshing Firefox didn't solve the problem. - Disabling most extensions didn't help either.

Has anyone a clue?

It's really annoying and I can't get rid of it.

I've got this issue on my laptop as well. Laptop and PC! They're both connected via the Firefox Sync option.

Thank you for any help!

Best, DD

I've tried a few things: - I deleted the folder "sessionstore-backups" in my profile folder and restarted Firefox. - Refreshing Firefox didn't solve the problem. - Disabling most extensions didn't help either. Has anyone a clue? It's really annoying and I can't get rid of it. I've got this issue on my laptop as well. Laptop and PC! They're both connected via the Firefox Sync option. Thank you for any help! Best, DD

被選擇的解決方法

So currently, no home page will load at Firefox startup, whether it is the built-in about:home page or your custom URL?

Your browser.startup.homepage preference looks fine.

The browser.startup.page preference is purely numeric (integer), so just leave that on the default value of 1 for now.

I think we have seen a couple threads on home pages not loading recently, but I can't remember the cause. Can you rule out your extensions? One way to do that is to test in Firefox's Safe Mode. Here's how:

In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

從原來的回覆中察看解決方案 0
引用

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

更多資訊

FredMcD
  • Top 10 Contributor
4148 個解決方法 57911 個答案

有幫助的回覆

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar. Type browser.startup.homepage

What is the value? Right-click and select Reset to restore its default value; about:home

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar. Type '''browser.startup.homepage''' What is the value? Right-click and select '''Reset''' to restore its default value; '''about:home'''
這篇文章有幫助嗎? 1
引用

提出問題者

It says "https://www.theguardian.com/international".

I reset it and it's back to "about:home".

Edit: By changing it back to my homepage again, it's starting with a blank page again.

It says "https://www.theguardian.com/international". I reset it and it's back to "about:home". Edit: By changing it back to my homepage again, it's starting with a blank page again.

由 dondiato 於 修改

這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8511 個解決方法 69529 個答案

有幫助的回覆

Does this problem only occur at startup? What I mean is, do you get your home page if you do either or both of these:

  • Click the Home button on the toolbar, or use the Alt+Home keyboard shortcut
  • Launch a new window from the menu or using Ctrl+n

If those work, Firefox understands what your home page setting is. There is a startup override that you could double check here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste startup and pause while the list is filtered

(3) Double-click the browser.startup.page preference to display a dialog where you can check/correct the value:

  • 0 => blank page
  • 1 => your home page(s) {default}
  • 2 => the last page viewed in Firefox
  • 3 => previous session windows and tabs

If yours has changed to 0, 2 or 3, change it back to 1 and then click OK to save the change.

Does this problem only occur at startup? What I mean is, do you get your home page if you do either or both of these: * Click the Home button on the toolbar, or use the Alt+Home keyboard shortcut * Launch a new window from the menu or using Ctrl+n If those work, Firefox understands what your home page setting is. There is a startup override that you could double check here: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''startup''' and pause while the list is filtered (3) Double-click the '''browser.startup.page''' preference to display a dialog where you can check/correct the value: * 0 => blank page * 1 => your home page(s) '''{default}''' * 2 => the last page viewed in Firefox * 3 => previous session windows and tabs If yours has changed to 0, 2 or 3, change it back to 1 and then click OK to save the change.

由 jscher2000 於 修改

這篇文章有幫助嗎? 1
引用

提出問題者

Thank you!

When I launch a new window from the menu (or CTRL+N), it opens my homepage. If I click on the home-button itself, it launches the homepage as well.

The very first start-up of Firefox doesn't really work for me. It always starts with a blank page. Afterwards it usually stays like that but now that I have changed the browser.startup.page to my homepage, it always ends up opening the homepage (even though it should be a blank page in some cases).

I'll restart my PC now and check if the issue is still there.

When it comes to changing the preference, there doesn't appear any dialogue when I click on browser.startup.page. Why's that?

Thanks for helping!

Thank you! When I launch a new window from the menu (or CTRL+N), it opens my homepage. If I click on the home-button itself, it launches the homepage as well. The very first start-up of Firefox doesn't really work for me. It always starts with a blank page. Afterwards it usually stays like that but now that I have changed the '''browser.startup.page''' to my homepage, it always ends up opening the homepage (even though it should be a blank page in some cases). I'll restart my PC now and check if the issue is still there. When it comes to changing the preference, there doesn't appear any dialogue when I click on '''browser.startup.page'''. Why's that? Thanks for helping!
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8511 個解決方法 69529 個答案

(Deleted; misunderstood the last reply.)

(Deleted; misunderstood the last reply.)

由 jscher2000 於 修改

這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8511 個解決方法 69529 個答案

dondiato said

When it comes to changing the preference, there doesn't appear any dialogue when I click on browser.startup.page. Why's that?

You either can double-click, or use right-click > Modify.

Edit: The "dialog" is just a blank space.

''dondiato [[#answer-1210797|said]]'' <blockquote> When it comes to changing the preference, there doesn't appear any dialogue when I click on '''browser.startup.page'''. Why's that? </blockquote> You either can double-click, or use right-click > Modify. '''Edit:''' The "dialog" is just a blank space.

由 jscher2000 於 修改

這篇文章有幫助嗎?
引用

提出問題者

jscher2000 said

dondiato said
When it comes to changing the preference, there doesn't appear any dialogue when I click on browser.startup.page. Why's that?

You either can double-click, or use right-click > Modify.

Edit: The "dialog" is just a blank space.

All right. Rather than typing in the whole homepage, I should just type in the number. Am I right?

As for now, it seems to work even though I kept the homepage itself inside. Somehow the issue got solved.

Thank you very much!

''jscher2000 [[#answer-1210801|said]]'' <blockquote> ''dondiato [[#answer-1210797|said]]'' <blockquote> When it comes to changing the preference, there doesn't appear any dialogue when I click on '''browser.startup.page'''. Why's that? </blockquote> You either can double-click, or use right-click > Modify. '''Edit:''' The "dialog" is just a blank space. </blockquote> All right. Rather than typing in the whole homepage, I should just type in the number. Am I right? As for now, it seems to work even though I kept the homepage itself inside. Somehow the issue got solved. Thank you very much!
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8511 個解決方法 69529 個答案

Yes, just the number. Thanks for reporting back.

Yes, just the number. Thanks for reporting back.
這篇文章有幫助嗎?
引用

提出問題者

jscher2000 said

Yes, just the number. Thanks for reporting back.

I am sorry but it didn't solve the problem... Is there any other way?

''jscher2000 [[#answer-1210808|said]]'' <blockquote> Yes, just the number. Thanks for reporting back. </blockquote> I am sorry but it didn't solve the problem... Is there any other way?
這篇文章有幫助嗎?
引用

提出問題者

Home

That's what it looks like now.

It doesn't matter whether I reset the whole thing or if I put a 1 inside. I even tried setting my homepage up through Options but it doesn't work out.

[https://imgur.com/a/ZmiRkcy Home] That's what it looks like now. It doesn't matter whether I reset the whole thing or if I put a 1 inside. I even tried setting my homepage up through '''Options''' but it doesn't work out.
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8511 個解決方法 69529 個答案

選擇的解決方法

So currently, no home page will load at Firefox startup, whether it is the built-in about:home page or your custom URL?

Your browser.startup.homepage preference looks fine.

The browser.startup.page preference is purely numeric (integer), so just leave that on the default value of 1 for now.

I think we have seen a couple threads on home pages not loading recently, but I can't remember the cause. Can you rule out your extensions? One way to do that is to test in Firefox's Safe Mode. Here's how:

In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

So currently, no home page will load at Firefox startup, whether it is the built-in about:home page or your custom URL? Your '''browser.startup.homepage''' preference looks fine. The '''browser.startup.page''' preference is purely numeric (integer), so just leave that on the default value of 1 for now. I think we have seen a couple threads on home pages not loading recently, but I can't remember the cause. Can you rule out your extensions? One way to do that is to test in Firefox's Safe Mode. Here's how: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
這篇文章有幫助嗎?
引用

提出問題者

jscher2000 said

Can you rule out your extensions? One way to do that is to test in Firefox's Safe Mode.

Thank you very, very much! I simply disabled an extension which apparently was the sole reason for this issue to happen. Finally!

You're awesome!

''jscher2000 [[#answer-1210833|said]]'' <blockquote> Can you rule out your extensions? One way to do that is to test in Firefox's Safe Mode. </blockquote> Thank you very, very much! I simply disabled an extension which apparently was the sole reason for this issue to happen. Finally! You're awesome!
這篇文章有幫助嗎?
引用
jxpfox 0 個解決方法 2 個答案

I have this same issue on Windows 8.1 . After Firefox v67 the selected Homepage (google) does not open on Startup, I just get a blank New Tab. Also, all my desktop shortcuts (URLs) just open a New blank Tab. I have no extensions installed. Synced to Android devices, they work fine!

Once Firefox is running it all works just fine. i.e. I hit a URL shortcut from my desktop and get 1 New Tab, hit the URL again and I get a 2nd Tab opening correctly on the destination URL.

This has worked for years, only failed after the V67 update. a Firefox Reset did not change the symptom.

any ideas appreciated
kind regards
I have this same issue on Windows 8.1 . After Firefox v67 the selected Homepage (google) does not open on Startup, I just get a blank New Tab. Also, all my desktop shortcuts (URLs) just open a New blank Tab. I have no extensions installed. Synced to Android devices, they work fine! Once Firefox is running it all works just fine. i.e. I hit a URL shortcut from my desktop and get 1 New Tab, hit the URL again and I get a 2nd Tab opening correctly on the destination URL. This has worked for years, only failed after the V67 update. a Firefox Reset did not change the symptom. any ideas appreciated kind regards
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8511 個解決方法 69529 個答案

Hi jxpfox, there is a different issue in Firefox 67 depending on your settings. Please see the following thread: https://support.mozilla.org/questions/1261184

Hi jxpfox, there is a different issue in Firefox 67 depending on your settings. Please see the following thread: https://support.mozilla.org/questions/1261184
這篇文章有幫助嗎? 1
引用
jxpfox 0 個解決方法 2 個答案

THANK YOU jscher2000

As soon as I read that thread I knew it would be right;  and it was !
This has been annoying me for weeks  so  THANK YOU !!
kind regards
THANK YOU jscher2000 As soon as I read that thread I knew it would be right; and it was ! This has been annoying me for weeks so THANK YOU !! kind regards
這篇文章有幫助嗎?
引用
FredMcD
  • Top 10 Contributor
4148 個解決方法 57911 個答案

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution. Thank you for contacting Mozilla Support.
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題