X
點擊此處開啟此網站的行動版。

技術支援討論區

Block autoplay is broken

已張貼

Hi, below are my current customized autoplay settings. They were fine for quite a few months and videos were blocked from autoplay. Then something changed a few days ago (i didnt mess with them;) and videos (particularly in youtube) are not blocked any more. Anyone else with the issue and can you tell me how to block videos from autoplay??

app.normandy.startupRolloutPrefs.media.autoplay.default;1 dom.media.autoplay.autoplay-policy-api;false media.autoplay.allow-extension-background-pages;false media.autoplay.allow-muted;false media.autoplay.blackList-override-default;true

media.autoplay.block-event.enabled;true media.autoplay.block-webaudio;false

media.autoplay.default;1 media.autoplay.enabled;false media.autoplay.enabled.user-gestures-needed;true

media.block-autoplay-until-in-foreground;true

Hi, below are my current customized autoplay settings. They were fine for quite a few months and videos were blocked from autoplay. Then something changed a few days ago (i didnt mess with them;) and videos (particularly in youtube) are not blocked any more. Anyone else with the issue and can you tell me how to block videos from autoplay?? app.normandy.startupRolloutPrefs.media.autoplay.default;1 dom.media.autoplay.autoplay-policy-api;false media.autoplay.allow-extension-background-pages;false media.autoplay.allow-muted;false media.autoplay.blackList-override-default;true media.autoplay.block-event.enabled;true media.autoplay.block-webaudio;false media.autoplay.default;1 media.autoplay.enabled;false media.autoplay.enabled.user-gestures-needed;true media.block-autoplay-until-in-foreground;true

由 huego 於 修改

被選擇的解決方法

Thanks for the link! But it's no good to my issue.

Just found the solution in one of the other topics in the forum -

media.autoplay.enabled.user-gestures-needed - this one must be set to FALSE

Thanks again!

從原來的回覆中察看解決方案 0

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

更多資訊

McCoy
  • Top 10 Contributor
578 個解決方法 5391 個答案

Hello huego,

I think (hope) you will find the answer here :

https://support.mozilla.org/en-US/kb/block-autoplay

Any good  ?

Hello huego, I think (hope) you will find the answer here : https://support.mozilla.org/en-US/kb/block-autoplay Any good ?

選擇的解決方法

Thanks for the link! But it's no good to my issue.

Just found the solution in one of the other topics in the forum -

media.autoplay.enabled.user-gestures-needed - this one must be set to FALSE

Thanks again!

Thanks for the link! But it's no good to my issue. Just found the solution in one of the other topics in the forum - media.autoplay.enabled.user-gestures-needed - this one must be set to FALSE Thanks again!

由 huego 於 修改

McCoy
  • Top 10 Contributor
578 個解決方法 5391 個答案

huego said

media.autoplay.enabled.user-gestures-needed - this one must be set to FALSE

I have mine set to "true", as I don't want videos autoplaying on every site - I thought that was what you wanted too ....

On YouTube I have given permission to autoplay (as shown in that link).

I must have totally misconstrued your question (sorry .... )

''huego [[#answer-1210736|said]]'' <blockquote> media.autoplay.enabled.user-gestures-needed - this one must be set to FALSE </blockquote> I have mine set to "true", as I don't want videos autoplaying on every site - I thought that was what you wanted too .... On YouTube I have given permission to autoplay (as shown in that link). I must have totally misconstrued your question (sorry .... )