X
點擊此處開啟此網站的行動版。

技術支援討論區

blank page

已張貼

on site polishburger.pl I have blank page. It becomes blank after it's loaded. I can click links - mouse cursor changes. Disabling hardware acceleration, safe mode, refreshing firefox, disabling tracking protection, disabling addons does not help - always page becomes blank as soon as it loads = less than 1s.

on site polishburger.pl I have blank page. It becomes blank after it's loaded. I can click links - mouse cursor changes. Disabling hardware acceleration, safe mode, refreshing firefox, disabling tracking protection, disabling addons does not help - always page becomes blank as soon as it loads = less than 1s.
引用

提出問題者

https://www.vivalapizza.pl/ is also affected

https://www.vivalapizza.pl/ is also affected
這篇文章有幫助嗎?
引用
FredMcD
  • Top 10 Contributor
4220 個解決方法 58899 個答案

I'm getting hungry.

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

I'm getting hungry. Many site issues can be caused by corrupt cookies or cache. '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}
這篇文章有幫助嗎? 0
引用

提出問題者

Does "refreshing firefox" not mean "remove cache, cookies... all except sync account" ?

Does "refreshing firefox" not mean "remove cache, cookies... all except sync account" ?
這篇文章有幫助嗎?
引用

提出問題者

Still nothing after following instructions in links

Still nothing after following instructions in links
這篇文章有幫助嗎?
引用
FredMcD
  • Top 10 Contributor
4220 個解決方法 58899 個答案

Refreshing Firefox {web link} is a LAST RESORT ! !

Refreshing Firefox -- easily fix most problems

If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its factory default state while saving your essential information like bookmarks and open tabs. Everything else, like user settings and add-ons, are removed. Note: Refresh saves your old profile to the desktop in a folder called Old Firefox.

[https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings Refreshing Firefox] {web link} is a '''LAST RESORT ! !''' Refreshing Firefox -- easily fix most problems If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its factory default state while saving your essential information like bookmarks and open tabs. Everything else, like user settings and add-ons, are removed. '''Note:''' Refresh saves your old profile to the desktop in a folder called '''Old Firefox.'''
這篇文章有幫助嗎? 0
引用
FredMcD
  • Top 10 Contributor
4220 個解決方法 58899 個答案

Are you having problems with any other website?

Are you having problems with any other website?
這篇文章有幫助嗎?
引用

提出問題者

Just these two pages so far. I tried to refresh firefox. All the steps I've found in another posts about blank pages. Refreshed firefox, then no hardware acceleration, then disabled all addons, then safe mode, then incognito mode and still blank page.

Could you check these two sites?

Just these two pages so far. I tried to refresh firefox. All the steps I've found in another posts about blank pages. Refreshed firefox, then no hardware acceleration, then disabled all addons, then safe mode, then incognito mode and still blank page. Could you check these two sites?
這篇文章有幫助嗎?
引用
FredMcD
  • Top 10 Contributor
4220 個解決方法 58899 個答案

I did and had no problem.

The next normal step is to Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

I did and had no problem. The next normal step is to Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Secure''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia
這篇文章有幫助嗎?
引用

提出問題者

Nah... "safe mode" causes more problems than it solves.

I manually removed ~/.mozilla directory and it started to work. After setting up sync it stopped working again. Yeah - it's one of addons probably... BUT I disabled all addons and the page is still blank. So it's not an addon - it's something else that is synced.

Although I tweaked in the past some flags in "about:config" but I never added any variable to syncing as it would cause problems on all of mine computers at once... and it would be hard to find out which variable caused the problem... just like now (:

So the status is: - page is not blank before sync (clean profile) - page is blank after sync (disabled all addons by hand) - page is blank on 2 of my computers (archlinux) - did not add any variables to syncing - page works for everyone else

Nah... "safe mode" causes more problems than it solves. I manually removed ~/.mozilla directory and it started to work. After setting up sync it stopped working again. Yeah - it's one of addons probably... BUT I disabled all addons and the page is still blank. So it's not an addon - it's something else that is synced. Although I tweaked in the past some flags in "about:config" but I never added any variable to syncing as it would cause problems on all of mine computers at once... and it would be hard to find out which variable caused the problem... just like now (: So the status is: - page is not blank before sync (clean profile) - page is blank after sync (disabled all addons by hand) - page is blank on 2 of my computers (archlinux) - did not add any variables to syncing - page works for everyone else
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8632 個解決方法 70597 個答案

有幫助的回覆

Hi CapSel, I am on Firefox 66, so I can't replicate your setup. If you try any of the following after the page turns white, does it make any difference?

  • Tap the Esc key
  • Change the zoom level, for example, by holding down Ctrl and tapping the + key once or twice (with Ctrl help down, tap - once or twice to zoom back out)
  • Change the shape of the tab content area, for example, by dragging the right border of the window to the left (if it's a resizable window) or by opening the Bookmarks Sidebar (Ctrl+b)
Hi CapSel, I am on Firefox 66, so I can't replicate your setup. If you try any of the following after the page turns white, does it make any difference? * Tap the Esc key * Change the zoom level, for example, by holding down Ctrl and tapping the + key once or twice (with Ctrl help down, tap - once or twice to zoom back out) * Change the shape of the tab content area, for example, by dragging the right border of the window to the left (if it's a resizable window) or by opening the Bookmarks Sidebar (Ctrl+b)
這篇文章有幫助嗎? 1
引用

提出問題者

I've disabled hardware acceleration and restarted firefox. No effects with: - esc key - zoom level by keyboard only or by ctrl+scroll - changing size/shape of window - moving tab to new window - ctrl+shift+r

I'm using Xfce without compositions in window manager - no shadows, etc

I've disabled hardware acceleration and restarted firefox. No effects with: - esc key - zoom level by keyboard only or by ctrl+scroll - changing size/shape of window - moving tab to new window - ctrl+shift+r I'm using Xfce without compositions in window manager - no shadows, etc
這篇文章有幫助嗎?
引用

提出問題者

The page is there - I can click links, cursor changes shape, I can go to menu to order... But it's all just white. Inspector from dev tools does not detect any ... layer (div/span...) on top except elements that are just there in another browser.

The page is there - I can click links, cursor changes shape, I can go to menu to order... But it's all just white. Inspector from dev tools does not detect any ... layer (div/span...) on top except elements that are just there in another browser.
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8632 個解決方法 70597 個答案

有幫助的回覆

Hmm, if you have rules out the extensions, maybe it is one of the preferences that sync'd over. It's difficult to think of a relevant one.

Does Firefox using the same Sync account work on another system, or is this Sync account just for this one system?

Hmm, if you have rules out the extensions, maybe it is one of the preferences that sync'd over. It's difficult to think of a relevant one. Does Firefox using the same Sync account work on another system, or is this Sync account just for this one system?
這篇文章有幫助嗎? 1
引用

提出問題者

Page works on iPad, Android. I have another laptop for work with my account synced and it's affected too.

Page works on iPad, Android. I have another laptop for work with my account synced and it's affected too.
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8632 個解決方法 70597 個答案

There are some sites that do a fade-in effect that sometimes fails. Yours is a bit inside out, in that the site appears and then disappears, and then doesn't reappear. If you use the Page Inspector to check the body, does it have a rule similar to:

opacity: 0

which could explain why everything in the page is rendered transparent? Assuming that is the explanation, I wonder why it is persisting?

There are some sites that do a fade-in effect that sometimes fails. Yours is a bit inside out, in that the site appears and then disappears, and then doesn't reappear. If you use the Page Inspector to check the body, does it have a rule similar to: opacity: 0 which could explain why everything in the page is rendered transparent? Assuming that is the explanation, I wonder why it is persisting?
這篇文章有幫助嗎? 1
引用

提出問題者

Nothing with "opacity" BUT... I've found that if I remove last element in body the page shows! YEAH!

But how is this possible? Here is a Node that I delete with devtools inspector:

Nothing with "opacity" BUT... I've found that if I remove last element in body the page shows! YEAH! But how is this possible? Here is a Node that I delete with devtools inspector: <div class="watermark__overlay" style="position: fixed; inset: 0px; background: rgba(0, 0, 0, 0) url(&quot;data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAAAFklEQVQ4jWP4TyFgGDVg1IBRA4aLAQBdePwusY1T3AAAAABJRU5ErkJggg==&quot;) repeat scroll 0% 0%; z-index: 5000; pointer-events: none;"></div>
這篇文章有幫助嗎?
引用

提出問題者

It filtered html

class = "watermark__overlay"

It filtered html class = "watermark__overlay"
這篇文章有幫助嗎?
引用

提出問題者

Setting "z-index" to -1000 also helps.

Setting "z-index" to -1000 also helps.
這篇文章有幫助嗎?
引用

提出問題者

background attribute of this element is set to:

rgba(0, 0, 0, 0) url("data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAAAFklEQVQ4jWP4TyFgGDVg1IBRA4aLAQBdePwusY1T3AAAAABJRU5ErkJggg==") repeat scroll 0% 0%

background attribute of this element is set to: rgba(0, 0, 0, 0) url("data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAAAFklEQVQ4jWP4TyFgGDVg1IBRA4aLAQBdePwusY1T3AAAAABJRU5ErkJggg==") repeat scroll 0% 0%
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8632 個解決方法 70597 個答案

The element has a transparent background image in front of a transparent color, so it shouldn't turn solid white. Very odd.

Does yours match mine? You can right-click > Copy > OuterHTML, then paste, then remove the angle brackets after pasting:

div class="watermark__overlay" style="position: fixed; inset: 0px; background: rgba(0, 0, 0, 0) url("data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAAAcUlEQVQ4jY2TOwIAMARD0/sfWlcqjw6G1icRSNJ5LSJORLS/7Esx3UmJFuBNIiSK0w/68q7JhDwAMXWHii246g7VFPbjo6T2TwxQ9c5ipzu2sW0cMSga/IzQLVMpMAlFI20aTGOku9BCbxTRavBzwtkucA2IhyxBxBUAAAAASUVORK5CYII=") repeat scroll 0% 0%; z-index: 5000; pointer-events: none;"

The element has a transparent background image in front of a transparent color, so it shouldn't turn solid white. Very odd. Does yours match mine? You can right-click > Copy > OuterHTML, then paste, then remove the angle brackets after pasting: div class="watermark__overlay" style="position: fixed; inset: 0px; background: rgba(0, 0, 0, 0) url(&quot;data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAAAcUlEQVQ4jY2TOwIAMARD0/sfWlcqjw6G1icRSNJ5LSJORLS/7Esx3UmJFuBNIiSK0w/68q7JhDwAMXWHii246g7VFPbjo6T2TwxQ9c5ipzu2sW0cMSga/IzQLVMpMAlFI20aTGOku9BCbxTRavBzwtkucA2IhyxBxBUAAAAASUVORK5CYII=&quot;) repeat scroll 0% 0%; z-index: 5000; pointer-events: none;"
這篇文章有幫助嗎? 1
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題