X
點擊此處開啟此網站的行動版。

技術支援討論區

Application window misrendered on macOS Mojave

已張貼

Hi. I'll try to keep this brief.

After reverting a macOS defaults command back to standard ( defaults write -g NSRequiresAquaSystemAppearance -bool No ) so that I can use the normal Mojave dark mode instead of the pre-Mojave dark mode, Firefox started displaying blank, light mode styled, context menus.

I tried all the recommended troubleshooting steps and eventually deleted all traces of Firefox, including Application Support and org.mozilla preference files. I then re-installed Firefox via a fresh download. However, the entire application is unusable, as if the OS is just not rendering the application properly.

I've uploaded a short video to demonstrate: https://imgur.com/a/DAcbL5k

Firefox works normally in a new user account I created just to test it so there is something user space level going on but I'd like to know what it could be and maybe a Moz developer would find it useful to know as well.
Hi. I'll try to keep this brief. After reverting a macOS defaults command back to standard ( defaults write -g NSRequiresAquaSystemAppearance -bool No ) so that I can use the normal Mojave dark mode instead of the pre-Mojave dark mode, Firefox started displaying blank, light mode styled, context menus. I tried all the recommended troubleshooting steps and eventually deleted all traces of Firefox, including Application Support and org.mozilla preference files. I then re-installed Firefox via a fresh download. However, the entire application is unusable, as if the OS is just not rendering the application properly. I've uploaded a short video to demonstrate: https://imgur.com/a/DAcbL5k Firefox works normally in a new user account I created just to test it so there is something user space level going on but I'd like to know what it could be and maybe a Moz developer would find it useful to know as well.
引用

額外的系統細節

已安裝的外掛程式

None, clean re-install.

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.86 Safari/537.36

更多資訊

WestEnd
  • Top 25 Contributor
61 個解決方法 5340 個答案

I tried that on Window 10 but don't see that box your showing so what addons do you have installed?

I tried that on Window 10 but don't see that box your showing so what addons do you have installed?
這篇文章有幫助嗎?
引用

提出問題者

It's a very peculiar issue that is only occurring under a single user account on my Mac.

The issue was not resolved even when doing a full reset of Mozilla, deleting all of its data and re-installing it.

I've since migrated my data into another user account but for now that broken account is still there in case a developer would like for me to run any tests that might be useful to them.

It's a very peculiar issue that is only occurring under a single user account on my Mac. The issue was not resolved even when doing a full reset of Mozilla, deleting all of its data and re-installing it. I've since migrated my data into another user account but for now that broken account is still there in case a developer would like for me to run any tests that might be useful to them.
這篇文章有幫助嗎?
引用

提出問題者

Solution

The problem is triggered by the hybrid dark mode hack or rather in how Firefox appears to be handling its presence.

The way online stories say to disable the hack is to revert it by using the command:

defaults write -g NSRequiresAquaSystemAppearance -bool No

One commentor, however, discovered that the solution was to delete the key entirely:

defaults delete -g NSRequiresAquaSystemAppearance

I've confirmed in my broken user account that deleting the key successfully repaired Firefox.

'''Solution''' The problem is triggered by the hybrid dark mode hack or rather in how Firefox appears to be handling its presence. The way online stories say to disable the hack is to revert it by using the command: defaults write -g NSRequiresAquaSystemAppearance -bool No One commentor, however, discovered that the solution was to delete the key entirely: defaults delete -g NSRequiresAquaSystemAppearance I've confirmed in my broken user account that deleting the key successfully repaired Firefox.
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題