X
點擊此處開啟此網站的行動版。

技術支援討論區

can't open links if Firefox is not already running

已張貼

Firefox Developer Edition (67.0b5) is my default browser I'm running windows 10.

if Firefox is running and i click on a link in my email, Firefox will open a new tab and show the page. if Firefox is NOT running and I click on a link, Firefox will open a blank tab; I'll have to click the link again - without closing Firefox - for the page to show.

this behavior is fairly new - about 4 updates back.

thank you;

Firefox Developer Edition (67.0b5) is my default browser I'm running windows 10. if Firefox is running and i click on a link in my email, Firefox will open a new tab and show the page. if Firefox is NOT running and I click on a link, Firefox will open a blank tab; I'll have to click the link again - without closing Firefox - for the page to show. this behavior is fairly new - about 4 updates back. thank you;

被選擇的解決方法

If you have a MOZ_NO_REMOTE environment variable then remove this variable and do not change its value to 0 because that doesn't work (Firefox checks for its existence and not the value). See "Windows Control Panel -> System"

從原來的回覆中察看解決方案 0
引用
cor-el
  • Top 10 Contributor
  • Moderator
17415 個解決方法 157316 個答案

Make sure that you do not start Firefox with the -no-remote command line switch. You can check the target line in the Firefox desktop shortcut. If you use this switch then you can't open an external link in this Firefox instance. You normally don't use this switch with the default profile, but only use it to open additional Firefox instances (or other versions) with their own profile and run them simultaneously.

Make sure that you do not start Firefox with the -no-remote command line switch. You can check the target line in the Firefox desktop shortcut. If you use this switch then you can't open an external link in this Firefox instance. You normally don't use this switch with the default profile, but only use it to open additional Firefox instances (or other versions) with their own profile and run them simultaneously. *https://developer.mozilla.org/en-US/Mozilla/Multiple_Firefox_Profiles *https://developer.mozilla.org/en-US/Command_Line_Options
這篇文章有幫助嗎?
引用

提出問題者

Thank you for the reply;

The shortcut to Firefox doesn't contain any switches, and this is the only Firefox browser on my machine.

Do you know have any more ideas on what could be going on?

thank you

Thank you for the reply; The shortcut to Firefox doesn't contain any switches, and this is the only Firefox browser on my machine. Do you know have any more ideas on what could be going on? thank you
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17415 個解決方法 157316 個答案

選擇的解決方法

If you have a MOZ_NO_REMOTE environment variable then remove this variable and do not change its value to 0 because that doesn't work (Firefox checks for its existence and not the value). See "Windows Control Panel -> System"

If you have a MOZ_NO_REMOTE environment variable then remove this variable and do not change its value to 0 because that doesn't work (Firefox checks for its existence and not the value). See "Windows Control Panel -> System"
這篇文章有幫助嗎?
引用

提出問題者

cor-el;

Thank you very much for your help, your last reply led me to look around FF, so I used the Help -> Troubleshooting information -> Refresh Firefox... and that did it!

Again, I appreciate your help. Thank you very much, Ghayth

cor-el; Thank you very much for your help, your last reply led me to look around FF, so I used the Help -> Troubleshooting information -> Refresh Firefox... and that did it! Again, I appreciate your help. Thank you very much, Ghayth
這篇文章有幫助嗎?
引用
tubascuba 1 個解決方法 8 個答案

I have iMac OSX 10.14.6 and Firefox 68.0.2. Since the last Firefox update I cannot launch external links into Firefox if Firefox is not already running. When I try to launch the link Firefox does start but only displays a blank tab. If I then click the link again (now that Firefox is running) the link works fine. Sorry but I don't understand the reference from cor-el earlier about MOZ_NO_REMOTE Firefox is my default browser. Any advice most gratefully received.

I have iMac OSX 10.14.6 and Firefox 68.0.2. Since the last Firefox update I cannot launch external links into Firefox if Firefox is not already running. When I try to launch the link Firefox does start but only displays a blank tab. If I then click the link again (now that Firefox is running) the link works fine. Sorry but I don't understand the reference from cor-el earlier about MOZ_NO_REMOTE Firefox is my default browser. Any advice most gratefully received.
這篇文章有幫助嗎?
引用
tubascuba 1 個解決方法 8 個答案

I should have read this thread more carefully! I just tried Help -> Troubleshooting information -> Refresh Firefox and it worked for me too!

Many thanks cor-el and sorry I missed that first time looking at the thread.

I should have read this thread more carefully! I just tried Help -> Troubleshooting information -> Refresh Firefox and it worked for me too! Many thanks cor-el and sorry I missed that first time looking at the thread.
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題