X
點擊此處開啟此網站的行動版。

技術支援討論區

what to do with a .swf game file

已張貼

When I tried to play a game which I've played easily on Internet Explorer and on Chrome, Firefox asks if I want to go to IE or save the file. When I selected save I didn't know where to save it. Also, why is Firefox not just playing this game?

When I tried to play a game which I've played easily on Internet Explorer and on Chrome, Firefox asks if I want to go to IE or save the file. When I selected save I didn't know where to save it. Also, why is Firefox not just playing this game?
引用

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

更多資訊

WestEnd
  • Top 25 Contributor
61 個解決方法 5340 個答案

So what site is this loading from?

So what site is this loading from?
這篇文章有幫助嗎? 1
引用
the-edmeister
  • Moderator
5391 個解決方法 40022 個答案

Firefox, Chrome, and Internet Explorer each use a different version of Flash. NPAPI for Firefox, PPAPI for Chrome, and ActiveX for IE versions of Flash.

Sounds like you don't have the NPAPI Plugin version of Flash which Firefox needs to display .swf files.

If you go here you can select the correct Plugin version manually. Select the Operating System, then select for Firefox - NPAPI/ https://get.adobe.com/flashplayer/otherversions/

Or when using Firefox go here: https://get.adobe.com/flashplayer/ but make sure you deselect the Optional offers.

Firefox, Chrome, and Internet Explorer each use a different version of Flash. NPAPI for Firefox, PPAPI for Chrome, and ActiveX for IE versions of Flash. Sounds like you don't have the '''NPAPI Plugin''' version of Flash which Firefox needs to display .swf files. If you go here you can select the correct Plugin version manually. Select the Operating System, then select '''for Firefox - NPAPI'''/ https://get.adobe.com/flashplayer/otherversions/ Or when using Firefox go here: https://get.adobe.com/flashplayer/ but make sure you deselect the '''''Optional offers'''.
這篇文章有幫助嗎? 1
引用
jscher2000
  • Top 10 Contributor
8577 個解決方法 70121 個答案

有幫助的回覆

A while back, Firefox also stopped running SWF files that did not originate from the web (http: or https: address). So that prevented playing locally saved SWF files whose addresses in the address bar start with file:/// when you open them.

This was for security reasons related to strange protocols, but if you want to turn off this protection, you could.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste https_ and pause while the list is filtered

(3) Double-click the plugins.http_https_only preference to switch the value from true to false to let Firefox run SWF files on file:/// and other non-web addresses

A while back, Firefox also stopped running SWF files that did not originate from the web (http: or https: address). So that prevented playing locally saved SWF files whose addresses in the address bar start with file:/// when you open them. This was for security reasons related to strange protocols, but if you want to turn off this protection, you could. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''https_''' and pause while the list is filtered (3) Double-click the '''plugins.http_https_only''' preference to switch the value from true to false to let Firefox run SWF files on file:/// and other non-web addresses
這篇文章有幫助嗎? 1
引用
PyGreen 1 個解決方法 9 個答案

Thank jscher2000. that's what I need.

Thank '''jscher2000'''. that's what I need.
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題