X
點擊此處開啟此網站的行動版。

技術支援討論區

Avast Security Browser Extension not staying enabled after upgrading to Firefox 66.0

已張貼

Yesterday I upgraded to the newest version of Firefox (66.0, 64-bit). I use Avast Antivirus for virus protection, and I noticed after I upgraded to the new version of Firefox and went to go online, the Avast Online Security Browser Extension showed that the automatic blocking of trackers was disabled, so I clicked More Settings and re-checked the things that were previously unchecked (the do not track boxes), afterwhich I clicked Save, and everything was A-OK.

After I was finished, I closed the page I was on.

When I went back in awhile later, the same thing occurred, and I had to do the same thing all over again.

I'm not sure what to do so I don't have to keep repeating the same process over & over again. Any help would be greatly appreciated, as I'm unsure whether this is Firefox-related or Avast-related. I did post over at Avast's forums, too.

Thanks in advance.

Yesterday I upgraded to the newest version of Firefox (66.0, 64-bit). I use Avast Antivirus for virus protection, and I noticed after I upgraded to the new version of Firefox and went to go online, the Avast Online Security Browser Extension showed that the automatic blocking of trackers was disabled, so I clicked More Settings and re-checked the things that were previously unchecked (the do not track boxes), afterwhich I clicked Save, and everything was A-OK. After I was finished, I closed the page I was on. When I went back in awhile later, the same thing occurred, and I had to do the same thing all over again. I'm not sure what to do so I don't have to keep repeating the same process over & over again. Any help would be greatly appreciated, as I'm unsure whether this is Firefox-related or Avast-related. I did post over at Avast's forums, too. Thanks in advance.
FredMcD
  • Top 10 Contributor
4246 個解決方法 59390 個答案

If this does not help, contact Avast support.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

If this does not help, contact Avast support. https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save '''Note:''' Some software, '''like''' Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

提出問題者

Hi Fred, thank you for getting back to me. I meant to mention in my original post, I did try uninstalling and re-installing Firefox, but it didn't help.

I will do as you suggested, and I will reply again with updates as to how things go.

Hi Fred, thank you for getting back to me. I meant to mention in my original post, I did try uninstalling and re-installing Firefox, but it didn't help. I will do as you suggested, and I will reply again with updates as to how things go.
jscher2000
  • Top 10 Contributor
8690 個解決方法 71037 個答案

Possibly related question: Do you use Firefox in its regular mode (remembering history) or in automatic private browsing mode ("Never remember history")?

Possibly related question: Do you use Firefox in its regular mode (remembering history) or in automatic private browsing mode ("Never remember history")?

提出問題者

jscher2000 said

Possibly related question: Do you use Firefox in its regular mode (remembering history) or in automatic private browsing mode ("Never remember history")?

Hi jscher2000. In answer to your question, I use Firefox in its regular mode.

''jscher2000 [[#answer-1206730|said]]'' <blockquote> Possibly related question: Do you use Firefox in its regular mode (remembering history) or in automatic private browsing mode ("Never remember history")? </blockquote> Hi jscher2000. In answer to your question, I use Firefox in its regular mode.
Pj 42 個解決方法 869 個答案

IwakuraLain said

Avast Security Browser Extension not staying enabled after upgrading to Firefox 66.0.

I have the Avast Online Security Extension, also. I had it Disabled for quite a while for testing. I just activated again, so I'll keep an eye on it. Did you recently Update Avast? A new version is out. (Avast Online Security was last Updated in Feb 2019.)

What are your Extensions (including any Disabled ones)?

[Image links removed by moderator. Please read Forum rules and guidelines, thanks.]

''IwakuraLain [[#question-1253696|said]]'' <blockquote> Avast Security Browser Extension not staying enabled after upgrading to Firefox 66.0. </blockquote> I have the '''Avast Online Security''' Extension, also. I had it Disabled for quite a while for testing. I just activated again, so I'll keep an eye on it. Did you recently '''Update Avast'''? A new version is out. ('''Avast Online Security''' was last Updated in Feb 2019.) What are your Extensions (including any Disabled ones)? ''[Image links removed by moderator. Please read [[Forum rules and guidelines]], thanks.]''

由 Chris Ilias 於 修改

提出問題者

Hi PJ, yes, I have the latest version of Avast on my computer, and RE extensions, the Avast Online Security Browser Extension is the only one I have.

Hi PJ, yes, I have the latest version of Avast on my computer, and RE extensions, the Avast Online Security Browser Extension is the only one I have.
Pj 42 個解決方法 869 個答案

IwakuraLain said

Hi Pj, yes, I have the latest version of Avast on my computer, and RE: Extensions, the Avast Online Security Browser Extension is the only one I have.

Ok, so far mine is still Enabled. Is yours showing Enabled when you click on 'Disabled'?

It should say 'Enabled' when it is Enabled, and it will be Disabled when it reads 'Disabled'. I know it can be taken to 'mean' the opposite. Perhaps for clarity it should have read:

"Automatic Blocking of Trackers is..."


~Pj

''IwakuraLain [[#answer-1206872|said]]'' <blockquote> Hi Pj, yes, I have the latest version of Avast on my computer, and RE: Extensions, the Avast Online Security Browser Extension is the only one I have. </blockquote> Ok, so far mine is still '''Enabled'''. Is yours showing '''Enabled''' when you click on 'Disabled'? It should say ''''Enabled'''' when it is '''Enabled''', and it will be Disabled when it reads 'Disabled'. I know it can be taken to 'mean' the opposite. Perhaps for clarity it should have read:<Br><Br>"Automatic Blocking of Trackers '''is'''..." ~Pj

提出問題者

Well, when I open up Firefox, the Avast SBE says "Automatic Blocking Of Trackers Is Disabled", and I have to manually enable it/check the boxes that normally would be checked when I click on More Settings, and I always hit "Save" afterwards.

It stays enabled while I'm using Firefox. After I'm through and close Firefox, when I go back in later on, it reverts back to saying "Automatic Blocking Of Trackers Is Disabled", and I have to enable it all over again, etc.

Well, when I open up Firefox, the Avast SBE says "Automatic Blocking Of Trackers Is Disabled", and I have to manually enable it/check the boxes that normally would be checked when I click on More Settings, and I always hit "Save" afterwards. It stays enabled while I'm using Firefox. After I'm through and close Firefox, when I go back in later on, it reverts back to saying "Automatic Blocking Of Trackers Is Disabled", and I have to enable it all over again, etc.
Pj 42 個解決方法 869 個答案

IwakuraLain said

...It stays enabled while I'm using Firefox. After I'm through and close Firefox, when I go back in later on, it reverts back to saying "Automatic Blocking Of Trackers Is Disabled", and I have to enable it all over again, etc.

Well, you have a unique problem or there's a small number of people reporting this, I guess. I closed FF and started it again and mine stays 'Enabled'.

Anyone else know what it is? Something corrupt in the FF Profile?


~Pj

''IwakuraLain [[#answer-1207049|said]]'' <blockquote> ...It stays enabled while I'm using Firefox. After I'm through and close Firefox, when I go back in later on, it reverts back to saying "Automatic Blocking Of Trackers Is Disabled", and I have to enable it all over again, etc. </blockquote> Well, you have a unique problem or there's a small number of people reporting this, I guess. I closed FF and started it again and mine stays ''''Enabled''''. Anyone else know what it is? Something corrupt in the FF Profile? ~Pj

提出問題者

I thought I would add, I did post on Avast's Support forums as well, but no one has responded to me about this particular glitch.

I thought I would add, I did post on Avast's Support forums as well, but no one has responded to me about this particular glitch.
Pj 42 個解決方法 869 個答案

IwakuraLain said

I thought I would add, I did post on Avast's Support forums as well, but no one has responded to me about this particular glitch.

Then as time passes, and no one else posting there or here about this, I'd say the problem is unique at your end. The mystery continues.


~Pj

''IwakuraLain [[#answer-1207170|said]]'' <blockquote> I thought I would add, I did post on Avast's Support forums as well, but no one has responded to me about this particular glitch. </blockquote> Then as time passes, and no one else posting there or here about this, I'd say the problem is unique at your end. The mystery continues. ~Pj