搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Need to locate in about:config, and disable, all keyboard shortcuts

  • 9 回覆
  • 4 有這個問題
  • 192 次檢視
  • 最近回覆由 jscher2000

more options

Greetings and felicitations!

Deprecating the ability to change keyboard shortcuts (read as: disable) is probably the most abhorrent thing to me about Quantum. I am sick and tired of losing work because I hit delete and Firefox randomly decides to go back a page rather than deleting a character in some text I'm writing.

Is this even possible anymore?

Please don't suggest the two addons out there that function in 65+. They simply do not function for what I need.

What I would like, if it is possible, is to know where all this is in config. I found how to disable browser.backspace_action, but I'm not sure where to look for the others.

A list would be great, or even a prefix/word to search for in config would be really helpful.

Thanks in advance for the assistance.

PS - Why does moz seem so bizarrely intent on NOT allowing users to change these?

被選擇的解決方法

youareevil said

Which extension would you recommend?

I don't use any extensions to change keyboard shortcuts, but the one that I've heard of most of is Saka Key: https://addons.mozilla.org/firefox/addon/saka-key/

從原來的回覆中察看解決方案 👍 1

所有回覆 (9)

more options

Overal keyboard shortcuts are controlled by the O/S but some can be modified.

https://support.mozilla.org/en-US/questions/1180599

more options

Sorry, I must have missed it.

There doesn't seem to be a solution there or at the links in the thread.

It's the non-OS shortcuts that I'm having problems with, but that also doesn't seem to be addressed in that thread.

Thanks.

more options

Firefox never included many preferences to disable keyboard shortcuts, but there were a couple legacy extensions (confusingly, two were both named keyconfig).

Currently, extensions can override some keyboard shortcuts by injecting a script into the page and capturing them that way. However, I don't know of a broad, general purpose extension designed for that. What have you found in your searches so far?

As an example of what a script in a page can do, try this test page before and after checking the FOR TESTING box: https://www.jeffersonscher.com/res/keyvents.html

more options

Thanks.

…and extra points for the great demo.

Which extension would you recommend?

more options

選擇的解決方法

youareevil said

Which extension would you recommend?

I don't use any extensions to change keyboard shortcuts, but the one that I've heard of most of is Saka Key: https://addons.mozilla.org/firefox/addon/saka-key/

more options

Thanks! I'll give it a try.

more options

jscher2000 said

youareevil said
Which extension would you recommend?

I don't use any extensions to change keyboard shortcuts, but the one that I've heard of most of is Saka Key: https://addons.mozilla.org/firefox/addon/saka-key/

So far so good. Saka Key seems to be doing the job.

Thanks again!

more options

yes but how to disable ALL keyboard shortcuts. saka key is confusing. I am sick of trying to type alt codes and having my browser dance all over both monitors.... for instance, try typing ALT+0244

how to disable them all? why does firefox keep getting worse? i was happily using an old version till the toolsheds forgot to renew their damn certificate...

EDIT: and i even went through, disabled all the keys, but it still seems to be using the default keys. so annoying damn...

由 backbuttonsucks 於 修改

more options

Hi backbuttonsucks, the answer is still that there is no feature to disable ALL keyboard shortcuts.

I am sick of trying to type alt codes and having my browser dance all over both monitors.... for instance, try typing ALT+0244

Hmm, what do you mean by "dance"? The Alt key isn't used to switch tabs on Windows or Mac versions of Firefox, but typing Alt + a number from 1 to 9 will change tabs on Linux. But switching among tabs within a window sounds different from what you are describing.

If this is a problem with changing tabs on Linux and you don't find a workaround on this site, try one of the following where there may be more Linux users available to respond to discussions: