搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The CONTENT BLOCKING SHIELD ICON (on my address bar) has disappeared. Is there a way to restore it?

  • 53 回覆
  • 1 有這個問題
  • 715 次檢視
  • 最近回覆由 cor-el

more options

The CONTENT BLOCKING SHIELD ICON (on my address bar) has disappeared. Is there a way to restore it? Thanks in advance.

由 oscivwar 於 修改

被選擇的解決方法

I usually miss a few things along the way!!

Thanks to both of you for trying to help the helpless!!  :)

從原來的回覆中察看解決方案 👍 0

所有回覆 (20)

more options

If you think mixed active content blocking is not working on your Firefox, you could check here to make sure it hasn't been turned off:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste mix and pause while the list is filtered

(3) If the security.mixed_content.block_active_content preference is set to false instead of true, try double-clicking it to restore the normal behavior. If the status is "locked" and you can't re-enable it, that could indicate malware or an unwanted "autoconfig" file that we can help you investigate.

more options

You only see this icon if you are on a website where Firefox is blocking content due to Content Blocking settings.

Also check that Content Blocking is still enabled.

more options

Completed all of the above (to the best of my ability)... Still no SHIELD ICON... :(

more options

Thank you...

more options

Just wondering if a CLEAN INSTALL of FIREFOX would work??

more options

Tried a CLEAN INSTALL of FIREFOX to no avail.

more options

oscivwar said

The CONTENT BLOCKING SHIELD ICON (on my address bar) has disappeared.

Hello oscivwar,

Is this on one particular site  ?

You do know that when there is no blockable content, the shield icon won't appear, don't you  ? (also see cor-el's post)

If this is on one particular site, would you check what it says about content blocking when you click on the little 'i' in a circle, next to the padlock  ?

more options

It (the SHIELD) never shows. Thanks for asking.

Below the "i" It says SECURE CONNECTION, that there there is BLOCKABLE CONTENT and there is a PERMISSIONS line. Some sites show that POPUPS are allowed.

Thanks...

more options

It does not allow me to turn off blocking...

more options

oscivwar said

Below the "i" It says SECURE CONNECTION, that there there is BLOCKABLE CONTENT and there is a PERMISSIONS line.

Next to 'Blockable content detected on this site' - does it say 'Standard', 'Strict' or 'Custom'  ? (there's a gear next to it) You're sure you have set content blocking the way you want it  ? (again : see cor-el's post)

Some sites show that POPUPS are allowed.

That has nothing to do with the shield icon, though ..... ;)


What puzzles me though, is the fact that in your original post you say that the shield icon has disappeared - which suggests that maybe you changed the content blocking settings somehow ...... (?)

more options

Not that I am aware. It shows on my other computer and they are synced.

more options

Everything else seems just fine.

more options

CONTENT BLOCKING is set to STANDARD but it doesn't seem to be blocking anything.

more options

oscivwar said

CONTENT BLOCKING is set to STANDARD but it doesn't seem to be blocking anything.

'Standard' only blocks known trackers in private windows .....

I really think that maybe you should read that article again :

https://support.mozilla.org/en-US/kb/content-blocking

Here, on this site (support.mozilla.org), when you have chosen 'Standard' you will see 'Blockabale content detected on this site' as well .....


But I'm still wondering about your original post, in which you mention that the shield icon has disappeared. On which site  ? Did you used to see that shield icon on every site you visit  ?

more options

Not sure, but it isn't showing up at all / anywhere now. The 'site information' circle is there.

more options

oscivwar said

Not sure, but it isn't showing up at all / anywhere now.

If that shield icon used to be there, then all I can think of is that you somehow changed your content blocking settings, and probably don't remember (or realizing) doing it.

I don't think that you have anything to worry about - if your content blocking settings are the way you want them to be, then apparantly there is no need for that shield icon to appear.

The 'site information' circle is there.

You're talking about the little 'i' in a circle : clicking on that will open the Control Center :

https://support.mozilla.org/en-US/kb/control-center-site-privacy-and-security-firefox

more options

Thank you...

more options

oscivwar said

Thank you...

My pleasure  !

(I hope this means that your mind has been set at ease ...... )

more options

Never... :)

more options

oscivwar said

Never... :)

Aww, what can we do to make that happen  ?

(never say "Never" ..... )

  1. 1
  2. 2
  3. 3