搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

cant find inspect on right click menu

  • 16 回覆
  • 1 有這個問題
  • 114 次檢視
  • 最近回覆由 SamadhiGhosh

more options

on doing right click, I cant find the inspect element on it. Is there some problem with the current version of Mozilla?

所有回覆 (16)

more options

It is possible to disable the developer tools via GPO or a policies.json file.

You can check the about:policies#active page to see whether policies are active.

more options

cor-el said

It is possible to disable the developer tools via GPO or a policies.json file. You can check the about:policies#active page to see whether policies are active.

Hey thanks for sharing the policy-template link but I did not find any policy that covered disabling inspect element option in Mozilla. I searched for syntax to enable inspect option but couldn't find one. Can you help here?

由 SamadhiGhosh 於 修改

more options

Do you see all developer tools present in the Web Developer menu (Tools -> Web Developer) and in the developer toolbar button drop-down list?

more options

cor-el said

Do you see all developer tools present in the Web Developer menu (Tools -> Web Developer) and in the developer toolbar button drop-down list?

No @cor-el. I do not find the web-developer option in tool menu. Do you know how to make it visible?

more options

SamadhiGhosh said

I do not find the web-developer option in tool menu.

Does it come up with using the keys of Control+SHIFT+C?


~Pj

more options

Pj said

SamadhiGhosh said
I do not find the web-developer option in tool menu.

Does it come up with using the keys of Control+SHIFT+C?


~Pj

Hey PJ, I tried Ctrl+Shift+C but didnt work. PFA screenshot.

more options

SamadhiGhosh said

I tried Ctrl+Shift+C but didn't work. PFA screenshot.

Do you have FF 65.0.1? Though I'd figure FF 64 would have Web Developer in there, also. Is this a 'special' FF version vs the 'standard' public version?


~Pj

more options

Pj said

SamadhiGhosh said
I tried Ctrl+Shift+C but didn't work. PFA screenshot.

Do you have FF 65.0.1? Though I'd figure FF 64 would have Web Developer in there, also. Is this a 'special' FF version vs the 'standard' public version?


~Pj

Hi PJ,

It's FF 64. I have attached screenshot of the version.

more options

Enter about:policies in the URL bar and paste here its content.

more options

TyDraniu said

Enter about:policies in the URL bar and paste here its content.

Hello @tyDranu,

I found out that the value for DisableDeveloperTool is set to true. PFA screenshot of the same.

more options

This is what I found in omni.ja file:

removeDevToolsMenus(window) {

   // This will hide the "Tools > Web Developer" menu.
   window.document.getElementById("webDeveloperMenu").setAttribute("hidden", "true");
   // This will hide the "Web Developer" item in the hamburger menu.
   window.document.getElementById("appMenu-developer-button").setAttribute("hidden",
     "true");
 },

And when I searched for getElementById, I found multiple instances in the very same file with respective attributes having hidden = true

由 SamadhiGhosh 於 修改

more options

Open the New Tab page by clicking the + button on the tab strip.

   Click on one of the blank images to open the corresponding website.
   Important: Let the website finish loading (wait for the spinning blue loading icon in the tab to stop).
   Open the New Tab page again and you will see a new image for the website you just went to.
   Repeat this process for the rest of the missing images.
more options

Like I wrote above, you have some policies active and one disables the developer tools.

If you do not have a policies.json file in the distribution folder then check this Windows Registry key. It is likely that your IT department (or less likely some security software) has added these policies, so you would have to contact them if you have a question.

You can inspect the Mozilla and Firefox keys in this location to see what policies are active:

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\
  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox
more options

cor-el said

Like I wrote above, you have some policies active and one disables the developer tools. If you do not have a policies.json file in the distribution folder then check this Windows Registry key. It is likely that your IT department (or less likely some security software) has added these policies, so you would have to contact them if you have a question. You can inspect the Mozilla and Firefox keys in this location to see what policies are active:
  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\
  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox

Hey cor-el, You are right. I am sure the webdeveloper tool has been disabled by the security team. I have raised a ticket already to get this solved.

Thanks everyone for your valuable time and help.

Have a great day!

more options
more options

cor-el said

Did you miss this:
Nope. I did went through the URL that you have sent me in the beginning but I was not able to find the exact attribute which has kept webdeveloper tool disabled. Later I found out that omni.ja could be opened in Notepad++ and that's when things became more clearer.