搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Cannot access my homepage without jumping through a hoop

  • 7 回覆
  • 1 有這個問題
  • 57 次檢視
  • 最近回覆由 FredMcD

more options

If I open Firefox my custom homepage opens appropriately.

However, when I close out firefox and then re-open the browser I get the following message:

"We are having trouble restoring your last browsing session. Select Restore Session to try again.

Still not able to restore your session? Sometimes a tab is causing the issue. View previous tabs, remove the checkmark from the tabs you don’t need to recover, and then restore."

Clicking the "restore session" button gets me to the homepage. What do I need to do to be able to open firefox and go to my homepage on startup of the browser each time that I want to use Firefox instead of having to restore the session? Thanks.

被選擇的解決方法

Type about:preferences#general<enter> in the address bar. [v63+] Type about:preferences#home

There are two settings;

  • When Firefox Starts

When the browser is started, what do you want to display? Many of us choose Show My Home Page.

  • Home Page

When a new page is opened, what do you want to be displayed?

  1. Use Current Page. Use what ever page(s) are open at that time.
  2. Use Bookmark
  3. Restore To Default. about:home shows a Mozilla home page with tools.

You can use any of these that you wish;

about:home (Firefox default home page), about:newtab (shows the sites most visited), about:blank (a blank page),

or you can enter any webpage or about: page you want.

從原來的回覆中察看解決方案 👍 0

所有回覆 (7)

more options

You may have corrupt sessionstore [v56] sessionstore.jsonlz4 file(s). Delete all sessionstore* files and the sessionstore-backups folder.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Locate the above file. Then rename or delete it. Restart Firefox.


Don't delete the files if you need to rescue any data from them, just move them out of the profile folder to some location where Firefox doesn't look for them. You can try to read out their contents using this tool: https://www.jeffersonscher.com/res/scrounger.html

more options

Thank you for your solution idea.

I deleted the sessionstore.jsonlz4 and sessionstore backup folder. This worked temporarily for a couple of times opening the homepage and then unfortunately reverted back to requiring the restore session button to reopen the homepage. So not a permanent fix.

more options

I had that same issue but this was from restoring a working image and it would say the same message. Far past firefox browser didn't do this it was more recent with the later Quantum firefox versions.

more options

選擇的解決方法

Type about:preferences#general<enter> in the address bar. [v63+] Type about:preferences#home

There are two settings;

  • When Firefox Starts

When the browser is started, what do you want to display? Many of us choose Show My Home Page.

  • Home Page

When a new page is opened, what do you want to be displayed?

  1. Use Current Page. Use what ever page(s) are open at that time.
  2. Use Bookmark
  3. Restore To Default. about:home shows a Mozilla home page with tools.

You can use any of these that you wish;

about:home (Firefox default home page), about:newtab (shows the sites most visited), about:blank (a blank page),

or you can enter any webpage or about: page you want.

more options

This does not change anything. My homepage is set as a custom URL of my choice as it always has.

Deleting the sessionstore files/folder again allows me to open to my homepage one time and then it reverts to the page which says that I need to restore session when I close and try to reopen the browser again.

I'm looking for an alternative browser as I just would like to land on a home page when opening up the browser. Seems simple enough.

All worked fine until the recent upgrade.

more options

I was able to solve this issue by doing two things:


Open firefox profile. Find prefs file Right click on the prefs file. Properties were checked as hidden. Unchecked that.

In address bar: about:preferences#privacy checked "clear history on close"

more options

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.