X
點擊此處開啟此網站的行動版。

技術支援討論區

Wrong browser language detected

已張貼

Hello, I have Windows 7 in Italian and Firefox 65.0 (64 bit) in Italian but often sites detect my browser to be in French. French is among the Languages I've added but is not configured as first, see attached image. Please also see about:support Internationalization and localization as attached image.

https://web.whatsapp.com/ is among the sites that show me French text, if I open the HTML code it shows me This problem has been affecting Firefox since at least 2015. Thanks Frank

Hello, I have Windows 7 in Italian and Firefox 65.0 (64 bit) in Italian but often sites detect my browser to be in French. French is among the Languages I've added but is not configured as first, see attached image. Please also see about:support Internationalization and localization as attached image. https://web.whatsapp.com/ is among the sites that show me French text, if I open the HTML code it shows me <html class="no-js" dir="ltr" loc="fr"> This problem has been affecting Firefox since at least 2015. Thanks Frank
附加的畫面擷圖

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

更多資訊

cor-el
  • Top 10 Contributor
  • Moderator
17346 個解決方法 156810 個答案

You can check the installed languages and their order.

  • Options/Preferences -> General -> Languages
You can check the installed languages and their order. *Options/Preferences -> General -> Languages

提出問題者

Hello cor-el, did you see the image I attached? It shows Options/Preferences -> General -> Languages.

Please note this language issue is happening on many different computers with Windows in Italian and Firefox.

I believe [it-it] in first position gets ignored. Furthermore [en-us] in second position gets ignored.

Thanks

Hello cor-el, did you see the image I attached? It shows Options/Preferences -> General -> Languages. Please note this language issue is happening on many different computers with Windows in Italian and Firefox. I believe [it-it] in first position gets ignored. Furthermore [en-us] in second position gets ignored. Thanks
WestEnd
  • Top 25 Contributor
61 個解決方法 5340 個答案

Did you remove the other language options to see what happens?

Did you remove the other language options to see what happens?
cor-el
  • Top 10 Contributor
  • Moderator
17346 個解決方法 156810 個答案

Did you try to remove the first [it-it] entry and move the last Italiano [it] item to the top? Note that websites might not support Italian and fallback to another language in the list.

You can also try to start with a fresh list and ad the languages via the Add button in case the current setting is no longer compatible with the Firefox version you use.

Did you try to remove the first [it-it] entry and move the last Italiano [it] item to the top? Note that websites might not support Italian and fallback to another language in the list. You can also try to start with a fresh list and ad the languages via the Add button in case the current setting is no longer compatible with the Firefox version you use.

提出問題者

WestEnd said

Did you remove the other language options to see what happens?

Yes. [it-it], which is the standard configuration on all Windows Italian computers, gets ignored. Inglese (Stati Uniti) [en-us] gets ignored. Italian or French get picked only when [it] or [fr] are selected.

''WestEnd [[#answer-1193617|said]]'' <blockquote> Did you remove the other language options to see what happens? </blockquote> Yes. '''[it-it]''', which is the standard configuration on all Windows Italian computers, gets ignored. '''Inglese (Stati Uniti) [en-us]''' gets ignored. Italian or French get picked only when [it] or [fr] are selected.

由 _FrankMasta_ 於 修改

提出問題者

cor-el said

Did you try to remove the first [it-it] entry and move the last Italiano [it] item to the top? Note that websites might not support Italian and fallback to another language in the list. You can also try to start with a fresh list and ad the languages via the Add button in case the current setting is no longer compatible with the Firefox version you use.

As you suggest I can use a fresh list and solve the issue. But since this is happening on all Italian Windows machines I wanted to address the problem.

Please take a look at the attached image, [en-us] gets ignored and WhatsApp site gets displayed in French.

''cor-el [[#answer-1193834|said]]'' <blockquote> Did you try to remove the first [it-it] entry and move the last Italiano [it] item to the top? Note that websites might not support Italian and fallback to another language in the list. You can also try to start with a fresh list and ad the languages via the Add button in case the current setting is no longer compatible with the Firefox version you use. </blockquote> As you suggest I can use a fresh list and solve the issue. But since this is happening on all Italian Windows machines I wanted to address the problem. Please take a look at the attached image, [en-us] gets ignored and WhatsApp site gets displayed in French.