搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox closes itself randomly on page loads

  • 10 回覆
  • 2 有這個問題
  • 1174 次檢視
  • 最近回覆由 wtoalabi

more options

Since the start of Firefox Quantum release, when I returned to Firefox I've had issues with Firefox closing itself randomly on page loads - sometimes it can happen right after I start browser, sometimes once a day, completely random, haven't noticed any patterns.

I've tried to google and look into this forums, I've seen people reporting similar issues (but not lately) and I've tried various fixes suggested here and there, for example:

- Disabling all extensions

- Disabling Hardware Acceleration

- Reseting my profile

- Reinstalling Firefox

- Heck I've even reinstalled my Windows


Not once has the closing triggered crash report.

I don't have any similar issues with any other software on my computer so it must be something Firefox specific. I've monitored my PC resource usage, thought maybe somehow it hogs up all my CPU, RAM or disk and that makes it close - nope, same haeppens even when CPU usage is 20%, RAM 12 of 32GB, disk 0-5% (SSDs) etc.

Honestly I'm out of ideas what to try and if we somebody can't help me find a solution I sadly may have to abandon Firefox once again (which I really would not like to do)

由 kerts93 於 修改

被選擇的解決方法

FredMcD said

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.

What theme are you using?

Built in dark them. However I think I fiqured out, which extension is casusing this: 1Password (desktop app version). It seems disabling this is making things behave normally.

從原來的回覆中察看解決方案 👍 0

所有回覆 (10)

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

FredMcD said

Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

In that case looks like the problem wasn't there. So I guess that means the issue lies in some kind of extension/addon?

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

FredMcD said

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link} Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A) In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox. Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them. If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

If you read the original post, already tried that. Just to be sure I'm now trying to disable/enable all addons 1-by-1 to see if anything changes. So far I've gone through most of the list, no success so far.

more options

Okay, looks like I found the bugger, not sure why disabling this extension before didn't help, but for now I've gone without crashes.

Looks like this was the cause: https://addons.mozilla.org/en-US/firefox/addon/floccus/

more options

kerts93 said

Okay, looks like I found the bugger, not sure why disabling this extension before didn't help, but for now I've gone without crashes. Looks like this was the cause: https://addons.mozilla.org/en-US/firefox/addon/floccus/

Nvm, as soon as I posted this the issue returned

more options

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.


What theme are you using?

more options

選擇的解決方法

FredMcD said

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.

What theme are you using?

Built in dark them. However I think I fiqured out, which extension is casusing this: 1Password (desktop app version). It seems disabling this is making things behave normally.

more options

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

more options

A window user here with the same issue. Plus the fact that the Recently Closed Tabs are always empty when I restart the browser. At least, I should have a way to repopulate all the abruptly closed tabs instead of scouring through the history and opening them one by one. I am a web dev and I just moved from chrome because of its heavy usage of memory and I am enjoying Firefox as a better alternative. I also have Nightly and Dev version with the same experience. Please help ship a fix. Thanks!