X
點擊此處開啟此網站的行動版。

技術支援討論區

Ctrl-K puts a question mark in the "awesome bar"

已張貼

This morning I brought up Firefox on my Win10 64 system as I always do, and immediately hit "ctrl-k" to get the cursor into the "awesome bar" (which is set to all three tick boxes in the privacy & security -> address bar settings.) Usually I enter shortcuts (set in bookmarks, like 'gm' for mail.google.com) so that I don't have to type in the full address. However that didn't work today because every time I hit "ctrl-k" a question mark automatically appears in the "awesome bar". It will search just fine but if I want to go to a web site or use a short cut I have to backspace over the question mark or it will just search for what I'm typing in. I tried clearing everything (ctrl-shift-del, tick all boxes, "for all time") and still the problem persists. I also unchecked all three tick boxes in Privacy & Security -> Address bar and it still happens. Disabled all addons and problem persists. Help! This is seriously getting in the way of my work flow. Please let me know if there's any information that you need. I consider myself a power user so don't be afraid to dive into the weeds if need be.

Thanks!


and I see that it's running 65.0 (new version?).

This morning I brought up Firefox on my Win10 64 system as I always do, and immediately hit "ctrl-k" to get the cursor into the "awesome bar" (which is set to all three tick boxes in the privacy & security -> address bar settings.) Usually I enter shortcuts (set in bookmarks, like 'gm' for mail.google.com) so that I don't have to type in the full address. However that didn't work today because every time I hit "ctrl-k" a question mark automatically appears in the "awesome bar". It will search just fine but if I want to go to a web site or use a short cut I have to backspace over the question mark or it will just search for what I'm typing in. I tried clearing everything (ctrl-shift-del, tick all boxes, "for all time") and still the problem persists. I also unchecked all three tick boxes in Privacy & Security -> Address bar and it still happens. Disabled all addons and problem persists. Help! This is seriously getting in the way of my work flow. Please let me know if there's any information that you need. I consider myself a power user so don't be afraid to dive into the weeds if need be. Thanks! and I see that it's running 65.0 (new version?).
user1929 72 個解決方法 290 個答案

I think this is an intentional change (although I haven't been able to find any information about it). Previously (before Firefox 57), ctrl+k would focus the separate search box, which would only allow you to search and not to search history. The new "?" prefix in the url bar matches this old behavior - it will open a search results page, even if what you typed is a URL.

I'm not aware of any way to turn this off, but you could also use the ctrl+L shortcut, which focuses the address bar without adding a prefix.

I think this is an intentional change (although I haven't been able to find any information about it). Previously (before Firefox 57), ctrl+k would focus the separate search box, which would only allow you to search and not to search history. The new "?" prefix in the url bar matches this old behavior - it will open a search results page, even if what you typed is a URL. I'm not aware of any way to turn this off, but you could also use the ctrl+L shortcut, which focuses the address bar without adding a prefix.

提出問題者

Thanks for the info. If this is the new default for Firefox then I'm saddened. I guess I'll just get used to ctrl-L.

Thanks for the info. If this is the new default for Firefox then I'm saddened. I guess I'll just get used to ctrl-L.
cor-el
  • Top 10 Contributor
  • Moderator
17516 個解決方法 158398 個答案

You can add the regular search bar to the Navigation Toolbar or to the overflow area (>>) to make Ctrl+K focus this search bar instead of the location bar and avoid getting the '?'.

You can add the regular search bar to the Navigation Toolbar or to the overflow area (>>) to make Ctrl+K focus this search bar instead of the location bar and avoid getting the '?'.