X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox removes spaces as I type

已張貼

Starting 3-4 days ago, I can't type reliably on 1 specific website: - on any page on this website (CVMG.ca), I type a word, hit space, then start another word the space is removed and the words join together - if I add 2-3 more spaces, the same thing happens - all the spaces are removed when I start typing the next word - if I hold down the space bar and let auto-space insert (6-8 spaces), the next word types correctly (no spaces are removed) - this occurs when using Firefox 64.0.2 on a Mac running OS X 10.14.2 - it seems to happen only on one website - I can enter words on other sites on this browser (such as what I'm typing now) - Typing works normally when I access the website from Safari. - There's a similar problem described on github for Firefox support that relates to a change in CSS. - see attached screenshot - t shows a reply typed into a general forum gadget, but the same thing happens when I type into any other entry space on that website. - I have filed a similar trouble ticket with the web hosting service

Starting 3-4 days ago, I can't type reliably on 1 specific website: - on any page on this website (CVMG.ca), I type a word, hit space, then start another word the space is removed and the words join together - if I add 2-3 more spaces, the same thing happens - all the spaces are removed when I start typing the next word - if I hold down the space bar and let auto-space insert (6-8 spaces), the next word types correctly (no spaces are removed) - this occurs when using Firefox 64.0.2 on a Mac running OS X 10.14.2 - it seems to happen only on one website - I can enter words on other sites on this browser (such as what I'm typing now) - Typing works normally when I access the website from Safari. - There's a similar problem described on github for Firefox support that relates to a change in CSS. - see attached screenshot - t shows a reply typed into a general forum gadget, but the same thing happens when I type into any other entry space on that website. - I have filed a similar trouble ticket with the web hosting service
附加的畫面擷圖

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • Firefox 64.0.2
  • 使用者代理:Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:64.0) Gecko/20100101 Firefox/64.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/64.0.2/Darwin/en-CA/

擴充套件

  • Clear Cache 3.1 (clearcache@michel.de.almeida)
  • Ghostery – Privacy Ad Blocker 8.3.0 (firefox@ghostery.com)
  • Grammarly for Firefox 8.842.2006 (87677a2c52b84ad3a151a4a72f5bd3c4@jetpack)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription:
  • adapterDeviceID: 0x0166
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • contentUsesTiling: True
  • crashGuards: []
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'opt-in', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'TileHeight': 1024, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 1024, u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 3
  • usesTiling: True
  • webgl1DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
  • webgl1Version: 4.1 INTEL-12.4.7
  • webgl1WSIInfo: CGL
  • webgl2DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
  • webgl2Renderer: Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
  • webgl2Version: 4.1 INTEL-12.4.7
  • webgl2WSIInfo: CGL
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL
  • windowUsingAdvancedLayers: False

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
WestEnd
  • Top 25 Contributor
60 個解決方法 5376 個答案

Since that is a login site until someone with that account using firefox to test that is the only way to find what happens.

Since that is a login site until someone with that account using firefox to test that is the only way to find what happens.
FredMcD
  • Top 10 Contributor
4229 個解決方法 59020 個答案

That is very odd. I might suspect malware if this happens on other websites.

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

That is very odd. I might suspect malware if this happens on other websites. Many site issues can be caused by corrupt cookies or cache. '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}

提出問題者

Um, sorry. Try this: - login to cvmg.ca as test@cvmg.ca password is firefoxtest - in the left side menu, click Firefox test - it has a test forum page with freeform text you can use to re-create the problem - click Create topic and give it a try

while preparing this test, it seems that only freeform text on this website is affected. So, typing something into the Subject line behaves correctly, but typing in the freeform text box removes spaces as I type.

Um, sorry. Try this: - login to cvmg.ca as test@cvmg.ca password is firefoxtest - in the left side menu, click Firefox test - it has a test forum page with freeform text you can use to re-create the problem - click Create topic and give it a try while preparing this test, it seems that only freeform text on this website is affected. So, typing something into the Subject line behaves correctly, but typing in the freeform text box removes spaces as I type.

提出問題者

FredMcD said

That is very odd. I might suspect malware if this happens on other websites. Many site issues can be caused by corrupt cookies or cache. Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website. If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. How to disable Hardware Acceleration {web link}

I tried Safe mode and graphics hardware acceleration suggestions, the results don't vary (I ran tests for each case you can see results on the test page described above). I cleared cache before posting the original problem, then several times throughout these threads. No improvement.

I am reluctant to wipe all cookies as there's lots of good stuff there. Maybe I'll try to backup things first.

I didn't mention that this problem occurs on 2 Macs both running the latest OS X release. Oh, and 2 extensions (Ghostery and Grammarly) are installed but disabled.

''FredMcD [[#answer-1191901|said]]'' <blockquote> That is very odd. I might suspect malware if this happens on other websites. Many site issues can be caused by corrupt cookies or cache. '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} </blockquote> I tried Safe mode and graphics hardware acceleration suggestions, the results don't vary (I ran tests for each case you can see results on the test page described above). I cleared cache before posting the original problem, then several times throughout these threads. No improvement. I am reluctant to wipe all cookies as there's lots of good stuff there. Maybe I'll try to backup things first. I didn't mention that this problem occurs on 2 Macs both running the latest OS X release. Oh, and 2 extensions (Ghostery and Grammarly) are installed but disabled.
FredMcD
  • Top 10 Contributor
4229 個解決方法 59020 個答案

Access denied (error 403)

Access denied (error 403)

提出問題者

FredMcD said

Access denied (error 403)

Yup. Just click on the Test forum menu item anyway and all should be good.

''FredMcD [[#answer-1191958|said]]'' <blockquote> Access denied (error 403) </blockquote> Yup. Just click on the Test forum menu item anyway and all should be good.
FredMcD
  • Top 10 Contributor
4229 個解決方法 59020 個答案
https://cvmg.ca/Firefox-Test-Page/7134206

提出問題者

Thanks for confirming my problem FredMcD. I also opened a ticket with the service used to host the cvmg.ca site. They say they are investigating and it is likely their problem.

Thanks for confirming my problem FredMcD. I also opened a ticket with the service used to host the cvmg.ca site. They say they are investigating and it is likely their problem.