搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

content process limit

  • 5 回覆
  • 1 有這個問題
  • 1 次檢視
  • 最近回覆由 hake

more options

I have a system with a 2 core processor, an Intel P4 3.2GHz. I cannot set a content process limit of 2 so I have to accept a single process incarnation of Firefox (60.4.0 ESR, 64bit). Is this intentional or is the minimum number of processor cores required to be at least 4.

I have a system with a 2 core processor, an Intel P4 3.2GHz. I cannot set a content process limit of 2 so I have to accept a single process incarnation of Firefox (60.4.0 ESR, 64bit). Is this intentional or is the minimum number of processor cores required to be at least 4.

被選擇的解決方法

This may be a stupid question, but you have multiprocess enabled right?

To check, do the following:

  1. Type about:config in the Firefox address bar
  2. Bypass the security warning
  3. Find browser.tabs.remote.autostart (there may be multiple)
  4. Set them all to true
  5. Restart Firefox.
從原來的回覆中察看解決方案 👍 1

所有回覆 (5)

more options

You can set the content process limit to between 1 and 8. The default is 4, but you should be able to change this.

Go to the Firefox settings and go to the Performance section. Uncheck the Use recommended performance settings option and there you will find the content process limit setting.

If that content process limit setting appears locked, go to about:config in the Firefox address bar, bypass the warning and change the value of dom.ipc.processCount to anything between 1-8.

Hope this helps.

more options

Thank you Wesley. I am sorry to tell you that after changing dom.ipc.processCount to 2 in about:config, the content process limit remained grayed and unresponsive. although it did show the altered value of dom.ipc.processCount.

TaskManager still shows firefox.exe as a single process.

It wasn't long ago that Firefox 60 ESR ran with 4 processes regardless of the number of processor cores so something seems to have been changed in Firefox, it appears. Firefox will run 4 processes on a machine with a processor with 4 cores.

more options

I seem to have posted two replies so have erased the second of them.

由 hake 於 修改

more options

選擇的解決方法

This may be a stupid question, but you have multiprocess enabled right?

To check, do the following:

  1. Type about:config in the Firefox address bar
  2. Bypass the security warning
  3. Find browser.tabs.remote.autostart (there may be multiple)
  4. Set them all to true
  5. Restart Firefox.
more options

The grayed out bits are now accessible. Back to where I thought I was. I don't remember making changes to those settings.

Anyhow, thank you very much Wesley. I would never have guessed that solution.