X
點擊此處開啟此網站的行動版。

技術支援討論區

Following RSS links in Macbook Firefox 64.0 often results in redirects and multiple blank windows

已張貼

The subject pretty well describes the issue. I have to *quickly* force close, restart Firefox and restore windows, with the multiple blank windows unchecked.

I have viewed probably thousands of RSS links without issue before this version.

I only see the issue with RSS links but not all of them Maybe this sort of html is causing the problem: <atom:link href="https://www.easternherald.com/feed/" rel="self" type="application/rss+xml" /> I can see no other redirect code, and this type of code seems to be a common factor.

All dodgy links work fine with MSIE under Windows.


FIrefox 64.0 Quantum Macbook Pro 15" mid 2018 - macOS 10.14.2 (18C54)

The subject pretty well describes the issue. I have to *quickly* force close, restart Firefox and restore windows, with the multiple blank windows unchecked. I have viewed probably thousands of RSS links without issue before this version. I only see the issue with RSS links but not all of them Maybe this sort of html is causing the problem: <atom:link href="https://www.easternherald.com/feed/" rel="self" type="application/rss+xml" /> I can see no other redirect code, and this type of code seems to be a common factor. All dodgy links work fine with MSIE under Windows. FIrefox 64.0 Quantum Macbook Pro 15" mid 2018 - macOS 10.14.2 (18C54)

被選擇的解決方法

As I said earlier I successfully re-directed xml files to open with Safari. I have just upgraded to 64.0.2 Firefox. Bizarrely (fortunately) it now ignores this, and xml pages are now opening and displaying correctly in Firefox, without infinite re-direction loops (as they previously did for many years).

Look like it was a bug, and now cured.

Phew - it will save me a great deal of time.

從原來的回覆中察看解決方案 0

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:64.0) Gecko/20100101 Firefox/64.0

更多資訊

提出問題者

Sorry for the bad formatting, but not my fault. Unless there is a completely blank line the editor concatenates.

In particular the last lines should be:

FIrefox 64.0 Quantum

Macbook Pro 15" mid 2018 - macOS 10.14.2 (18C54)

Sorry for the bad formatting, but not my fault. Unless there is a completely blank line the editor concatenates. In particular the last lines should be: FIrefox 64.0 Quantum Macbook Pro 15" mid 2018 - macOS 10.14.2 (18C54)

提出問題者

.... and of course I should have said this is an example of a non-working link:

https://www.easternherald.com/feed/

Do *not* link to it unless you have a 'force close' window for Firefox ready (8-)#

.... and of course I should have said this is an example of a non-working link: https://www.easternherald.com/feed/ Do *not* link to it unless you have a 'force close' window for Firefox ready (8-)#

由 tonyfirshman 於 修改

AliceWyman
  • Moderator
240 個解決方法 2594 個答案

有幫助的回覆

Firefox 64 can no longer handle RSS feeds such as the example link you posted. See Feed reader replacements for Firefox for more information.

When I click on https://www.easternherald.com/feed/ in Firefox 64 I see an Opening dialog box, asking me what to do with the file:

Fx64OpeningDialog-RSS+xml

You must have chosen to open the link with Firefox, which would cause the continuous loop you describe. See this article for possible solutions: Firefox repeatedly opens empty tabs or windows after you click on a link

Firefox 64 can no longer handle RSS feeds such as the example link you posted. See [[Feed reader replacements for Firefox]] for more information. When I click on https://www.easternherald.com/feed/ in Firefox 64 I see an Opening dialog box, asking me what to do with the file: ;[[Image:Fx64OpeningDialog-RSS+xml]] You must have chosen to open the link with Firefox, which would cause the continuous loop you describe. See this article for possible solutions: [[Firefox repeatedly opens empty tabs or windows after you click on a link]]

提出問題者

I had not changed the default - it said 'Always ask' but it never did. I was opening an XML link in my own code using 'target=_blank" ' . That sounds like a bug.

Oddly there are two entries for 'XML file' in the configuration dropdown. I presume only the first is used. The second links to 'UP Studio' - a 3D design program. I can see no way to delete the second.

Not perfect, but I have set xml files to open using Safari. In previous versions, the xml page would parse and show correctly under FIrefox. Under Safari it goes straight to code.

I link to hundreds of these files each week as part of my work, so this workaround, although not perfect, will save me a great deal of time. As I could never be sure of a crash, I was forced to copy *every* link and paste in Safari.

Many thanks.

I hope in future versions, xml pages will be handled as they used to be. Why was this removed I wonder?

I had not changed the default - it said 'Always ask' but it never did. I was opening an XML link in my own code using 'target=_blank" ' . That sounds like a bug. Oddly there are two entries for 'XML file' in the configuration dropdown. I presume only the first is used. The second links to 'UP Studio' - a 3D design program. I can see no way to delete the second. Not perfect, but I have set xml files to open using Safari. In previous versions, the xml page would parse and show correctly under FIrefox. Under Safari it goes straight to code. I link to hundreds of these files each week as part of my work, so this workaround, although not perfect, will save me a great deal of time. As I could never be sure of a crash, I was forced to copy *every* link and paste in Safari. Many thanks. I hope in future versions, xml pages will be handled as they used to be. Why was this removed I wonder?
AliceWyman
  • Moderator
240 個解決方法 2594 個答案

The two entries for 'XML file' in Firefox preferences under Applications is probably because they have different MIMEtypes, for example, one for application/rss+xml and a different one for application/xml Ref: https://validator.w3.org/feed/docs/warning/UnexpectedContentType.html (quote) RSS feeds should be served as application/rss+xml (RSS 1.0 is an RDF format, so it may be served as application/rdf+xml instead). Atom feeds should use application/atom+xml. Alternatively, for compatibility with widely-deployed web browsers, any of these feeds can use one of the more general XML types - preferably application/xml


You can reset all download actions for content types by deleting the handlers.json file from the Firefox profile folder, as explained here, under Reset actions for all content types: Firefox repeatedly opens empty tabs or windows after you click on a link

You can use an extension to restore RSS handling to Firefox, such as Livemarks

The two entries for 'XML file' in Firefox preferences under Applications is probably because they have different MIMEtypes, for example, one for application/rss+xml and a different one for application/xml Ref: https://validator.w3.org/feed/docs/warning/UnexpectedContentType.html (quote) ''RSS feeds should be served as application/rss+xml (RSS 1.0 is an RDF format, so it may be served as application/rdf+xml instead). Atom feeds should use application/atom+xml. Alternatively, for compatibility with widely-deployed web browsers, any of these feeds can use one of the more general XML types - preferably application/xml'' ----- You can reset all download actions for content types by deleting the handlers.json file from the Firefox profile folder, as explained here, under '''Reset actions for all content types''': [[Firefox repeatedly opens empty tabs or windows after you click on a link#w_reset-actions-for-all-content-types]] You can use an extension to restore RSS handling to Firefox, such as [https://addons.mozilla.org/en-US/firefox/addon/livemarks/ Livemarks]
jscher2000
  • Top 10 Contributor
8688 個解決方法 71019 個答案

有幫助的回覆

There are some new add-ons to ease the viewing of RSS feeds in a tab. For example:

https://addons.mozilla.org/firefox/addon/want-my-rss/

I think it normally looks for feeds mentioned in <link> tags at the top of the code. It may not "see" links in pages, so may not solve the problem with those -- they typically don't indicate whether they are for regular HTML pages or RSS feed, so it would be difficult to detect them.

There are some new add-ons to ease the viewing of RSS feeds in a tab. For example: https://addons.mozilla.org/firefox/addon/want-my-rss/ I think it normally looks for feeds mentioned in <link> tags at the top of the code. It may not "see" links in pages, so may not solve the problem with those -- they typically don't indicate whether they are for regular HTML pages or RSS feed, so it would be difficult to detect them.

選擇的解決方法

As I said earlier I successfully re-directed xml files to open with Safari. I have just upgraded to 64.0.2 Firefox. Bizarrely (fortunately) it now ignores this, and xml pages are now opening and displaying correctly in Firefox, without infinite re-direction loops (as they previously did for many years).

Look like it was a bug, and now cured.

Phew - it will save me a great deal of time.

As I said earlier I successfully re-directed xml files to open with Safari. I have just upgraded to 64.0.2 Firefox. Bizarrely (fortunately) it now ignores this, and xml pages are now opening and displaying correctly in Firefox, without infinite re-direction loops (as they previously did for many years). Look like it was a bug, and now cured. Phew - it will save me a great deal of time.
AliceWyman
  • Moderator
240 個解決方法 2594 個答案

tonyfirshman said

As I said earlier I successfully re-directed xml files to open with Safari. I have just upgraded to 64.0.2 Firefox. Bizarrely (fortunately) it now ignores this, and xml pages are now opening and displaying correctly in Firefox, without infinite re-direction loops (as they previously did for many years). Look like it was a bug, and now cured.

Thanks for the follow-up. I'll mark the above as the solution.

''tonyfirshman [[#answer-1187596|said]]'' <blockquote> As I said earlier I successfully re-directed xml files to open with Safari. I have just upgraded to 64.0.2 Firefox. Bizarrely (fortunately) it now ignores this, and xml pages are now opening and displaying correctly in Firefox, without infinite re-direction loops (as they previously did for many years). Look like it was a bug, and now cured. </blockquote> Thanks for the follow-up. I'll mark the above as the solution.