搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Override "important!" in source files with userChrome.css

  • 4 回覆
  • 1 有這個問題
  • 296 次檢視
  • 最近回覆由 Yaron

more options

Hello,

I'm trying to change the default text direction in the URL bar from right to left (in FF RTL locals).

Replacing

html|input.urlbar-input:-moz-locale-dir(rtl) {

 direction: ltr !important;
 text-align: right !important;

}

with

html|input.urlbar-input {

 direction: ltr !important;
 text-align: left !important;

}

in chrome\browser\content\browser\browser.css does change the direction.

However, I can not achieve that with userChrome.css. Is it possible to override the "important!" rule in the source file with userChrome.css?

Thank you.

被選擇的解決方法

If you use the html namespace in a rule then you need to add the line that define this namespace at the top of the userChrome.css file as you can see in the browser.css file. Otherwise html|<element> can't be resolved to the proper namespace.

Actually, best is probably to add this rule like I posted above via a separate file this is imported in userChrome.css that has the proper @namespace line(s).

I used *|input.urlbar-input instead of html|input.urlbar-input to make this work for all namespaces to avoid having to add a HTML namespace line.

從原來的回覆中察看解決方案 👍 1

所有回覆 (4)

more options

If you change the BIDI text direction via "Ctrl+Shift+X" then Firefox should remember this although I don't know whether this is website dependent.

Because there is likely JavaScript active to set the proper BIDI direction, you may not be able to override this in userChrome.css.

Did you try to place these rules above the @namespace line or place the code in a separate file via @import url("<file>"); and don't use the default @namespace line?

I tested with this code in a LTR locale and have the text aligned to the right, but can't use Ctrl+Shift+X

*|input.urlbar-input:-moz-locale-dir(ltr) {
 text-align: right !important;
}

Try this code:

*|input.urlbar-input:-moz-locale-dir(rtl) {
 text-align: left !important;
}
more options

Hello cor-el,

Thanks for testing and replying. I appreciate it.

I actually did not use the @namespace line at all. https://www.userchrome.org/adding-style-recipes-userchrome-css.html

I'm not quite sure if you were somehow able to override the source file with userChrome.css.

Regarding "Ctrl+Shift+X": you're right. With the following code it does work.

html|input.urlbar-input {

 direction: ltr !important;
 text-align: left !important;

}

html|input.urlbar-input[dir=rtl] {

 text-align: right !important;

}

more options

選擇的解決方法

If you use the html namespace in a rule then you need to add the line that define this namespace at the top of the userChrome.css file as you can see in the browser.css file. Otherwise html|<element> can't be resolved to the proper namespace.

Actually, best is probably to add this rule like I posted above via a separate file this is imported in userChrome.css that has the proper @namespace line(s).

I used *|input.urlbar-input instead of html|input.urlbar-input to make this work for all namespaces to avoid having to add a HTML namespace line.

more options

Hello cor-el,

Great! Thank you very much.

Your code indeed overrides the source file.

  • |input.urlbar-input { direction: ltr !important; text-align: left !important; }
  • |input.urlbar-input[dir=rtl] { text-align: right !important; }

Best regards.