搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Hide status bar as mouse moves AWAY from url link

  • 5 回覆
  • 1 有這個問題
  • 397 次檢視
  • 最近回覆由 packern

more options

Hi every one I have project with which I have managed to hide the status bar on mouse over using the useChrome.css. So you don't see the URl on mouse over. We are using Openkiosk based on Firefox as a information screen to describe what people are looking at in a chapel, the stain glass windows in fact. its a touch screen device not connected to the internet in any way. This has black html pages and the only thing I cant get rid of is when you click on the next link is it flashes the URL link from localhost. I can simulate this with moving the mouse pointer away/off the url link.

I just wondered if anyone knows the code to stop this, I have been looking for days and I cant find it anywhere.

被選擇的解決方法

Take out those two lines of code and put in fist one above from cor-el E.G. :-

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

statuspanel {display:none!important;}


-moz-any(#content,#appcontent) browser{
margin-right:-20px!important;
overflow-y:scroll;
margin-bottom:-20px!important;
overflow-x:scroll;

}

To many lines of code then So thank you that has worked :-)

從原來的回覆中察看解決方案 👍 0

所有回覆 (5)

more options

What code are you currently using in userChrome.css for #statuspanel manages?

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#statuspanel-label  { display:none!important; }
more options

Thank you for the reply

This is the whole css file so you can see what I have done so far :-

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

statuspanel[type="status"] .statuspanel-label {display:none!important;}

statuspanel[type="overLink"] .statuspanel-label {display:none!important;}

-moz-any(#content,#appcontent) browser{
margin-right:-14px!important;
overflow-y:scroll;
margin-bottom:-14px!important;
overflow-x:scroll;

}

They use an older version of Firefox so seems to use "older" code no # tags in those lines.

Openkiosk 47.0.2.2

As I said its as you move the mouse away from the hyperlink it flashes up in the bottom left corner.

more options

選擇的解決方法

Take out those two lines of code and put in fist one above from cor-el E.G. :-

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

statuspanel {display:none!important;}


-moz-any(#content,#appcontent) browser{
margin-right:-20px!important;
overflow-y:scroll;
margin-bottom:-20px!important;
overflow-x:scroll;

}

To many lines of code then So thank you that has worked :-)

more options

Note that Firefox 61+ releases use IDs: #statuspanel and #statuspanel-label. Older versions used statuspanel (tag name) and .statuspanel-label (class name).

Are you using code to place the Tab bar at the bottom of the window?

more options

Yes I got that with the # That's why I referred to it as old code.

This :-

-moz-any(#content,#appcontent) browser{ margin-right:-20px!important; overflow-y:scroll; margin-bottom:-20px!important; overflow-x:scroll; }

I got that code from somewhere to hide the scroll bars as the guys who done the html made it the exact size of screen pixel so the scroll bars popped up.

I could do with putting a label to show what it is...…... but HOW do I do that ??

由 packern 於 修改