X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox freezes system randomly

已張貼

Hardware: Lenovo Ideapad 100 Laptop, i3-5005U CPU, 8GB RAM. Software: Arch Linux OS, Kernel 4.19, Firefox 63.

Issue: While using Firefox, the system freezes completely, forcing a reboot. This happens randomly, and may be minutes after launching the program, or spaced by a few days. It is especially common while watching videos on Youtube (If I open several tabs with one focused on a long video on Youtube, it is very likely the system will eventually freeze) but it has also happened when trying to switch tabs, opening firefox's menu, and scrolling.

What I've tried: Reinstalling Firefox, creating a new places database, disabling hardware acceleration. I use no extensions. After each of these tweaks, the system has eventually frozen at least once. I have tried stressing the system's CPU and -virtual- memory for a while in two separate occassions using the STRESS program, with no freezes. Temepratures always stay below 65C. I have also tried "stressing" the system using two other browsers: Opera and Chromium. Opening many sites in tabs, with one focusing a playing video on Youtube, and letting it run for a long while. No freezes either.

It might be related to this issue: https://bbs.archlinux.org/viewtopic.php?id=236686 but for me it has only happened while using Firefox, and no other program like LibreOffice, Chromium, Opera, PCManFM, stress, etc.

Is there any way to fix this? It is very disappointing as I much prefer using Firefox than any other browser.

Hardware: Lenovo Ideapad 100 Laptop, i3-5005U CPU, 8GB RAM. Software: Arch Linux OS, Kernel 4.19, Firefox 63. Issue: While using Firefox, the system freezes completely, forcing a reboot. This happens randomly, and may be minutes after launching the program, or spaced by a few days. It is especially common while watching videos on Youtube (If I open several tabs with one focused on a long video on Youtube, it is very likely the system will eventually freeze) but it has also happened when trying to switch tabs, opening firefox's menu, and scrolling. What I've tried: Reinstalling Firefox, creating a new places database, disabling hardware acceleration. I use no extensions. After each of these tweaks, the system has eventually frozen at least once. I have tried stressing the system's CPU and -virtual- memory for a while in two separate occassions using the STRESS program, with no freezes. Temepratures always stay below 65C. I have also tried "stressing" the system using two other browsers: Opera and Chromium. Opening many sites in tabs, with one focusing a playing video on Youtube, and letting it run for a long while. No freezes either. It might be related to this issue: https://bbs.archlinux.org/viewtopic.php?id=236686 but for me it has only happened while using Firefox, and no other program like LibreOffice, Chromium, Opera, PCManFM, stress, etc. Is there any way to fix this? It is very disappointing as I much prefer using Firefox than any other browser.

額外的系統細節

已安裝的外掛程式

None.

應用程式

  • User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36 OPR/56.0.3051.104

更多資訊

Corey 'linuxmodder' Sheldon 21 個解決方法 223 個答案

While this is odd to be seeing in 63.0, look at the memory usage maybe you are experiencing a odd even one-off memory leak in firefox. Curious is this firefox from the arch repos or mozilla.org ?

While this is odd to be seeing in 63.0, look at the memory usage maybe you are experiencing a odd even one-off memory leak in firefox. Curious is this firefox from the arch repos or mozilla.org ?

提出問題者

Corey 'linuxmodder' Sheldon said

While this is odd to be seeing in 63.0, look at the memory usage maybe you are experiencing a odd even one-off memory leak in firefox. Curious is this firefox from the arch repos or mozilla.org ?

It's installed from the repos. It has been happening for all versions of Firefox since I installed that system a couple months ago. Maybe trying an AppImage of the browser would we useful to test - do you know if Mozilla provides any? I'll check memory usage next time I test it. The browser would have to quite suddenly gobble up almost 8GB of RAM and SWAP itself (everything else taking about 150MB..), but who knows..!

EDIT: Nevermind the first part - I have removed the installation of Firefox I had from the repos and installed the one provided by Mozilla. I'll update if the issues persist.

''Corey 'linuxmodder' Sheldon [[#answer-1175613|said]]'' <blockquote> While this is odd to be seeing in 63.0, look at the memory usage maybe you are experiencing a odd even one-off memory leak in firefox. Curious is this firefox from the arch repos or mozilla.org ? </blockquote> It's installed from the repos. It has been happening for all versions of Firefox since I installed that system a couple months ago. Maybe trying an AppImage of the browser would we useful to test - do you know if Mozilla provides any? I'll check memory usage next time I test it. The browser would have to quite suddenly gobble up almost 8GB of RAM and SWAP itself (everything else taking about 150MB..), but who knows..! EDIT: Nevermind the first part - I have removed the installation of Firefox I had from the repos and installed the one provided by Mozilla. I'll update if the issues persist.

由 gerebord 於 修改

提出問題者

gerebord said

EDIT: Nevermind the first part - I have removed the installation of Firefox I had from the repos and installed the one provided by Mozilla. I'll update if the issues persist.

Yup, they do. Firefox froze the system pretty quickly while watching a video on Youtube. This is the one downloaded from Mozilla, no extensions. I had HTOP running alonside Firefox to see what was happening when it would crash, and memory usage was at 1.8GB out of 8GB, CPU usage was at around 30%. I have pictures of it, but I'd rather not upload them unless someone willing to fix this needs them.

EDIT: I don't mean to sound rude with that last part, I'm just weary of my privacy when I share stuff online :)

''gerebord [[#answer-1175685|said]]'' <blockquote> EDIT: Nevermind the first part - I have removed the installation of Firefox I had from the repos and installed the one provided by Mozilla. I'll update if the issues persist. </blockquote> Yup, they do. Firefox froze the system pretty quickly while watching a video on Youtube. This is the one downloaded from Mozilla, no extensions. I had HTOP running alonside Firefox to see what was happening when it would crash, and memory usage was at 1.8GB out of 8GB, CPU usage was at around 30%. I have pictures of it, but I'd rather not upload them unless someone willing to fix this needs them. EDIT: I don't mean to sound rude with that last part, I'm just weary of my privacy when I share stuff online :)

由 gerebord 於 修改

提出問題者

Should I not seek technical support for this? Should I perhaps issue a bug? The situation hasn't changed.

Should I not seek technical support for this? Should I perhaps issue a bug? The situation hasn't changed.