搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Connection not secure - search engines over VPN, works with Chrome

  • 15 回覆
  • 1 有這個問題
  • 65 次檢視
  • 最近回覆由 Adam H.

more options

When I work from home and I connect to my client's network via Crosslink VPN, Firefox shows the "Connection not secure" warning page with "Error code: SEC_ERROR_UNKNOWN_ISSUER" for

https://duckduckgo.com/?q=firefox+insecure+connection+warning&t=ffab

and

https://www.google.co.uk/

which is making my life quite difficult! Chrome works but I haven't got Chrome customised to my liking or with my passwords etc.

I don't really know what it's doing but I suspect some certificate has gone missing over the VPN link. Is there a fix?

Thanks Adam

所有回覆 (15)

more options
more options

My laptop does have Windows 10 Defender virus scanning set up and running, but it always has that and normally without the VPN connected, it's fine.

I think it's unlikely that making the Crosslink VPN connection switches on or alters the virus software, surely. I had a good look just now through its configuration and it does make checks for all sorts of configuration, scripts and processes before it connects - including the virus scanner - but I don't believe it changes the virus scanner configuration.

There is the option to run applications with tunnelling, but firefox was very unhappy being run like that, and wouldn't make any connections at all.

more options

Is there nothing I can do? :(

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

No, the problem still persists.

more options

I called for more help.

more options

I'm working from home again and using the Crosslink VPN. I'm forced to abandon Firefox and use Chrome because of this certificates issue, but there are also other symptoms, in case it helps solve the problem:

- closing Crosslink does not help, the issue remains and I guess I'll need to reboot

- Firefox has slowed down noticeably

- the amount of ads I'm seeing while surfing the web with Chrome (and without No Script and uBlock) is aggravating my OCD - pass me that axe Eugene....

more options

Help!

Arrrrrgghhhh

blub blub blub

more options

If you view the certificate for DuckDuckGo, who is the issuer?

more options

I can't view it. It says:

duckduckgo.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. Error code: SEC_ERROR_UNKNOWN_ISSUER

more options

If you click "Learn More" are you able to view the certificate?

more options

no, that's a link to a help page in the knowledge base

more options

but I can get to the page information dialog box via the address bar info icon, and that shows that the certificate appears to be empty - clicking on the 'view certificate' button has no effect :(

more options

I am still suffering! HELP!!! Somebody tell me what I have to do to get Firefox to work!

PPPPPLLLLLLEEEEEEEAAAAAAASSSSSSSEEEEEEEEEEEEEEEE!!!!!!!!

more options

This issue is a Firefox issue! Please don't ignore it. I need a solution to be able to use FF. IE works. Chrome works. It must be a FF issue - where do you raise bugs for FF? Is there a bug tracker?