搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox uses 100% of a kernel and the tab contents are no longer displayed.

  • 3 回覆
  • 1 有這個問題
  • 68 次檢視
  • 最近回覆由 TyDraniu

more options

Hello,

after being in use for a while Firefox refuses to load a new tab and stops displaying the content of previous loaded tabs. Instead everything is white with a spinning circle in the center. A quick view on htop reveals that Firefox uses 100% of _one_ kernel while the other 15 watch doing nothing.

I'm running Firefox on x86_64 Linux 4.19.1-arch1-1-ARCH.

Currently are the following addons in use: uBlock, uMatrix, Cookie AutoDelete, Decentraleyes, Header Editor, HTTPS Everywhere, Neat URL, Skip Redirect, WebApi Manager

I'm glad for any help. :)

被選擇的解決方法

pr0genitor said

The problem is: why is Firefox only using one core? If it would spread it evenly across the 16 cores it wouldn't crash.

Your Firefox is using only one core. Try to turn on those preferences and restart the browser:

  • layout.omtp.enabled
  • layout.display-list.retain
  • layers.acceleration.force-enabled

Then check, if it's better. You can go to about:support to check Multiprocess windows, Composing, Async pan/zoom, Off main thread composing values.

從原來的回覆中察看解決方案 👍 0

所有回覆 (3)

more options

Go to about:performance and examine, if there any clues to find out, what is eating your resources.

more options

After checking for a while now I came to the result that mostly resource heavy tabs seem to be the cause for all this trouble. I don't want to change my surf behavior though, because I know that it could work.

The problem is: why is Firefox only using one core? If it would spread it evenly across the 16 cores it wouldn't crash.

more options

選擇的解決方法

pr0genitor said

The problem is: why is Firefox only using one core? If it would spread it evenly across the 16 cores it wouldn't crash.

Your Firefox is using only one core. Try to turn on those preferences and restart the browser:

  • layout.omtp.enabled
  • layout.display-list.retain
  • layers.acceleration.force-enabled

Then check, if it's better. You can go to about:support to check Multiprocess windows, Composing, Async pan/zoom, Off main thread composing values.