X
點擊此處開啟此網站的行動版。

技術支援討論區

shift opens developer toolbar

已張貼

only in FF whenever pushing shift key it opens the developers window at the bottom of the browser not allowing me to use shift as it should be

only in FF whenever pushing shift key it opens the developers window at the bottom of the browser not allowing me to use shift as it should be
附加的畫面擷圖

被選擇的解決方法

Tried changing the Mousewheel value, no luck.

Went out, got myself a new keyboard.

Issue solved

從原來的回覆中察看解決方案 0

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 31.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:63.0) Gecko/20100101 Firefox/63.0

更多資訊

McCoy
  • Top 10 Contributor
545 個解決方法 5143 個答案

Hello isratom,

It sounds like you may have a sticky F2 key (the keyboard shortcut for the developer toolbar is Shift + F2).

Would you try pressing the F2 key a few times to see if that solves the problem  ?

Hello isratom, It sounds like you may have a sticky F2 key (the keyboard shortcut for the developer toolbar is Shift + F2). Would you try pressing the F2 key a few times to see if that solves the problem ?

提出問題者

Pressed F2 key several times, F2 key does not respond and shift still opens developer window

Pressed F2 key several times, F2 key does not respond and shift still opens developer window

由 isratom 於 修改

McCoy
  • Top 10 Contributor
545 個解決方法 5143 個答案

I just found out that the developer toolbar has been removed :

https://www.ghacks.net/2018/05/21/firefox-62-developer-toolbar-removal/

So, this can't be the developer toolbar.

Looking at your screenshot I can't figure out what it is I'm looking at (I don't understand your language), but maybe if you'd try to press the following keys a few times :

F7 (Style Editor = Shift + F7) F5 (Performance = Shift + F5) F9 (Storage Inspector = Shift + F9)

If none of these work, then I can only hope that somebody else will come to your rescue, cause this must be really annoying.

I just found out that the developer toolbar has been removed : https://www.ghacks.net/2018/05/21/firefox-62-developer-toolbar-removal/ So, this can't be the developer toolbar. Looking at your screenshot I can't figure out what it is I'm looking at (I don't understand your language), but maybe if you'd try to press the following keys a few times : F7 (Style Editor = Shift + F7) F5 (Performance = Shift + F5) F9 (Storage Inspector = Shift + F9) If none of these work, then I can only hope that somebody else will come to your rescue, cause this must be really annoying.

提出問題者

Prssing shift Alone does exactly what pressing shift+f7 does

Prssing shift Alone does exactly what pressing shift+f7 does
McCoy
  • Top 10 Contributor
545 個解決方法 5143 個答案

isratom said

Prssing shift Alone does exactly what pressing shift+f7 does

Ahh, Style editor .....

https://www.ctc.ca.gov/site-information/accessibility/key-firefox

(see under "Tools")

Pressing the F7 key a few times doesn't change anything  ?

Make sure that you don't enable caret browsing though :

https://www.askvg.com/how-to-turn-caret-browsing-on-or-off-in-mozilla-firefox/

''isratom [[#answer-1170897|said]]'' <blockquote> Prssing shift Alone does exactly what pressing shift+f7 does </blockquote> Ahh, Style editor ..... https://www.ctc.ca.gov/site-information/accessibility/key-firefox (see under "Tools") Pressing the F7 key a few times doesn't change anything ? Make sure that you don't enable caret browsing though : https://www.askvg.com/how-to-turn-caret-browsing-on-or-off-in-mozilla-firefox/
McCoy
  • Top 10 Contributor
545 個解決方法 5143 個答案

Just to make sure that you didn't inadvertently mark my last post as Chosen Solution :

Did pressing the F7 key a few times work  ?

Just to make sure that you didn't inadvertently mark my last post as Chosen Solution : Did pressing the F7 key a few times work ?

提出問題者

No it didnt, for a moment i thought it did but its as was before

Tried to shhot a video just to find out i can't send it

No it didnt, for a moment i thought it did but its as was before Tried to shhot a video just to find out i can't send it
McCoy
  • Top 10 Contributor
545 個解決方法 5143 個答案

isratom said

No it didnt, for a moment i thought it did but its as was before

Bummer  ! Would you please remove the Chosen Solution mark from my post ("Undo" button to the right of that post)  ?

I will call for help, cause I'm all out of ideas (so sorry .... ).

''isratom [[#answer-1170932|said]]'' <blockquote> No it didnt, for a moment i thought it did but its as was before </blockquote> Bummer ! Would you please remove the Chosen Solution mark from my post ("Undo" button to the right of that post) ? I will call for help, cause I'm all out of ideas (so sorry .... ).

提出問題者

Unmarked the solution. Thank you for your help.

Unmarked the solution. Thank you for your help.
jscher2000
  • Top 10 Contributor
8774 個解決方法 71729 個答案

Hi isratom, Shift by itself definitely shouldn't open any panels in Firefox.

Since this started, have you already tried shutting down and restarting Windows 7, in case there is a component running in memory that has gotten corrupted?

Do you recall any software changes around the time this problem started? That could include an update to Firefox, to Windows, or to your keyboard software.

If this appeared after a Firefox update, I suggest:

Clean Reinstall

This takes about 5 minutes. It's not about your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. It's not essential to uninstall Firefox, but you can if you like, saying No to any request about removing personal data.

It only takes a few minutes.

(1) Download a fresh installer for Firefox to a convenient location:

https://www.mozilla.org/firefox/all/

Note: Currently, your Firefox identifies itself as the 32-bit version.

(2) Exit out of Firefox (if applicable).

If you use Microsoft Office, please change your default browser to Internet Explorer temporarily before the next step.

(3) Using Windows Explorer/My Computer (hold down the Windows key and press E to launch it), right-click > rename the program folder as follows (you might have one or both):

C:\Program Files (x86)\Mozilla Firefox =to=> C:\Program Files (x86)\OldFirefox

C:\Program Files\Mozilla Firefox =to=> C:\Program Files\OldFirefox

(4) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement?

Hi isratom, Shift by itself definitely shouldn't open any panels in Firefox. Since this started, have you already tried shutting down and restarting Windows 7, in case there is a component running in memory that has gotten corrupted? Do you recall any software changes around the time this problem started? That could include an update to Firefox, to Windows, or to your keyboard software. If this appeared after a Firefox update, I suggest: '''Clean Reinstall''' This takes about 5 minutes. It's not about your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. It's not essential to uninstall Firefox, but you can if you like, saying No to any request about removing personal data. It only takes a few minutes. (1) Download a fresh installer for Firefox to a convenient location: https://www.mozilla.org/firefox/all/ ''Note: Currently, your Firefox identifies itself as the 32-bit version.'' (2) Exit out of Firefox (if applicable). ''If you use '''Microsoft Office''', please change your default browser to Internet Explorer temporarily before the next step.'' (3) Using Windows Explorer/My Computer (hold down the Windows key and press E to launch it), right-click > rename the program folder as follows (you might have one or both): C:\Program Files (x86)\Mozilla Firefox =to=> C:\Program Files (x86)\OldFirefox C:\Program Files\Mozilla Firefox =to=> C:\Program Files\OldFirefox (4) Run the installer you downloaded in step (A). It should automatically connect to your existing settings. Any improvement?

提出問題者

Did as explained

Same problem with Shift kay + New problem.

When i try to reach any link in your message using FF it opens the destination lin/page but starts an unstopoble reload action enabaling any further actions.

Had to write this message using Chrome browser.

Did as explained Same problem with Shift kay + New problem. When i try to reach any link in your message using FF it opens the destination lin/page but starts an unstopoble reload action enabaling any further actions. Had to write this message using Chrome browser.
jscher2000
  • Top 10 Contributor
8774 個解決方法 71729 個答案

It sounds like Firefox is confused about the input from the function keys on your keyboard for some reason. The Storage Inspector is called up by Shift+F9. Reloading can be triggered by the F5 key.

Do you have a specialized keyboard such as a gaming keyboard?

If you have the Microsoft ergonomic keyboard, it has an F Lock key which disables the function keys. If you have that option, does it make any difference?

It sounds like Firefox is confused about the input from the function keys on your keyboard for some reason. The Storage Inspector is called up by Shift+F9. Reloading can be triggered by the F5 key. Do you have a specialized keyboard such as a gaming keyboard? If you have the Microsoft ergonomic keyboard, it has an F Lock key which disables the function keys. If you have that option, does it make any difference?
cor-el
  • Top 10 Contributor
  • Moderator
17539 個解決方法 158588 個答案

Boot the computer in Windows Safe mode with network support to see if that has effect in case other software is causing problems.

Boot the computer in Windows Safe mode with network support to see if that has effect in case other software is causing problems. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10

提出問題者

I am using a simple 4Tech keyboard. Nothing fancy.

Could the same keyboard react diferently to different browsers? I have none of these issues with Chrome nor Internet Explorer

I am using a simple 4Tech keyboard. Nothing fancy. Could the same keyboard react diferently to different browsers? I have none of these issues with Chrome nor Internet Explorer
jscher2000
  • Top 10 Contributor
8774 個解決方法 71729 個答案

I've never heard of this before, so I definitely have no idea what's causing it. In years past, low batteries in a Bluetooth keyboard caused problems in Firefox. Stuff happens.

I've never heard of this before, so I definitely have no idea what's causing it. In years past, low batteries in a Bluetooth keyboard caused problems in Firefox. Stuff happens.
McCoy
  • Top 10 Contributor
545 個解決方法 5143 個答案

'Don't know whether you're using a mouse or not, but if you do, would you try this :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

mousewheel.with_shift.action

and change its value to 0 (zero)

Then close and restart Firefox.

If it doesn't make a difference, then change the value back to its default.

It's a mere stab in the dark, but at this point worth a try .....

'Don't know whether you're using a mouse or not, but if you do, would you try this : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''mousewheel.with_shift.action''' and change its value to '''0''' (zero) Then close and restart Firefox. If it doesn't make a difference, then change the value back to its default. It's a mere stab in the dark, but at this point worth a try .....

選擇的解決方法

Tried changing the Mousewheel value, no luck.

Went out, got myself a new keyboard.

Issue solved

Tried changing the Mousewheel value, no luck. Went out, got myself a new keyboard. Issue solved

由 isratom 於 修改

McCoy
  • Top 10 Contributor
545 個解決方法 5143 個答案

isratom said

Went out, got myself a new keyboard. Issue solved

That must be a huge relief - well done  !

Woud you please mark your last post as Chosen Solution  ? (button to the right of your post)

Enjoy your new keyboard  !

''isratom [[#answer-1171274|said]]'' <blockquote> Went out, got myself a new keyboard. Issue solved </blockquote> That must be a huge relief - well done ! Woud you please mark ''your'' last post as Chosen Solution ? (button to the right of your post) Enjoy your new keyboard !