X
點擊此處開啟此網站的行動版。

技術支援討論區

WidevineCdm-plug-in crashed — no video playing

已張貼

Since ± half october 2018 I can't play videos anymore on some sites and get this crash message. Youtube does work, probably because without Widevine? I'm on FF Dev Edition, Mac with El Capitan. Thanks, Pieter

Since ± half october 2018 I can't play videos anymore on some sites and get this crash message. Youtube does work, probably because without Widevine? I'm on FF Dev Edition, Mac with El Capitan. Thanks, Pieter

被選擇的解決方法

The Firefox 64.0 release has switched to a newer Widevine version (4.10.1196.0), so maybe this new version has fixed it.

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 31.0 r0

Widevine version: 4.10.1146.0 always on + auto updates

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:64.0) Gecko/20100101 Firefox/64.0

更多資訊

jscher2000
  • Top 10 Contributor
8776 個解決方法 71744 個答案

Hi Pieter, Widevine is required by Netflix and Amazon Prime, but I don't know whether YouTube uses it. Maybe if you have a paid subscription?

Does it make any difference if you disable DRM on the Preferences page? You can check that here:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type drm and Firefox should filter to the "Digital Rights Management" section.

Uncheck the box for "Play DRM-controlled content".

Any difference?


If that doesn't help, reinstalling Widevine might, but I'm not sure how to do that. Since Widevine is installed per profile, you might check whether creating a new profile works around it. In that case, perhaps we could transplant the Widevine folder (gmp-widevinecdm) from new to old.

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like Nov2018, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new. Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Do videos work any better in the new profile?

I guess we don't know at what point Firefox will install Widevine, so perhaps this isn't a useful test...

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

Hi Pieter, Widevine is required by Netflix and Amazon Prime, but I don't know whether YouTube uses it. Maybe if you have a paid subscription? Does it make any difference if you disable DRM on the Preferences page? You can check that here: * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Windows: "3-bar" menu button (or Tools menu) > Options * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''drm'' and Firefox should filter to the "Digital Rights Management" section. Uncheck the box for "Play DRM-controlled content". Any difference? ---- If that doesn't help, reinstalling Widevine might, but I'm not sure how to do that. Since Widevine is installed per profile, you might check whether creating a new profile works around it. In that case, perhaps we could transplant the Widevine folder (gmp-widevinecdm) from new to old. '''New Profile Test''' This takes about 3 minutes, plus the time to test your problem site(s). Inside Firefox, type or paste '''about:profiles''' in the address bar and press Enter/Return to load it. Click the Create a New Profile button, then click Next. Assign a name like Nov2018, ignore the option to relocate the profile folder, and click the Finish button. After creating the profile, scroll down to it and click the '''Set as default profile''' button below that profile, then scroll back up and click the '''Restart normally''' button. (There are some other buttons, but please ignore them.) Firefox should exit and then start up using the new profile, which will just look brand new. Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test. ''Do videos work any better in the new profile?'' I guess we don't know at what point Firefox will install Widevine, so perhaps this isn't a useful test... When you are done with the experiment, open the about:profiles page again, click the '''Set as default profile''' button for your normal profile, then click the '''Restart normally''' button to get back to it.

提出問題者

Thanks a lot for your assistance, but nothing worked out well.

1) If I disable DRM, the videos on those sites will not play because those are ± like TV-sites which need DRM. Tried that. 2) New profile test didn't make any difference. Widevine crashes always. (BTW I couldn't set the test profile as default, but used it in a new browser anyway)

Actually I think if I would be able to install an older version of Widevine it could work. It did for years. No idea where/how to find and install that. The Widevine site is of no help ...

Thanks a lot for your assistance, but nothing worked out well. 1) If I disable DRM, the videos on those sites will not play because those are ± like TV-sites which need DRM. Tried that. 2) New profile test didn't make any difference. Widevine crashes always. (BTW I couldn't set the test profile as default, but used it in a new browser anyway) Actually I think if I would be able to install an older version of Widevine it could work. It did for years. No idea where/how to find and install that. The Widevine site is of no help ...
jscher2000
  • Top 10 Contributor
8776 個解決方法 71744 個答案

On Windows, I have this

[profile-folder]\gmp-widevinecdm\1.4.9.1088

However, the manifest.json file inside mentions I have the version for Windows, so you may have a different version.

I do notice in the file that it lists these codecs:

"x-cdm-codecs": "vp8,vp9.0,avc1"

Were you running Firefox 63 beta when this problem started? I wonder if the issue could be linked to new support for the VP9 codec that was added in Firefox 63. Hmm...

As a test, you could hide VP9 from websites and see whether that leads them to serve VP8 or AVC1 video instead. No idea whether that will make any difference.

I created a userscript based on the h264ify extension that hides VP9 without hiding VP8.

Step 1 is to get a "monkey" extension that lets you inject snippets of script into web pages:

Step 2 is to install the script from here:

https://greasyfork.org/en/scripts/373685-hide-vp9-support-from-youtube

On Windows, I have this [profile-folder]\gmp-widevinecdm\1.4.9.1088 However, the manifest.json file inside mentions I have the version for Windows, so you may have a different version. I do notice in the file that it lists these codecs: "x-cdm-codecs": "vp8,vp9.0,avc1" Were you running Firefox 63 beta when this problem started? I wonder if the issue could be linked to new support for the VP9 codec that was added in Firefox 63. Hmm... As a test, you could hide VP9 from websites and see whether that leads them to serve VP8 or AVC1 video instead. No idea whether that will make any difference. I created a userscript based on the h264ify extension that hides VP9 without hiding VP8. Step 1 is to get a "monkey" extension that lets you inject snippets of script into web pages: * https://addons.mozilla.org/firefox/addon/tampermonkey/ * https://addons.mozilla.org/firefox/addon/violentmonkey/ * (It doesn't work in Greasemonkey for some reason) Step 2 is to install the script from here: https://greasyfork.org/en/scripts/373685-hide-vp9-support-from-youtube
jscher2000
  • Top 10 Contributor
8776 個解決方法 71744 個答案

This page has links for older Widevine downloads:

https://bug1388771.bmoattachments.org/attachment.cgi?id=8903279

That is from this old thread: How to manually install Widevine plugin in Firefox 58.0.2 on Windows 10 x64?

I don't know if you will need to adjust values in about:config relating to the lower version number. Probably best to test in the extra profile.

This page has links for older Widevine downloads: https://bug1388771.bmoattachments.org/attachment.cgi?id=8903279 That is from this old thread: [https://support.mozilla.org/questions/1207502 How to manually install Widevine plugin in Firefox 58.0.2 on Windows 10 x64?] I don't know if you will need to adjust values in about:config relating to the lower version number. Probably best to test in the extra profile.
cor-el
  • Top 10 Contributor
  • Moderator
17541 個解決方法 158617 個答案

If you have submitted crash reports then please post the IDs of one or more recent crash reports that start with "bp-".

  • bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

You can find the report ID of recent crash reports "on the "Help -> Troubleshooting Information" (about:support) page".

  • click the "All Crash Reports" button on this page to open the about:crashes page and see all crash reports.

Alternatively you can open about:crashes via the location/address bar.

See also:


Note that Firefox comes with a builtin Widevine JSON file.

If you have submitted crash reports then please post the IDs of one or more recent crash reports that start with "bp-". *bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx You can find the report ID of recent crash reports "on the "Help -> Troubleshooting Information" (about:support) page". *click the "All Crash Reports" button on this page to open the <b>about:crashes</b> page and see all crash reports. Alternatively you can open about:crashes via the location/address bar. See also: *https://support.mozilla.org/en-US/kb/Mozilla+Crash+Reporter ---- Note that Firefox comes with a builtin Widevine JSON file. *https://dxr.mozilla.org/mozilla-release/source/toolkit/content/gmp-sources/widevinecdm.json

提出問題者

Hi, This whole Widevine thing seems very complicated. Just to play videos. I don't have the time nor the knowledge to dive this deep into it. Sigh. Using another browser in the mean time. :-( Here is a recent crash report: ID: 609bdb74-677e-4324-b3bd-ee0ee0181103 I hope this is of help to you FF guys to shed some light on the problem. Hoping for a simple solution ... Thanks anyway.

Hi, This whole Widevine thing seems very complicated. Just to play videos. I don't have the time nor the knowledge to dive this deep into it. Sigh. Using another browser in the mean time. :-( Here is a recent crash report: ID: 609bdb74-677e-4324-b3bd-ee0ee0181103 I hope this is of help to you FF guys to shed some light on the problem. Hoping for a simple solution ... Thanks anyway.

提出問題者

∆ Magic! I asked for a simple solution and guess what, the problem solved itself. I tried opening an old version of FF (not my usual FF dev edition) and updated it to the latest version. That worked for the videos. Then I opened my usual FF dev edition again and yes that works now as if nothing ever happened. Maybe you guys can explain this but I am classifying it under "magic". Thanks for the magic. PS: My feeling is that somehow an update didn't install right or something, although I'm sure a few updates happened while the problem persisted in the latest weeks.

∆ Magic! I asked for a simple solution and guess what, the problem solved itself. I tried opening an old version of FF (not my usual FF dev edition) and updated it to the latest version. That worked for the videos. Then I opened my usual FF dev edition again and yes that works now as if nothing ever happened. Maybe you guys can explain this but I am classifying it under "magic". Thanks for the magic. PS: My feeling is that somehow an update didn't install right or something, although I'm sure a few updates happened while the problem persisted in the latest weeks.

提出問題者

Too good to be true it was ... Next time I tried to watch a video with digital rights it didn't work anymore. So what happens is this: I have to start FF (normal version: 63.0.1) to watch a video but before the video starts, there is a message that FF is auto-installing an extension. Then it works. Then I close FF and open FF Dev. Edition (64.0b6) and it works one time only. Next videos don't work until I repeat the whole procedure. Wow that's so weird. If the problem is that I have two x FF, I could get rid of the "normal" version and keep only the Dev version, if that helps. Any insights? Thanks

Too good to be true it was ... Next time I tried to watch a video with digital rights it didn't work anymore. So what happens is this: I have to start FF (normal version: 63.0.1) to watch a video but before the video starts, there is a message that FF is auto-installing an extension. Then it works. Then I close FF and open FF Dev. Edition (64.0b6) and it works ''one time'' only. Next videos don't work until I repeat the whole procedure. Wow that's so weird. If the problem is that I have two x FF, I could get rid of the "normal" version and keep only the Dev version, if that helps. Any insights? Thanks
WestEnd 60 個解決方法 5387 個答案

@Piroo, at this point looks like your going to have to contact WidevineCdm creators as this isn't something a default firefox installs to use. And since you haven't provided links to the video playback problem that makes it harder to know what videos are the cause of the problem. Just naming youtube - it could be any scenario that is causing it. And it could also be the security software causing the playback issues as well.

@Piroo, at this point looks like your going to have to contact WidevineCdm creators as this isn't something a default firefox installs to use. And since you haven't provided links to the video playback problem that makes it harder to know what videos are the cause of the problem. Just naming youtube - it could be any scenario that is causing it. And it could also be the security software causing the playback issues as well.

提出問題者

@WestEnd It is on any website with Widevine, like tv stations where you can watch the news online. It is not security software. Youtube does not use Widevine so there it works. Thanks

@WestEnd It is on any website with Widevine, like tv stations where you can watch the news online. It is not security software. Youtube does not use Widevine so there it works. Thanks

提出問題者

For the record I am telling here how it evolved. After about five months of using another browser and regularly checking the working of video in FF, suddenly since ± two weeks it works again and keeps on working. The only thing I did was updating FF every time a new version came out. So now it seems to be solved definitely in the end. Thanks anyway.

For the record I am telling here how it evolved. ''After about five months'' of using another browser and regularly checking the working of video in FF, suddenly since ± two weeks it works again and keeps on working. The ''only'' thing I did was updating FF every time a new version came out. So now it seems to be solved definitely in the end. Thanks anyway.
cor-el
  • Top 10 Contributor
  • Moderator
17541 個解決方法 158617 個答案

選擇的解決方法

The Firefox 64.0 release has switched to a newer Widevine version (4.10.1196.0), so maybe this new version has fixed it.

The Firefox 64.0 release has switched to a newer Widevine version (4.10.1196.0), so maybe this new version has fixed it.
James
  • Top 25 Contributor
  • Moderator
1598 個解決方法 11291 個答案

WestEnd said

@Piroo, at this point looks like your going to have to contact WidevineCdm creators as this isn't something a default firefox installs to use.

From https://support.mozilla.org/en-US/kb/enable-drm

Firefox downloads and enables the Google Widevine CDM by default...
''WestEnd [[#answer-1170246|said]]'' <blockquote> @Piroo, at this point looks like your going to have to contact WidevineCdm creators as this isn't something a default firefox installs to use. </blockquote> From https://support.mozilla.org/en-US/kb/enable-drm <blockquote>Firefox downloads and enables the Google Widevine CDM by default...</blockquote>

提出問題者

@James I really don't understand what you're trying to say. Sorry. Did you read the whole thread?

@James I really don't understand what you're trying to say. Sorry. Did you read the whole thread?
James
  • Top 25 Contributor
  • Moderator
1598 個解決方法 11291 個答案

Was in response to WestEnd and not you.

Was in response to WestEnd and not you.