搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

A web site keeps showing an older version of itself

  • 16 回覆
  • 1 有這個問題
  • 81 次檢視
  • 最近回覆由 James

more options

https://www.thisisanfield.com/ is showing me a version of itself that is 3 days old. (For example, right now, the main headline is a "preview" for a game that happened 3 days ago - see first image).

1. A new "private browsing" window shows the up-to-date version (second image)

2. If I clear all cookies related to this site (and the ad blocker is disabled), I get the up-to-date version once... and then when I reload, it goes back to the older version.

3. No such problem in Chrome.

PS I cleared the whole cache too, that didn't help.

附加的畫面擷圖

所有回覆 (16)

more options

Load the web page. Then, to reload the page bypassing the cache and force a fresh retrieval; Ctrl+Shift+R (Mac=Command+Shift+R)


Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on Cache and Form And Search History.

more options

Thanks for suggestion CTRL+Shift+R!

The other procedure hasn't helped though.

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Thanks again.

more options

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)
more options

old search item continues to appear on lowes website. Doing control, shift, R....returns same page with old search filed in

more options

Are you possibly using a bookmark to access this page?

If this is a bookmark then it might include GET data (?xxx=xxx) in the URL.


You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

more options

Thank you!

Since doing "forget about this site" I did not have the problem again.

more options

I've done all these steps multiple times on the Lowes site. I even removed and reinstalled firefox.

The old search page is still there. Does not happen on chrome or edge.

I give up!!!!!

more options

@ rschott

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

You can try to clear the location used by the Firefox disk cache (cache2), see the about:cache page for the path to the disk cache. Location used for the disk cache and other temporary files in "AppData\Local" (Local Directory on about:profiles).

  • C:\Users\<user>\AppData\Local\Mozilla\Firefox\Profiles\<profile>\

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

before I try all this,wouldn't my deleting the firefox program, and re installing it, give me a clean profile?

more options

Firefox comes in two or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user.

If you remove the Firefox folder, the user profiles would not be affected.

more options

gidiav said

Since doing "forget about this site" I did not have the problem again.

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

more options

After installing two new profiles and loading back my extensions manually, I discovered that Last Pass was remembering that drop down search page from 2 years ago (Duh)....Even tho I keep deleting everything to do with that page (cookies, cache, etc)...last pass was keeping it.

Deleted those sites from last pass and problem was solved.

thks for all the replies

more options

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

more options

FredMcD said

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

Please pay attention as gidiav is the OP and not rschott.

由 James 於 修改