搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox won't ask to save on closing(Save and Quit button) even though showquitwarning is enabled

  • 6 回覆
  • 1 有這個問題
  • 3403 次檢視
  • 最近回覆由 jscher2000

more options

So this happened today: - Firefox did an update while I was playing. - Suddenly I noticed the icon became a blank page and when I clicked it Windows informed me, that firefox isn't on my PC. (Uninstalled itself for some reason?) - Since then Firefox won't ask if I want to save my tabs so I have to manually restore previous session every time. ShowQuitwarning is set ot be enabled. I tried deleting/renaming sessionstore.js and prefs.js - When I restored ShowQuitwarning it says it isn't a boolean, but a string variable. I assume something got corrupted, by have no idea what and how to restore besides a full reinstall? (In the meantime the option seems to have vanished fully, it is not present in about:config)

由 KittenPaws 於 修改

被選擇的解決方法

Firefox 63 doesn't have the browser.showQuitWarning preference any more.

Firefox will automatically save your session.

To restore your session, as you've noted, you can use the menu:

  • menu button > Restore Previous Session
  • (menu bar) History > Restore Previous Session

If you want to restore automatically, you can set that on the Options page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

It's the first checkbox on the page ("General" panel).

從原來的回覆中察看解決方案 👍 0

所有回覆 (6)

more options

選擇的解決方法

Firefox 63 doesn't have the browser.showQuitWarning preference any more.

Firefox will automatically save your session.

To restore your session, as you've noted, you can use the menu:

  • menu button > Restore Previous Session
  • (menu bar) History > Restore Previous Session

If you want to restore automatically, you can set that on the Options page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

It's the first checkbox on the page ("General" panel).

more options

Oh, that's...sad. Thanks for the info.

more options

Hi KittenPaws, you said:

Oh, that's...sad.

Were you choosing differently at different times, or was it nice to have the confirmation, or ? Each person seems to have a different preference, so any other info you wanted to mention could be useful context for other Firefox 63 users.

more options

I was choosing differently occasionally. For instance when I'm browsing webshops for an item, I might have 10-20 tabs and wouldn't want to save them when I'm done. Sometimes I do when I want to get back to them later.

There is a really easy workaround for both depending on the settings, but still a few more clicks than being asked.

由 KittenPaws 於 修改

more options

KittenPaws said

I was choosing differently occasionally. For instance when I'm browsing webshops for an item, I might have 10-20 tabs and wouldn't want to save them when I'm done. Sometimes I do when I want to get back to them later. There is a really easy workaround for both depending on the settings, but still a few more clicks than being asked.

It's exactly the same for me, why are you just cutting off simple and very useful functions?? Just let them choose.

Please mozilla, don't become chrome or IE please

more options

Hi tinyMozillian, here in support we work with the Firefox we have today and can suggest relevant features, settings changes, and workarounds.

If you want to propose changes to future versions of Firefox, you can submit suggestions through one or more of the following links:

I'm pretty sure you won't be the only one.