X
點擊此處開啟此網站的行動版。

技術支援討論區

NO SOUND IN FIREFOX AFTER LAST WIN 7 UPDATE. OPERA WORKS

已張貼

Everything worked fine until latest Win 7 update, but i have no functioning 'restore point' to rollback to, so i have to find a workaround. Sound works on the PC, i can play mp3's or mp4's fine. But audio from Youtube or FaceBook or BBC Iplayer is absent when i open these sites in Firefox. (yes i've checked for volume and muting, i've cleared the cache i 've tried in safe mode, all without success) I tried one modification to the registry which worked ONCE and not afterwards.....which is of course impossible. If i open the very same sites in Opera...the audio is perfect. WHAT ON EARTH is going on and how do i put this right? Thanks in advance for any insights and fixes.

Everything worked fine until latest Win 7 update, but i have no functioning 'restore point' to rollback to, so i have to find a workaround. Sound works on the PC, i can play mp3's or mp4's fine. But audio from Youtube or FaceBook or BBC Iplayer is absent when i open these sites in Firefox. (yes i've checked for volume and muting, i've cleared the cache i 've tried in safe mode, all without success) I tried one modification to the registry which worked ONCE and not afterwards.....which is of course impossible. If i open the very same sites in Opera...the audio is perfect. WHAT ON EARTH is going on and how do i put this right? Thanks in advance for any insights and fixes.

被選擇的解決方法

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

從原來的回覆中察看解決方案 0

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 13.0 r0
  • Shockwave Flash 15.0 r0
  • Shockwave Flash 31.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:60.0) Gecko/20100101 Firefox/60.0

更多資訊

Pj 42 個解決方法 869 個答案

Arbuth said

...Everything worked fine until latest Win 7 update, but i have no functioning 'restore point' to rollback to... ...Sound works on the PC, I can play mp3's or mp4's fine. But audio from YouTube or FaceBook or BBC Iplayer is absent when I open these sites in Firefox...

You must have removed your Windows Restore Points? I always keep my recent ones, every so often deleting the older ones.

I'm up-to-date with Windows-7 Pro, but I'm still on FF 61.0.2. Did you check your Speaker Mixer besides the players' volume and mute functions?


~Pj

''Arbuth [[#question-1238213|said]]'' <blockquote> ...Everything worked fine until latest Win 7 update, but i have no functioning 'restore point' to rollback to... ...Sound works on the PC, I can play mp3's or mp4's fine. But audio from YouTube or FaceBook or BBC Iplayer is absent when I open these sites in Firefox... </blockquote> You must have removed your Windows Restore Points? I always keep my recent ones, every so often deleting the older ones. I'm up-to-date with Windows-7 Pro, but I'm still on FF 61.0.2. Did you check your Speaker Mixer besides the players' volume and mute functions? ~Pj

由 Pj 於 修改

提出問題者

Relevant restore points blown away in an overzealous PC cleaning binge. Image of mixer attached since you asked ;-)

Relevant restore points blown away in an overzealous PC cleaning binge. Image of mixer attached since you asked ;-)
Pj 42 個解決方法 869 個答案

Arbuth said

Have you reviewed the last Windows Update to see if all is well and no 'Fails' on any of the Updates?

Do you have an outboard audio setup (Sound Card?) or something 'standard' on the mommy board?

Otherwise, I be stumped on this one. I be no eggzpert. I only know enough to be dangerous. (Grin)

~Pj

''Arbuth [[#answer-1166983|said]]'' <blockquote> </blockquote> Have you reviewed the last Windows Update to see if all is well and no 'Fails' on any of the Updates? Do you have an outboard audio setup (Sound Card?) or something 'standard' on the mommy board? Otherwise, I be stumped on this one. I be no eggzpert. I only know enough to be dangerous. (Grin) ~Pj
cor-el
  • Top 10 Contributor
  • Moderator
17583 個解決方法 159079 個答案

You can check the Web Console for media related messages.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

You can check the Web Console for media related messages. *https://developer.mozilla.org/en-US/Tools/Web_Console You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox

由 cor-el 於 修改

提出問題者

Perhaps i should restate the issue: i can play video on any website within Firefox. But at no point is there audio. I can play these same sites in Opera, - works great. I can play native mp3's or mp4's on the PC. Works great. But Firefox has been struck dumb. PS thanx to PJ and Cor-El for trying

Perhaps i should restate the issue: i can play video on any website within Firefox. But at no point is there audio. I can play these same sites in Opera, - works great. I can play native mp3's or mp4's on the PC. Works great. But Firefox has been struck dumb. PS thanx to PJ and Cor-El for trying

提出問題者

HEY MOZILLA! NOT THAT YOU CARE ANY BUT FWIW I FOUND A WORKAROUND, WHICH IS THAT I PORTED EVERYTHING TO 'BRAVE' BROWSER AND THAT IS DOING GREAT SO FAR.

HEY MOZILLA! NOT THAT YOU CARE ANY BUT FWIW I FOUND A WORKAROUND, WHICH IS THAT I PORTED EVERYTHING TO 'BRAVE' BROWSER AND THAT IS DOING GREAT SO FAR.
Pj 42 個解決方法 869 個答案

Arbuth said

Maybe too late, but how is the FF App setup for audio?


~Pj

''Arbuth [[#answer-1167148|said]]'' <blockquote> </blockquote> Maybe too late, but how is the FF App setup for audio? ~Pj
FredMcD
  • Top 10 Contributor
4272 個解決方法 59920 個答案

Your System Details shows;

Installed Plug-ins

Shockwave Flash 13.0 r0 Shockwave Flash 15.0 r0 Shockwave Flash 31.0 r0
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Flash: Grab the uninstaller from here:

http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows

http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Then reinstall the latest version.

Note: Windows users should download the active_x for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the active_x.

Flash Player Version 31.0.0.122

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only>


See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Your System Details shows; Installed Plug-ins Shockwave Flash 13.0 r0 Shockwave Flash 15.0 r0 Shockwave Flash 31.0 r0 <br>Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer. Flash: Grab the uninstaller from here: http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac Then reinstall the latest version. '''Note: Windows users''' should download the '''active_x''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the '''plugin only.''' Not the '''active_x.''' Flash Player '''Version 31.0.0.122''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> ------------- See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

提出問題者

Hi PJ - thankyou - here's a screenshot fwiw. not sure if it helps or not.

Hi PJ - thankyou - here's a screenshot fwiw. not sure if it helps or not.

提出問題者

Hi FredMcD, ThankYOU! I thought i had this sorted but apparently not. Will try your advice and see what happens, - will advise if successful! Cheers!

Hi FredMcD, ThankYOU! I thought i had this sorted but apparently not. Will try your advice and see what happens, - will advise if successful! Cheers!

提出問題者

Hi FredMcD, ThankYOU!..... that seems to have it sorted! all good wishes!

Hi FredMcD, ThankYOU!..... that seems to have it sorted! all good wishes!
FredMcD
  • Top 10 Contributor
4272 個解決方法 59920 個答案

選擇的解決方法

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.