X
點擊此處開啟此網站的行動版。
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

技術支援討論區

Firefox crashes

已張貼

Every page with a video on it (even Youtube and Instagram) will crash the tab!

The crash happens in safe mode too!

Crash Report #1 ID: 49f883f9-f9c2-4111-bee9-26bd70181008

Crash Report #2 ID: 77d8ab6d-a54d-44a1-8537-50b520181008

Most Recent Crashes:

3821f8d4-b13e-468f-a1e6-f6ec50181008

ff1a61cc-2d95-4b44-8126-e172d0181006

d2e3d2d9-7555-47f7-b3c1-0afe60181001

0e10eede-554f-4c6c-8fdb-193020181001

80545949-1703-4e18-b5bb-78e5d0181001

Every page with a video on it (even Youtube and Instagram) will crash the tab! The crash happens in safe mode too! Crash Report #1 ID: 49f883f9-f9c2-4111-bee9-26bd70181008 Crash Report #2 ID: 77d8ab6d-a54d-44a1-8537-50b520181008 Most Recent Crashes: 3821f8d4-b13e-468f-a1e6-f6ec50181008 ff1a61cc-2d95-4b44-8126-e172d0181006 d2e3d2d9-7555-47f7-b3c1-0afe60181001 0e10eede-554f-4c6c-8fdb-193020181001 80545949-1703-4e18-b5bb-78e5d0181001

由 DarkSuniuM 於 修改

被選擇的解決方法

Problem Solved! I'm using Arch Linux, I was using these 2 ffmpeg versions: https://aur.archlinux.org/packages/ffmpeg-git https://aur.archlinux.org/packages/ffmpeg2.8

Today I uninstalled them using `pacman -Rsdd ffmpeg-git ffmpeg2.8` and Installed ffmpeg from the Arch Repository Restarted the firefox, the problem is gone!

從原來的回覆中察看解決方案 0

額外的系統細節

應用程式

  • Firefox 62.0.3
  • 使用者代理:Mozilla/5.0 (X11; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/62.0.3/Linux/en-US/

擴充套件

  • DuckDuckGo Privacy Essentials 2018.10.4 (jid1-ZAdIEUB7XOzOJw@jetpack) (Inactive)
  • FoxyProxy Standard 6.3 (foxyproxy@eric.h.jung) (Inactive)
  • IG Down For Instagram 1.5.2 ({585377b5-7af9-4351-b0db-b8a81b19c098}) (Inactive)
  • RESTClient 3.0.7 ({ad0d925d-88f8-47f1-85ea-8463569e756e}) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Haswell Mobile
  • adapterDeviceID: Mesa DRI Intel(R) Haswell Mobile
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • contentUsesTiling: False
  • crashGuards: []
  • driverDate:
  • driverVersion: 3.0 Mesa 18.2.2
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING', u'description': u'Compositing'}, {u'status': u'unavailable', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING', u'description': u'OpenGL Compositing'}, {u'status': u'unavailable', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Safe-mode is enabled', u'type': u'runtime'}], u'name': u'WEBRENDER', u'description': u'WebRender'}, {u'status': u'blocked', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}, {u'status': u'blocked', u'message': u'OMTP blocked by safe-mode', u'type': u'runtime'}], u'name': u'OMTP', u'description': u'Off Main Thread Painting'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'CairoUseXRender': 0, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: False
  • offMainThreadPaintWorkerCount: 0
  • usesTiling: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
FFus3r 50 個解決方法 757 個答案

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 54 and below:''' # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''Advanced'' panel and the ''General'' tab. # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]]

提出問題者

FFus3r said

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: In Firefox 54 and below:
  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.
In Firefox 55 and above:
  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.
Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Still got the problem, After restart, even after restarting to safe mode ID: 77d8ab6d-a54d-44a1-8537-50b520181008

''FFus3r [[#answer-1162281|said]]'' <blockquote> Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 54 and below:''' # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''Advanced'' panel and the ''General'' tab. # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] </blockquote> Still got the problem, After restart, even after restarting to safe mode ID: 77d8ab6d-a54d-44a1-8537-50b520181008
FFus3r 50 個解決方法 757 個答案

Copy the 5 most recent Report IDs that start with bp- and then go back to your forum question and paste those IDs into the "Post a Reply" box. Note: If a recent Report ID does not start with bp- click on it to submit the report.


More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

Copy the '''5''' most recent Report IDs that start with '''bp-''' and then go back to your forum question and paste those IDs into the "Post a Reply" box. ''' Note:''' If a recent Report ID does not start with '''bp-''' click on it to submit the report. More information and further troubleshooting steps can be found in the [[Firefox crashes - Troubleshoot, prevent and get help fixing crashes]] article.

提出問題者

FFus3r said

Copy the 5 most recent Report IDs that start with bp- and then go back to your forum question and paste those IDs into the "Post a Reply" box. Note: If a recent Report ID does not start with bp- click on it to submit the report. More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

3821f8d4-b13e-468f-a1e6-f6ec50181008 ff1a61cc-2d95-4b44-8126-e172d0181006 d2e3d2d9-7555-47f7-b3c1-0afe60181001 0e10eede-554f-4c6c-8fdb-193020181001 80545949-1703-4e18-b5bb-78e5d0181001

''FFus3r [[#answer-1162295|said]]'' <blockquote> Copy the '''5''' most recent Report IDs that start with '''bp-''' and then go back to your forum question and paste those IDs into the "Post a Reply" box. ''' Note:''' If a recent Report ID does not start with '''bp-''' click on it to submit the report. More information and further troubleshooting steps can be found in the [[Firefox crashes - Troubleshoot, prevent and get help fixing crashes]] article. </blockquote> 3821f8d4-b13e-468f-a1e6-f6ec50181008 ff1a61cc-2d95-4b44-8126-e172d0181006 d2e3d2d9-7555-47f7-b3c1-0afe60181001 0e10eede-554f-4c6c-8fdb-193020181001 80545949-1703-4e18-b5bb-78e5d0181001

選擇的解決方法

Problem Solved! I'm using Arch Linux, I was using these 2 ffmpeg versions: https://aur.archlinux.org/packages/ffmpeg-git https://aur.archlinux.org/packages/ffmpeg2.8

Today I uninstalled them using `pacman -Rsdd ffmpeg-git ffmpeg2.8` and Installed ffmpeg from the Arch Repository Restarted the firefox, the problem is gone!

Problem Solved! I'm using Arch Linux, I was using these 2 ffmpeg versions: https://aur.archlinux.org/packages/ffmpeg-git https://aur.archlinux.org/packages/ffmpeg2.8 Today I uninstalled them using `pacman -Rsdd ffmpeg-git ffmpeg2.8` and Installed ffmpeg from the Arch Repository Restarted the firefox, the problem is gone!