X
點擊此處開啟此網站的行動版。

技術支援討論區

layers.acceleration.force-enabled = true & layers.force-active = true seem to solve my screen tearing and graphical glitches on Ubuntu 18.04...any risks?

已張貼

I had screen tearing and graphical glitches when browsing. [layers.acceleration.force-enabled = true] solved screen tearing, but I still had some graphical glitches from time to time which now seem to have been fixed with [layers.force-active = true].

Could this be a working configuration on the long term? Currently it is running like a charm...

I'm running Ubuntu 18.04 and had already turned off hardware acceleration and smooth scrolling without the desired results before trying the above-mentioned things. I also played around with the xorg.config.d settings of the OS...

Best regards Mike

I had screen tearing and graphical glitches when browsing. [layers.acceleration.force-enabled = true] solved screen tearing, but I still had some graphical glitches from time to time which now seem to have been fixed with [layers.force-active = true]. Could this be a working configuration on the long term? Currently it is running like a charm... I'm running Ubuntu 18.04 and had already turned off hardware acceleration and smooth scrolling without the desired results before trying the above-mentioned things. I also played around with the xorg.config.d settings of the OS... Best regards Mike

被選擇的解決方法

Basically you are just forcing Hardware acceleration to run. The only risk is that it could break in the future, but then you'd just disable it. I'd suggest keeping your graphics drivers up to date along with Firefox, but otherwise it'll be fine (hopefully)

從原來的回覆中察看解決方案 1

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0

更多資訊

Tyler Downer
  • Top 25 Contributor
  • Moderator
1529 個解決方法 10657 個答案

選擇的解決方法

Basically you are just forcing Hardware acceleration to run. The only risk is that it could break in the future, but then you'd just disable it. I'd suggest keeping your graphics drivers up to date along with Firefox, but otherwise it'll be fine (hopefully)

Basically you are just forcing Hardware acceleration to run. The only risk is that it could break in the future, but then you'd just disable it. I'd suggest keeping your graphics drivers up to date along with Firefox, but otherwise it'll be fine (hopefully)

有幫助的回覆

Thank you Tyler for your reply!

Found a better solution. Setting gfx.xrender.enabled=true and layers.acceleration.force-enabled & layers.force-active back to default solves everything.

Thank you Tyler for your reply! Found a better solution. Setting gfx.xrender.enabled=true and layers.acceleration.force-enabled & layers.force-active back to default solves everything.
dsfounis 0 個解決方法 1 個答案

magma1988 said

Thank you Tyler for your reply! Found a better solution. Setting gfx.xrender.enabled=true and layers.acceleration.force-enabled & layers.force-active back to default solves everything.

How do you believe this is better than forcing hardware acceleration?

I'm on Ubuntu 18.04.1, Firefox 64.0 and I'm going through the same problems as you.

My AskUbuntu stack question: https://askubuntu.com/questions/1102427/strange-ghost-images-transparency-effect-in-full-screen-videos/1103067#1103067

''magma1988 [[#answer-1160780|said]]'' <blockquote> Thank you Tyler for your reply! Found a better solution. Setting gfx.xrender.enabled=true and layers.acceleration.force-enabled & layers.force-active back to default solves everything. </blockquote> How do you believe this is better than forcing hardware acceleration? I'm on Ubuntu 18.04.1, Firefox 64.0 and I'm going through the same problems as you. My AskUbuntu stack question: https://askubuntu.com/questions/1102427/strange-ghost-images-transparency-effect-in-full-screen-videos/1103067#1103067

提出問題者

With layers.acceleration.force-enabled=true you get a very smooth scrolling experience, but sometimes graphical glitches and artifacts happen - e.g. on the Ubuntu Certified Hardware website when hovering over the different manufacturers. Setting layers.force-active= true will solve this issue. In terms of performance this wasn't really good. Seemed to slow down everything. Setting both to default again and gfx.xrender.enabled=true will make everything feel snappier and faster again without graphical issues and tearing. This is why I believe it to be a better solution...just my opinion. I'm still doing it that way. Hope it helps...

With layers.acceleration.force-enabled=true you get a very smooth scrolling experience, but sometimes graphical glitches and artifacts happen - e.g. on the Ubuntu Certified Hardware website when hovering over the different manufacturers. Setting layers.force-active= true will solve this issue. In terms of performance this wasn't really good. Seemed to slow down everything. Setting both to default again and gfx.xrender.enabled=true will make everything feel snappier and faster again without graphical issues and tearing. This is why I believe it to be a better solution...just my opinion. I'm still doing it that way. Hope it helps...