X
點擊此處開啟此網站的行動版。

技術支援討論區

此討論串已經關閉並封存。 如果您有需要幫助,請新增一個新問題

How to never check for updates in version 63.0b4?

已張貼

Mozilla removed the option, I want to manually check for updates.

Mozilla removed the option, I want to manually check for updates.

被選擇的解決方法

Yes, like I said, Firefox will check for updates and show a message when it finds an update and you can no longer disable this. The only thing you can is to decide whether you install the update or decline.

從原來的回覆中察看解決方案 0

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 27.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

更多資訊

jscher2000
  • Top 10 Contributor
8643 個解決方法 70728 個答案

Well, for the moment*, set Firefox to notify you but not install automatically, and decline the invitation. But if you don't want frequent updates, why are you running Beta (63) instead of Release (62) or ESR (60)?

* I say for the moment because I think someone running Beta will need to figure out the answer.

Well, for the moment*, set Firefox to notify you but not install automatically, and decline the invitation. But if you don't want frequent updates, why are you running Beta (63) instead of Release (62) or ESR (60)? ''* I say for the moment because I think someone running Beta will need to figure out the answer.''

由 jscher2000 於 修改

提出問題者

jscher2000 said

Well, for the moment*, set Firefox to notify you but not install automatically, and decline the invitation. But if you don't want frequent updates, why are you running Beta (63) instead of Release (62) or ESR (60)? * I say for the moment because I think someone running Beta will need to figure out the answer.

I like using the beta version but I want to check for updates manually, not be notified about them.

''jscher2000 [[#answer-1151728|said]]'' <blockquote> Well, for the moment*, set Firefox to notify you but not install automatically, and decline the invitation. But if you don't want frequent updates, why are you running Beta (63) instead of Release (62) or ESR (60)? ''* I say for the moment because I think someone running Beta will need to figure out the answer.'' </blockquote> I like using the beta version but I want to check for updates manually, not be notified about them.
cor-el
  • Top 10 Contributor
  • Moderator
17425 個解決方法 157456 個答案

You can still decide if you want to install an update yourself, you only can't disable updating and Firefox will check whether an update is available and offer to download and install the update.

  • app.update.auto = false
You can still decide if you want to install an update yourself, you only can't disable updating and Firefox will check whether an update is available and offer to download and install the update. *app.update.auto = false

由 cor-el 於 修改

提出問題者

cor-el said

You can still decide if you want to install an update yourself, you only can't disable updating and Firefox will check whether an update is available and offer to download and install the update.
  • app.update.auto = false

It is on false but I still received a notification for it.

''cor-el [[#answer-1151747|said]]'' <blockquote> You can still decide if you want to install an update yourself, you only can't disable updating and Firefox will check whether an update is available and offer to download and install the update. *app.update.auto = false </blockquote> It is on false but I still received a notification for it.
cor-el
  • Top 10 Contributor
  • Moderator
17425 個解決方法 157456 個答案

選擇的解決方法

Yes, like I said, Firefox will check for updates and show a message when it finds an update and you can no longer disable this. The only thing you can is to decide whether you install the update or decline.

Yes, like I said, Firefox will check for updates and show a message when it finds an update and you can no longer disable this. The only thing you can is to decide whether you install the update or decline.
jscher2000
  • Top 10 Contributor
8643 個解決方法 70728 個答案

Firefox 62 and earlier had a preference named app.update.enabled to disable automatic update checking (mostly). After Firefox 62, that preference is no longer implemented, meaning, if prefs.js contains

pref("app.update.enabled", false);

it will have no effect any more.

Firefox 62 and earlier had a preference named '''app.update.enabled''' to disable automatic update checking (mostly). After Firefox 62, that preference is no longer implemented, meaning, if prefs.js contains pref("app.update.enabled", false); it will have no effect any more.

由 jscher2000 於 修改

cor-el
  • Top 10 Contributor
  • Moderator
17425 個解決方法 157456 個答案

有幫助的回覆

Updates can be disabled via the policy engine

Bug 1420514 - Remove or hide the update features in the preferences

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Updates can be disabled via the policy engine * https://github.com/mozilla/policy-templates/blob/master/README.md Bug 1420514 - Remove or hide the update features in the preferences (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)
Tonnes
  • Locale Leader
246 個解決方法 1454 個答案

有幫助的回覆

If you want to eliminate the update check completely, adding a app.update.disabledForTesting boolean preference using about:config and setting it to true should do it, but only for Nightly releases - it does not work for Beta. (See the bug and associated bug 1485928.)

Yet a method that should work for Beta is to set a policy as described here and indicated above by cor-el after you marked a previous "it isn’t possible" comment as solution. :) DisableAppUpdate would be the parameter to use - you can copy the support page example’s content or that from the README doc.

If you want to eliminate the update check completely, adding a ''app.update.disabledForTesting'' boolean preference using ''about:config'' and setting it to ''true'' should do it, but only for Nightly releases - it does not work for Beta. (See the bug and associated bug 1485928.) Yet a method that should work for Beta is to set a policy as described [https://support.mozilla.org/kb/customizing-firefox-using-policiesjson here] and indicated above by cor-el after you marked a previous "it isn’t possible" comment as solution. :) ''DisableAppUpdate'' would be the parameter to use - you can copy the support page example’s content or that from the README doc.
tedych 0 個解決方法 17 個答案

While the new policy/json solution for disabling updates works, it is inferior and I can't believe they ruin a well working option/feature and make it harder to achieve and even that way you cannot manually check for updates unless you (temporarily) undo the policy change beforehand. The result? The result would be worse than they expected and than the current situiation. I would update more and more rarely because it is harder to manually check for updates. The default was always to auto check for updates even as it was for years and people who don't mess with this setting would have been subject to auto update without this change now nevertheless.

While the new policy/json solution for disabling updates works, it is inferior and I can't believe they ruin a well working option/feature and make it harder to achieve and even that way you cannot manually check for updates unless you (temporarily) undo the policy change beforehand. The result? The result would be worse than they expected and than the current situiation. I would update more and more rarely because it is harder to manually check for updates. The default was always to auto check for updates even as it was for years and people who don't mess with this setting would have been subject to auto update without this change now nevertheless.
billynoah 1 個解決方法 19 個答案

If you are on a *nix based OS you can edit /etc/hosts and add:

127.0.0.1 aus5.mozilla.org

When you're ready to update simply comment it out, update, and then reenable the rule. What a pain!

If you are on a *nix based OS you can edit /etc/hosts and add: 127.0.0.1 aus5.mozilla.org When you're ready to update simply comment it out, update, and then reenable the rule. What a pain!
TimBray 0 個解決方法 1 個答案

cor-el said

Updates can be disabled via the policy engine


The policy feature is really quite easy. Much simpler than making mozilla.cfg and defaults/pref/local-settings.js

If you have firefox installed in /opt/firefox

mkdir /opt/firefox/distribution/ cd /opt/firefox/distribution/

Then make a file called policies.json containing:

{
    "policies": {
	"DisableAppUpdate": true
    }
}

And that is it.

''cor-el [[#answer-1151760|said]]'' <blockquote> Updates can be disabled via the policy engine * https://github.com/mozilla/policy-templates/blob/master/README.md </blockquote> The policy feature is really quite easy. Much simpler than making mozilla.cfg and defaults/pref/local-settings.js If you have firefox installed in /opt/firefox mkdir /opt/firefox/distribution/ cd /opt/firefox/distribution/ Then make a file called policies.json containing: <pre> { "policies": { "DisableAppUpdate": true } } </pre> And that is it.
Artmaker 1 個解決方法 17 個答案

MrGoatsy said

Mozilla removed the option, I want to manually check for updates.

I HATE THIS!!!!!! WHY do so many companies FORCE their S*** onto people. LET ME CHECK WHEN I WANT TO CHECK FOR UPDATES and STOP STUFFING NOTICES IN MY FACE WHEN I AM BUSY!!!!!!!

Yes I know your not Mozilla, just hoping someone actually in charge ever looks. Doubtful. I don't think they care.

''MrGoatsy [[#question-1232918|said]]'' <blockquote> Mozilla removed the option, I want to manually check for updates. </blockquote> I HATE THIS!!!!!! WHY do so many companies FORCE their S*** onto people. LET ME CHECK WHEN I WANT TO CHECK FOR UPDATES and STOP STUFFING NOTICES IN MY FACE WHEN I AM BUSY!!!!!!! Yes I know your not Mozilla, just hoping someone actually in charge ever looks. Doubtful. I don't think they care.
FredMcD
  • Top 10 Contributor
4230 個解決方法 59038 個答案

MrGoatsy Separate Security Issue: Update your Flash Player or remove it using these links; Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link}

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 32.0.0.114

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

'''MrGoatsy''' '''Separate Security Issue:''' Update your Flash Player or remove it using these links; [http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows] {web link} [http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac] {web link} '''Note: Windows users''' should download the '''ActiveX''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player Version: '''Version 32.0.0.114 ''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
Artmaker 1 個解決方法 17 個答案

Now wait. I read that firefox REMOVED the ability to turn off notifications. How would flash, OR my graphics driver have anything to do with that?

Now wait. I read that firefox REMOVED the ability to turn off notifications. How would flash, OR my graphics driver have anything to do with that?
jscher2000
  • Top 10 Contributor
8643 個解決方法 70728 個答案

Artmaker said

Now wait. I read that firefox REMOVED the ability to turn off notifications. How would flash, OR my graphics driver have anything to do with that?

That reply wasn't addressed to your post. There is no relation between your Flash plugin version and whether Firefox prompts you to update Firefox.

''Artmaker [[#answer-1187923|said]]'' <blockquote> Now wait. I read that firefox REMOVED the ability to turn off notifications. How would flash, OR my graphics driver have anything to do with that? </blockquote> That reply wasn't addressed to your post. There is no relation between your Flash plugin version and whether Firefox prompts you to update Firefox.
Artmaker 1 個解決方法 17 個答案

All I know is I got a note in my email and that was the post. Assumed it was a reply. Seems the forum set up here is somewhat lacking. But yea, I KNOW flash has nothing to do with this.


Darn shame... I put off upgrading anything like the plague. But it finally gets to a point where I have to. So daughter came here, upgraded my os (several versions up) firefox and anything else that got broke because of it. AND as ALWAYS..... Upgrades usually mean DOWN grades. This is one of them. MOZILLA.... GET THE DAMN ºª¶§§∞∞∞ notices OUT OF MY FACE. I will update IF AND WHEN I CHOOSE TO!!!!!!

So this will just be a constant annoyance. Marvelous. I'd stick to safari only that REALLY got downgraded. Slower than 1990 dial up was. Just to launch. It's dead. Never using it again.

All I know is I got a note in my email and that was the post. Assumed it was a reply. Seems the forum set up here is somewhat lacking. But yea, I KNOW flash has nothing to do with this. Darn shame... I put off upgrading anything like the plague. But it finally gets to a point where I have to. So daughter came here, upgraded my os (several versions up) firefox and anything else that got broke because of it. AND as ALWAYS..... Upgrades usually mean DOWN grades. This is one of them. MOZILLA.... GET THE DAMN ºª¶§§∞∞∞ notices OUT OF MY FACE. I will update IF AND WHEN I CHOOSE TO!!!!!! So this will just be a constant annoyance. Marvelous. I'd stick to safari only that REALLY got downgraded. Slower than 1990 dial up was. Just to launch. It's dead. Never using it again.
tedych 0 個解決方法 17 個答案

Artmaker, calm down. Firefox will never come to a point when you wouldn't be able to stop it from updating automatically. There is currently no program that I couldn't have been able to stop autoupdating (or bitching about that). Not a single one :) . Firefox is easy with just a policy in a text file with its new policy engine. Yes, whenever you will want to check/update you would have to revert/edit that policy file. It's annoying but still less so than most other (big or popular) programs. I'm still with 63.xx.x and will update eventually someday if some major bug is fixed or whatever. That's what they 'won' with their absurd move.

Artmaker, calm down. Firefox will never come to a point when you wouldn't be able to stop it from updating automatically. There is currently no program that I couldn't have been able to stop autoupdating (or bitching about that). Not a single one :) . Firefox is easy with just a policy in a text file with its new policy engine. Yes, whenever you will want to check/update you would have to revert/edit that policy file. It's annoying but still less so than most other (big or popular) programs. I'm still with 63.xx.x and will update eventually someday if some major bug is fixed or whatever. That's what they 'won' with their absurd move.
James
  • Moderator
1594 個解決方法 11232 個答案

FredMcD said

MrGoatsy Separate Security Issue: Update your Flash Player

This thread was started on Sept 8, 2018 so of course the Flash version then will be older ;) as it was bumped since then by various other posters.


Artmaker said

All I know is I got a note in my email and that was the post. Assumed it was a reply. Seems the forum set up here is somewhat lacking.

You bumped this thread today with your comment and FredMcD made a reply directed to the person who started this thread MrGoatsy but did not notice the thread was started back on Sept 8, 2018 in which there were a number of Flash versions since then.

Since the OP has not come back since and this thread is getting hijacked, might as well lock.

''FredMcD [[#answer-1187921|said]]'' <blockquote> '''MrGoatsy''' '''Separate Security Issue:''' Update your Flash Player </blockquote> This thread was started on Sept 8, 2018 so of course the Flash version then will be older ;) as it was bumped since then by various other posters. ''Artmaker [[#answer-1187936|said]]'' <blockquote> All I know is I got a note in my email and that was the post. Assumed it was a reply. Seems the forum set up here is somewhat lacking. </blockquote> You bumped this thread today with your comment and FredMcD made a reply directed to the person who started this thread MrGoatsy but did not notice the thread was started back on Sept 8, 2018 in which there were a number of Flash versions since then. Since the OP has not come back since and this thread is getting hijacked, might as well lock.

由 James 於 修改