搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Frame skipping on any audio or video

  • 10 回覆
  • 1 有這個問題
  • 317 次檢視
  • 最近回覆由 DeRobyJ

more options

I've recently built a desktop PC with this configuration:

Ryzen 7 1800X

Geforce GTX 750 Ti (driver version: 399.07)

16GB DDR4 RAM

250GB SSD + a HDD for data only, no system files

Windows 10 64bit

External Sound card Scarlett 2i4 1st gen. [it worked fine with my old Windows7 desktop]


Any audio (soundcloud, zophar.net/music) or video (youtube, twitch, facebook) stream has the same problem: it randomly skips frames. I mean that video nor audio are interrupted, they continue, but they skip some "frames".

This bug occurs with the current official version, the current beta version and the current Nightly.

This bug does not occur on my laptop, windows 8 running an i5 CPU and no dedicated GPU.

This bug does not occur on other apps. I've tried: VLC, Facebook app, Twitch app, Microsoft Edge, Internet Explorer, Winamp.

由 DeRobyJ 於 修改

被選擇的解決方法

I found the problem.

My webcam was malfunctioning, Windows continuously detected it plugging-in and out. I plugged it out and videos played normally.

從原來的回覆中察看解決方案 👍 0

所有回覆 (10)

more options

HI, have you checked the Scarlett 2i4 Support out to see what they have ? https://support.focusrite.com/hc/en-gb

Running a Alpha maybe the cause of this and it will be a new version before find a fix for it. Also : If you have a bug, file a bug report. https://bugzilla.mozilla.org/ Bug Writing Guidelines : https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines

VIDEO AUDIO

So see if something works out of these .

more options

Hi, I already tried installing the latest drivers from Focusrite, althout I highly doubt it had something to do with them, as the problem didn't happen with any other application.

For some reason the problem is now fixed, I didn't update a thing since my original post, yet it magically disappeared. It was quite severe before, but now it's completely gone.

I guess writing here solved my problem in some way! Maybe win10 updated something during standby without me noticing...

由 DeRobyJ 於 修改

more options

Great. Glad fixed itself. Let us know if you need help.

more options

Unfortunately it just came back, and then it kind of went away after just playing a video on another app... It still happens, but far less frequently, like 1 or 2 frame skips every minute. I don't know what to think... It still only happens on firefox.

由 DeRobyJ 於 修改

more options

Hello,

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

more options

Hi, I had already tried this and other solutions. I'll try it again later today, thanks.

more options

Unfortunately disabling hardware acceletarion didn't fix the problem.

I have noticed that the frame skips are more heavy on long videos.

more options

DeRobyJ said

Unfortunately disabling hardware acceletarion didn't fix the problem. I have noticed that the frame skips are more heavy on long videos.

What is your ISP speeds and link to the video that is doing the problem.

more options

Every video on any website and quality has this problem. Even audio-only streams have it, like SoundCloud.

It's 30Mbps download speed.

more options

選擇的解決方法

I found the problem.

My webcam was malfunctioning, Windows continuously detected it plugging-in and out. I plugged it out and videos played normally.