搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

In version 62.0, how can I permanently set Google as default search engine?

  • 9 回覆
  • 1 有這個問題
  • 205 次檢視
  • 最近回覆由 David

more options

It seems that default search engine reverts to Yahoo every time Firefox is upgraded. Can't find instructions to reset default in current version to Google.

被選擇的解決方法

contacted norton since i have a subscription, and they opened a remote session. the problem appeared after i did a query on google maps. i was asked if i wanted to install a firefox google maps tab that would always appear in firefox. that tab automatically redirected searches to yahoo instead of my preference of google. tab removed and problem went away. i need to read the fine print

從原來的回覆中察看解決方案 👍 0

所有回覆 (9)

more options

Google is actually the default search engine in Firefox, not yahoo. So it should be staying as Google.

I bet you have malware switching your search engine back to Yahoo. Can you go to about:support in your address bar, and copy the section called "Extensions" here?

more options

Don't know how to copy and paste that section, but the only options are Last Pass and Maps Tab. I remember the last time I dealt with this issue, there was some unrequested add-in/extension/malware that I could disable, but I do not now have the ability to disable. Should I just uninstall and re-install?

more options

I'd run a scan with Malwarebytes (www.malwarebytes.com) and then see if it works. If it doesn't, we can refresh Firefox

more options

Hi, note the name may have changed as well as the locations so please do a search for the files also :

This could be an issue caused by AdAware or Web Companion from Lavasoft. Uninstall it if in Programs and Features which is still in WIn10 if search.

You can look for a file named dsengine.js in these locations. You should only find channel-prefs.js in the "defaults\pref" location. Any file found here apart from channel-prefs.js is suspicious. You can check the content of the file in a text editor (use open with and do not double-click the file).

  • C:\Program Files\Mozilla Firefox\defaults\pref\
  • C:\Program Files (x86)\Mozilla Firefox\defaults\pref\

You can look for a file named dsengine.cfg in the main Firefox program folder.

  • C:\Program Files\Mozilla Firefox\
  • C:\Program Files (x86)\Mozilla Firefox\

Delete the dsengine.js and dsengine.cfg files when present.

Please download and give your self a scan : https://www.malwarebytes.com/

more options

Firefox from mozilla.org does not even come with Yahoo as a search engine option anymore since Fx 57 and later due in part with the legal dispute with Yahoo.

Something else it adding in a Yahoo search engine. There is was case of a Yaahoo malware if I recall.

more options

選擇的解決方法

contacted norton since i have a subscription, and they opened a remote session. the problem appeared after i did a query on google maps. i was asked if i wanted to install a firefox google maps tab that would always appear in firefox. that tab automatically redirected searches to yahoo instead of my preference of google. tab removed and problem went away. i need to read the fine print

more options

Glad you found out the problem Please Mark beside your post Solved (left top corner of answer) so that others can find it for a solution.

more options

That extension is malware and we will be blocking it later today. Glad things are working better for you!

more options

i have also reported this to google.