搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Any way to complete a page's animations *before* reading it?

  • 15 回覆
  • 2 有這個問題
  • 104 次檢視
  • 最近回覆由 jscher2000

more options

Many sites include migraine-inducing animations. It's hard to block these animations, but maybe it would be easier to run them to completion before reading the pages.

Right now, Firefox doesn't run the animations while the tabs are in the background, only when we move them to the foreground, and try to read them, and this means sites can punch users precisely when we are vulnerable to the migraine-inducing animations.

Ideally, I'd like some way to complete all time-based and scroll-position-based and exit-based animations, including sticky elements, first, so I can remove them and read the page at my leisure without getting hit by these animations. But completeling any category would help.

所有回覆 (15)

more options

Would "layout.animation.prerender.partial" in about:config help here?

more options

That is something out of FF/Mozilla control but comes from the site itself. you should contact their webmaster about the problem. Mozilla by default itself will not block those on site animations. To do that goes beyond Mozilla enduser help here.

more options

MarjaE said

Would "layout.animation.prerender.partial" in about:config help here?

You could give it a try .....

Would "image.animation_mode" set to "none" not work for you  ?

more options

pre-rendering means that Firefox tries to prepare possible frames to make it faster to start the actual animation and run the animation more smoothly.

// Prefs to control the maximum area to pre-render when animating a large
// element on the compositor.
pref("layout.animation.prerender.partial", false);
pref("layout.animation.prerender.viewport-ratio-limit-x", "1.125");
pref("layout.animation.prerender.viewport-ratio-limit-y", "1.125");
pref("layout.animation.prerender.absolute-limit-x", 4096);
pref("layout.animation.prerender.absolute-limit-y", 4096);
more options

"image.animation_mode" "none" only blocks animated paingifpainpainpain and animated pngpainpainpainpain.

It lets all other animation through.

more options

> you should contact their webmaster about the problem

I need to protect myself against this. I have tried to contact websites about pain/animation, but it's hard to do much with the migraines, and the only times I've heard back, from a site which would zoom images on mouseover, they've explained that they don't have any pain/animation...

more options

MarjaE said

> you should contact their webmaster about the problem I need to protect myself against this. I have tried to contact websites about pain/animation, but it's hard to do much with the migraines, and the only times I've heard back, from a site which would zoom images on mouseover, they've explained that they don't have any pain/animation...

That means FF hands a tied if the site doesn't want to address or says their site doesn't have that problem then that would mean it is more related to your hardware and O/S setting that could be the cause. So if another computer shows the same problem then it can be pointed to the site as a cause.

more options

See also:

  • bug 1475462 - Add support for CSS prefers-reduced-motion media feature for MacOSX [63]
  • bug 1478597 - Remove toolkit.cosmeticAnimations.enabled in favor of prefers-reduced-motion media query

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

由 cor-el 於 修改

more options

Thanks.

Ironically, the "Responsive Design" page animates on opening...

more options

There is a "Reader Mode" that can remove all of the advertisements, animations, and other garbage from articles, leaving only the text that you want to read. For most articles, there will be a button looking like a sheet of paper in the address bar. Clicking that will put the page into Reader Mode.

more options

Yes, but Firefox doesn't allow users to load pages in reader mode, so we can't escape animation-on-loading by using reader mode.

more options

So then what is the page? So far we talked about it but there is no link for anyone to see what happens if they click on it. Need some examples of those pages showing the problem so to verify others get the problem or not.

由 WestEnd 於 修改

more options

WestEnd said

That is something out of FF/Mozilla control but comes from the site itself. you should contact their webmaster about the problem. Mozilla by default itself will not block those on site animations. To do that goes beyond Mozilla enduser help here.

There are a number of Preference in Firefox that allows you to configure how say Gifs and HTML5 animation plays for example.

This is applicable to Fx support. Even if it was more of website issue as you say, you and others can still try to help.

more options

The animations I've been objecting to for YEARS now are PART AND PARCEL of Firefox - other browsers do not force-feed animations *on the tabs* (literally, ON THE TAB) like Firefox. There was a .css-file 'fix' that worked for one or two releases - but the animation came back with the next release. This is USER-HOSTILE.

more options

BillM said

The animations I've been objecting to for YEARS now are PART AND PARCEL of Firefox - other browsers do not force-feed animations *on the tabs* (literally, ON THE TAB) like Firefox.

Hi BillM, please don't hijack MarjaE's thread with your issue, which you've already posted here: https://support.mozilla.org/questions/1232771. This thread is about web page content.