搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Alt + D showing menu instead of fucusing search bar

  • 17 回覆
  • 1 有這個問題
  • 169 次檢視
  • 最近回覆由 cor-el

more options

Hello, Alt + D does not focus on the search bar, but displays the menu briefly and selects the File tab. I already cleaned up and restarted without addons. Both without success. How can this problem be solved?

所有回覆 (17)

more options

Somebody else posted the same question .....

Does Ctrl + L still work  ? (should do the same as Alt + D)

It could be that an add-on is using the shortcut - would you try Firefox in Safe Mode :

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

more options

Thanks for your reply. Yes, Ctrl + L works. As already mentioned, Safe Mode didn't solve the problem. Any other advice?

P.S.: It does not work on my windows tablet either.

more options

AndiLeni said

As already mentioned, Safe Mode didn't solve the problem.

I missed that - sorry ......

I haven't been able to find an explanation - but until somebody else comes up with the perfect answer, would you be happy using Ctrl + L  ?

more options

McCoy said

I missed that - sorry ......

No problem :)

It is not a big problem to use Ctrl + L. All I have to do is change my habit. But I thought the problem should definitely be reported and apparently I am not the only one who has had this problem lately.

more options

If I hold down the Alt key and tap and release the D key, the address bar contents are selected -- this is Windows 7 with U.S. English Firefox 61.

Does your menu bar activate for non-existent keyboard combinations such as Alt+X? I think the expected behavior for that one is "nothing happens."

more options

AndiLeni said

But I thought the problem should definitely be reported and apparently I am not the only one who has had this problem lately.

You did the right thing reporting this, especially since you're not the only one with this problem. I can't wait to find out what causes it - 'was hoping it would be an add-on  :(

more options

jscher2000 said

If I hold down the Alt key and tap and release the D key, the address bar contents are selected -- this is Windows 7 with U.S. English Firefox 61.

Same here (on Windows 10) - I just assumed that AndiLeni meant the address bar ...... (?)

more options

@jscher 2000

Alt + X opens the opens the manu bar and selects the "Extras" tab. Alt + C does the same with the Chronik tab. Alt + B opens the "Barbeiten" tab, Alt + A the "Ansicht" tab, Alt + L the "Lesezeichen" tab, Alt + H the "Hilfe" tab.

Apparently it has something to do with the naming of the manu items. Because in the german version the "File" menu is called "Datei" Alt + D opens this menu.

more options

Aha! Yes, that makes sense. If D is the specified "accelerator" key for the Datei menu, Alt + D should activate that accelerator key. (Depending on your Windows settings, accelerator keys may be underlined for easier keyboarding.)

Was Firefox 60 (German locale) working differently, and this just started in Firefox 61? Occasionally an updated localized version of Firefox has errors related to keyboard shortcuts. I'm not sure whose attention should be directed to this.

more options

And I just found this really old thread - and guess what  ?

http://forums.mozillazine.org/viewtopic.php?f=9&t=14532

One user says :

"Which language version of Firefox are you using? I had the same problem and searching the web I saw that German users were really annoyed by the alt+d binding because this should open their File menu. I installed the English version which brought back the alt+d shortcut. "

more options

@ jscher2000 Unfortunately I can't tell you if the problem existed in older versions. I switched my notebook and from chrome to firefox.

@ McCoy This thread is indeed helpfull. Maybe you should defend reddari's comment on an old thread ;) This probably means only german users are affected by this problem. But I still don't understand the whole situation....

more options

Just in case you'd like to file a bug report (if you think its worth the trouble) :

https://bugzilla.mozilla.org/

https://bugzilla.mozilla.org/enter_bug.cgi#h=bugForm%7CFirefox

more options

I filed the bug report. Maybe it will be resolved sometimes in the future. Thanks for your help!

more options

AndiLeni said

I filed the bug report.

Good for you  !

For now, just use Ctrl + L

(you may noy even want to go back to Alt + D ..... )

more options

The key assignment is different depending on the language package. For German it is the combination Alt + S See: https://bugzilla.mozilla.org/show_bug.cgi?id=1485052 And: https://pontoon.mozilla.org/de/firefox/all-resources/?string=75703

more options

AndiLeni said

The key assignment is different depending on the language package. For German it is the combination Alt + S
See: https://bugzilla.mozilla.org/show_bug.cgi?id=1485052
And: https://pontoon.mozilla.org/de/firefox/all-resources/?string=75703

Thank you so much for posting this  !

more options