X
點擊此處開啟此網站的行動版。

技術支援討論區

In the latest Firefox version (July 18) links to other pages in the same site won't work, but other links do. Why not (they work in other browsers)?

已張貼

Within that same web site the links to its associated PDFs and to other websites work in all browsers, still including Firefox in its latest version, so why the links to other pages within the same site no longer work in the latest version of Firefox when they always did in every other version is a mystery to me. Being non-technical, the obvious work-around of going back to a previous version is something equally mysterious and therefore inaccessible to me. I have never had to think of doing it before, having been a Firefox (default browser) user for eight years, opting always to have auto upgrades to the latest version because of a trouble-free experience of Firefox - until now.

Filling in an online ballot yesterday on a different website, while using Firefox, threw up a very similar problem. When I clicked on 'read candidates' statements', which had a PDF icon next to it, I wasn't taken to a PDF: nothing happened. So I suspect it was a link to a different page of that website, which comprised just a PDF. All very frustrating. I have reported this to the electoral body which provides the secure online ballot for the organisation staging the election, outlining what I describe above, and asking them too to report this to Mozilla.

My work-around, until Firefox fix this issue, which I have reported to them, is simply to use Internet Explorer or Chrome when necessary, resisting the temptation to make one of them my default browser and thus make even more megabucks for their rapacious owners.

Any help would be appreciated, but please don't assume when you kindly respond that I have technical knowledge! Plain English instructions, please. Thank you.

Within that same web site the links to its associated PDFs and to other websites work in all browsers, still including Firefox in its latest version, so why the links to other pages within the same site no longer work in the latest version of Firefox when they always did in every other version is a mystery to me. Being non-technical, the obvious work-around of going back to a previous version is something equally mysterious and therefore inaccessible to me. I have never had to think of doing it before, having been a Firefox (default browser) user for eight years, opting always to have auto upgrades to the latest version because of a trouble-free experience of Firefox - until now. Filling in an online ballot yesterday on a different website, while using Firefox, threw up a very similar problem. When I clicked on 'read candidates' statements', which had a PDF icon next to it, I wasn't taken to a PDF: nothing happened. So I suspect it was a link to a different page of that website, which comprised just a PDF. All very frustrating. I have reported this to the electoral body which provides the secure online ballot for the organisation staging the election, outlining what I describe above, and asking them too to report this to Mozilla. My work-around, until Firefox fix this issue, which I have reported to them, is simply to use Internet Explorer or Chrome when necessary, resisting the temptation to make one of them my default browser and thus make even more megabucks for their rapacious owners. Any help would be appreciated, but please don't assume when you kindly respond that I have technical knowledge! Plain English instructions, please. Thank you.

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 30.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

更多資訊

FredMcD
  • Top 10 Contributor
4271 個解決方法 59913 個答案

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link}

提出問題者

I'm very grateful for the swift and helpful response from FredMcd and I have tried starting in Safe Mode.

I can now navigate from page to page in any browser but when I click on PDF icons (either left click, or by using the options that come up in the right click menu, such as opening the link in a new window) there is no response from Firefox, whether or not I go into it via Safe Mode. Any ideas for a cure, please? I guess it must be something very simple. All I know is that in other browsers I don't get this problem.

Perhaps I should have mentioned that I am using a desktop in Windows 7 Professional, which itself I have carefully updated, as I do Firefox.

I'm very grateful for the swift and helpful response from FredMcd and I have tried starting in Safe Mode. I can now navigate from page to page in any browser but when I click on PDF icons (either left click, or by using the options that come up in the right click menu, such as opening the link in a new window) there is no response from Firefox, whether or not I go into it via Safe Mode. Any ideas for a cure, please? I guess it must be something very simple. All I know is that in other browsers I don't get this problem. Perhaps I should have mentioned that I am using a desktop in Windows 7 Professional, which itself I have carefully updated, as I do Firefox.
FredMcD
  • Top 10 Contributor
4271 個解決方法 59913 個答案

Others have reported issues with PDF files. I called for more help.

HBob said

. . . I have tried starting in Safe Mode
. . . . I can now navigate from page to page

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else. ++++++++++++++++++++++++++++++++++++++ It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Others have reported issues with PDF files. I called for more help. ''HBob [[#answer-1137910|said]]'' <blockquote> . . . I have tried starting in Safe Mode<br>. . . . I can now navigate from page to page </blockquote> https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else. ++++++++++++++++++++++++++++++++++++++ It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.