Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

An installed application on a preinstalled Ubuntu 16.04 (Dell laptop) doesn't exist in Firefox's Applications list

  • 7 回覆
  • 1 有這個問題
  • 646 次檢視
  • 最近回覆由 MGelbana

more options

I'm using a conference application called Zoom. There are URLs that can be clicked to open the application and let jump in right away to the meeting that ID existed in the URL. For example: https://zoom.us/j/1234567890

But none of the URLs I tried actually opens the application.

Or for instance when I try to login to my account, the app opens Firefox which after logging in through the web, redirects me to zoommtg://zoom.us/google?code=XXX and Firefox shows a message saying "The address wasn’t understood".

I tried the following boolean key on the about:config page for Firefox: network.protocol-handler.expose.zoommtg=false

And I tried assigning true instead of false, but this didn't do the trick.

My Firefox has the following key/value network.protocol-handler.expose-all;true

I understand that this configuration makes me not need to set the previous one as it overrides it.

From within my ~/.local/share/applications $ cat Zoom.desktop [Desktop Entry] Name=Zoom Comment=Zoom Video Conference Exec=/usr/bin/zoom %U Icon=Zoom.png Terminal=false Type=Application Encoding=UTF-8 Categories=Network;Application; StartupWMClass=zoom MimeType=x-scheme-handler/zoommtg;application/x-zoom; X-KDE-Protocols=zoommtg Name[en_US]=Zoom $ cat mimeapps.list

[Default Applications] text/html=firefox_firefox.desktop x-scheme-handler/http=firefox_firefox.desktop x-scheme-handler/https=firefox_firefox.desktop x-scheme-handler/about=firefox_firefox.desktop x-scheme-handler/unknown=firefox_firefox.desktop x-scheme-handler/zoommtg=Zoom.desktop application/x-zoom=Zoom.desktop

How can I configure Firefox to redirect the Zoom URLs to the application, so I can login to my account and use meeting links to join the meetings instantly ?

I uploaded a screenshot to show that Zoom doesn't show in Firefox's Applications list, but I'm not sure it isn't showing up !

附加的畫面擷圖

由 MGelbana 於 修改

被選擇的解決方法

I uninstalled Firefox (It was installed using Ubuntu's software center), it's a snap application.

I used a downloaded version of Firefox, from Firefox's website and it works like a charm !

I'm very sorry for wasting your time guys. I sincerely appreciate it. Thanks a lot.

從原來的回覆中察看解決方案 👍 0

All Replies (7)

more options

Sorry, the screenshot uploader doesn't always work with the question; it should work with a reply if you want to use it.

Does the test page work for you? It seems to use some kind of scripting rather than a regular URL, in case that makes a difference: https://zoom.us/test

more options

No it doesn't. It redirects me to downloading Zoom. Here is the screenshot.

more options

Using firefox 61+, I have no issues. See screenshots below.

Have you tried from safe mode?

more options

Tried this, Zoom still doesn't show up. I'll update my question to indicate that I'm using a preinstalled Ubuntu on a Dell machine. I think this has to do with this. I also THINK it has to do with something called xdg because on another machine I used to have, I THINK I used to see "xdg" somewhere when I clicked Zoom links.

more options

@MGelbana,

1) Can you confirm /usr/share/applications/zoom.desktop exists for me ? Or that ~/.local/share/applications/Zoom.desktop is symlinked to that location?

2) Generally you need to launch Zoom first (outside the browser), in order to set that feature (unless using the Firefox `Zoom Scheduler` addon like I do in addition. Once launched and logged in try again to use a zoommtg, if need be feel free to request or create a zoom link and we can test, been a zoom user for nearly 28 months now.

more options

1) There was a /usr/share/applications/Zoom.desktop (Notice the difference between Zoom and zoom) that I created in an attempt to fix this. I replaced it with a symlink sudo ln -s /home/mgelbana/.local/share/applications/Zoom.desktop /usr/share/applications/zoom.desktop But that didn't work either.

more options

選擇的解決方法

I uninstalled Firefox (It was installed using Ubuntu's software center), it's a snap application.

I used a downloaded version of Firefox, from Firefox's website and it works like a charm !

I'm very sorry for wasting your time guys. I sincerely appreciate it. Thanks a lot.