X
點擊此處開啟此網站的行動版。
Scheduled maintenance: Wednesday, April 1, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

技術支援討論區

turn off the warning about "block auto refresh"

S47
已張貼

I set

about:config?filter=accessibility.blockautorefresh

to true because some websites decides by itself to reload a page whilst reading!

What I am asking is if it is at all possible to stop this message coming across the top of the page every time I visit!

Many Thanks :)

I set about:config?filter=accessibility.blockautorefresh to true because some websites decides by itself to reload a page whilst reading! What I am asking is if it is at all possible to stop this message coming across the top of the page every time I visit! Many Thanks :)
附加的畫面擷圖

被選擇的解決方法

jscher2000 said

The - in the title is – (an "n-dash") which is a different character from a hyphen. If you go to the Console section of the developer tools (Ctrl+Shift+k) and type document.title and press Enter, you can copy the title and then paste it into your style rule. Then it should match exactly. Alternately, you can combine two title attribute selectors to match two word portions so that the dash isn't considered: #main-window[title*="NRK.no"][title*="nyheter, tv og radio fra Norge og hele verden"] notification[value="refresh-blocked"]{


document.title I did not know that :D or the: n-dash

  • #main-window[title*="NRK.no"][title*="nyheter, tv og radio fra Norge og hele verden"] notification[value="refresh-blocked"]{

This worked, the first one did not :D


my situation: see added picture for windows 10 or go to file explorer options in older windows, then view then find something about showing/hiding the file extension (check/uncheck)

  • In your explorer window, go to View and check (File name extensions)

X:\Users\Windows log in user name\AppData\Roaming\Mozilla\Firefox\Profiles\XXXXXXXX.default\Chrome

Create a TXT (text) file and call it:

userChrome.css

yes to changing the file type!

See "Finish product:" or keep reading!


I mark these as the solutions:

Get the sites exact name: Console section of the developer tools (Ctrl+Shift+k) and type document.title


For a website that has an; "n-dash" IN THE TITLE nrk.no who's title is: NRK.no – nyheter, tv og radio fra Norge og hele verden use:

#main-window[title*="NRK.no"][title*="nyheter, tv og radio fra Norge og hele verden"] notification[value="refresh-blocked"]{

 visibility: collapse !important;

}


for a website with a simple title like: reload every 10 seconds who's title is: "Reload Every 10 Seconds" use:

#main-window[title*="Reload Every 10 Seconds"] notification[value="refresh-blocked"]{

 visibility: collapse !important;

}


ALL the answers was provided by: Mr. jscher2000

And a million thanks to you :D


Finish product: /* remove allow to refresh */ /*01 check site name: (Ctrl+Shift+k) and type: document.title*/

/*Sites with "n-dash" in title*/

#main-window[title*="NRK.no"][title*="nyheter, tv og radio fra Norge og hele verden"] notification[value="refresh-blocked"]{

 visibility: collapse !important;

}

/*Sites with simpler titles*/

#main-window[title*="Reload Every 10 Seconds"] notification[value="refresh-blocked"]{

 visibility: collapse !important;

} #main-window[title*="Bergensavisen"] notification[value="refresh-blocked"]{

 visibility: collapse !important;

}

從原來的回覆中察看解決方案 0

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 30.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

更多資訊

Shadow110 1072 個解決方法 14836 個答案

HI, that should have turned it off but you are running version 62 so any guess as to what happens in a Beta.

I can not find anything other than to do what you did as the settings in Options do not include the check box that when combined would turn that off.

Have you restarted Firefox after making the changes ?

HI, that should have turned it off but you are running version 62 so any guess as to what happens in a Beta. I can not find anything other than to do what you did as the settings in Options do not include the check box that when combined would turn that off. Have you restarted Firefox after making the changes ?

提出問題者

Pkshadow said

HI, that should have turned it off but you are running version 62 so any guess as to what happens in a Beta. I can not find anything other than to do what you did as the settings in Options do not include the check box that when combined would turn that off. Have you restarted Firefox after making the changes ?

I had it not in the beta either! I am running beta now and still it shows off for every website! Ran Nightly and still a problem :(

''Pkshadow [[#answer-1135144|said]]'' <blockquote> HI, that should have turned it off but you are running version 62 so any guess as to what happens in a Beta. I can not find anything other than to do what you did as the settings in Options do not include the check box that when combined would turn that off. Have you restarted Firefox after making the changes ? </blockquote> I had it not in the beta either! I am running beta now and still it shows off for every website! Ran Nightly and still a problem :(
McCoy
  • Top 10 Contributor
627 個解決方法 6011 個答案

Probably a rhetorical question, but just to make sure : After you changed the value of that preference on the 'about:config' page - did you then close and restart Firefox, in order for the change to take effect  ?

Probably a rhetorical question, but just to make sure : After you changed the value of that preference on the 'about:config' page - did you then close and restart Firefox, in order for the change to take effect ?

有幫助的回覆

McCoy said

Probably a rhetorical question, but just to make sure : After you changed the value of that preference on the 'about:config' page - did you then close and restart Firefox, in order for the change to take effect  ?

yes :)

''McCoy [[#answer-1135442|said]]'' <blockquote> Probably a rhetorical question, but just to make sure : After you changed the value of that preference on the 'about:config' page - did you then close and restart Firefox, in order for the change to take effect ? </blockquote> yes :)
McCoy
  • Top 10 Contributor
627 個解決方法 6011 個答案

S47 said

McCoy said
Probably a rhetorical question, but just to make sure : After you changed the value of that preference on the 'about:config' page - did you then close and restart Firefox, in order for the change to take effect  ?

yes :)

I overlooked the fact that Pkshadow already asked the same question - sorry  !

''S47 [[#answer-1135493|said]]'' <blockquote> ''McCoy [[#answer-1135442|said]]'' <blockquote> Probably a rhetorical question, but just to make sure : After you changed the value of that preference on the 'about:config' page - did you then close and restart Firefox, in order for the change to take effect ? </blockquote> yes :) </blockquote> I overlooked the fact that Pkshadow already asked the same question - sorry !

提出問題者

McCoy said

S47 said
McCoy said
Probably a rhetorical question, but just to make sure : After you changed the value of that preference on the 'about:config' page - did you then close and restart Firefox, in order for the change to take effect  ?

yes :)

I overlooked the fact that Pkshadow already asked the same question - sorry  !

No worries ;) it's fine :)

''McCoy [[#answer-1135496|said]]'' <blockquote> ''S47 [[#answer-1135493|said]]'' <blockquote> ''McCoy [[#answer-1135442|said]]'' <blockquote> Probably a rhetorical question, but just to make sure : After you changed the value of that preference on the 'about:config' page - did you then close and restart Firefox, in order for the change to take effect ? </blockquote> yes :) </blockquote> I overlooked the fact that Pkshadow already asked the same question - sorry ! </blockquote> No worries ;) it's fine :)

提出問題者

BUMP!

BUMP!
McCoy
  • Top 10 Contributor
627 個解決方法 6011 個答案

S47 said

BUMP!

Just to make sure :

accessibility.blockautorefresh :

its value needs to be set to false to turn it OFF

its value needs to be set to true to turn it ON

(after a value has been changed : close and restart Firefox)

''S47 [[#answer-1137534|said]]'' <blockquote> BUMP! </blockquote> Just to make sure : '''accessibility.blockautorefresh''' : its value needs to be set to '''false''' to turn it OFF its value needs to be set to '''true''' to turn it ON (after a value has been changed : close and restart Firefox)
cor-el
  • Top 10 Contributor
  • Moderator
17851 個解決方法 161570 個答案

blockautorefresh is all or nothing. When you enable this accessibility feature (i.e. pref is true like you posted above) then you will see a warning bar every time you visit a web page where this applies. There isn't a white list to bypass this warning, so you will have to accept it or disable this feature (i.e. set the pref to false).

I don't know if any of the popular content blocking extensions support this feature.

blockautorefresh is all or nothing. When you enable this accessibility feature (i.e. pref is true like you posted above) then you will see a warning bar every time you visit a web page where this applies. There isn't a white list to bypass this warning, so you will have to accept it or disable this feature (i.e. set the pref to false). I don't know if any of the popular content blocking extensions support this feature.

提出問題者

the answer is: it can not be done! this exact option of firefox was made by Apple.

the answer is: it can not be done! this exact option of firefox was made by Apple.
jscher2000
  • Top 10 Contributor
8950 個解決方法 73363 個答案

有幫助的回覆

I think you're giving up a little too easily here.

You can use custom style rules in a userChrome.css file to hide that notification --

notification[value="refresh-blocked"]{
  visibility: collapse !important;
}

-- but I find it hard to believe that would be a good way to use this feature because won't you need the Allow button when you want to be redirected?

As a workaround, you could hide most of the bar by giving it a negative top margin, and then slide it down when you hover it, maybe after a half second delay:

notification[value="refresh-blocked"] {
  margin-top: -30px !important;
  transition: margin-top 500ms ease;
}
notification[value="refresh-blocked"]:hover {
  margin-top: 0 !important;
  transition: margin-top 500ms ease 500ms;
}

Or similarly, you could hide the contents of the bar, leaving just the 5 pixels of padding around the contents, until you hover it:

notification[value="refresh-blocked"] > hbox, 
notification[value="refresh-blocked"] > toolbarbutton {
  visibility: collapse !important;
}
notification[value="refresh-blocked"]:hover > hbox, 
notification[value="refresh-blocked"]:hover > toolbarbutton {
  visibility: visible !important;
}

Either would allow access to the bar on demand while giving you back most of the content area for the page.

I was using this page for testing: https://www.jeffersonscher.com/res/reload.html

I think you're giving up a little too easily here. You can use custom style rules in a userChrome.css file to hide that notification -- <pre>notification[value="refresh-blocked"]{ visibility: collapse !important; } </pre> -- but I find it hard to believe that would be a good way to use this feature because won't you need the Allow button when you ''want'' to be redirected? As a workaround, you could hide ''most'' of the bar by giving it a negative top margin, and then slide it down when you hover it, maybe after a half second delay: <pre>notification[value="refresh-blocked"] { margin-top: -30px !important; transition: margin-top 500ms ease; } notification[value="refresh-blocked"]:hover { margin-top: 0 !important; transition: margin-top 500ms ease 500ms; } </pre> Or similarly, you could hide the ''contents'' of the bar, leaving just the 5 pixels of padding around the contents, until you hover it: <pre>notification[value="refresh-blocked"] > hbox, notification[value="refresh-blocked"] > toolbarbutton { visibility: collapse !important; } notification[value="refresh-blocked"]:hover > hbox, notification[value="refresh-blocked"]:hover > toolbarbutton { visibility: visible !important; } </pre> Either would allow access to the bar on demand while giving you back most of the content area for the page. I was using this page for testing: https://www.jeffersonscher.com/res/reload.html
jscher2000
  • Top 10 Contributor
8950 個解決方法 73363 個答案

Now... what about doing that only for one site? It's difficult. You can limit that rule to pages that contain a certain phrase in the title, but not with a particular address. So as an example with title:

Firefox marks the test page as

title="Reload Every 10 Seconds - Mozilla Firefox"

That's the title on the tab plus " - Mozilla Firefox"

So to limit the rule to that page, for example:

#main-window[title="Reload Every 10 Seconds - Mozilla Firefox"] notification[value="refresh-blocked"]{
  visibility: collapse !important;
}

If there is a pattern to the titles that varies from page to page, such as this site having "| Mozilla Support" in each title:

#main-window[title*="| Mozilla Support"] notification[value="refresh-blocked"]{
  visibility: collapse !important;
}

(using title*= matches the text anywhere in the title)

Et cetera.

A good site to get advice on trickier custom style rules is: https://www.reddit.com/r/FirefoxCSS/

Now... what about doing that only for one site? It's difficult. You can limit that rule to pages that contain a certain phrase in the title, but not with a particular address. So as an example with title: Firefox marks the test page as title="Reload Every 10 Seconds - Mozilla Firefox" That's the title on the tab plus " - Mozilla Firefox" So to limit the rule to that page, for example: <pre>#main-window[title="Reload Every 10 Seconds - Mozilla Firefox"] notification[value="refresh-blocked"]{ visibility: collapse !important; } </pre> If there is a pattern to the titles that varies from page to page, such as this site having "| Mozilla Support" in each title: <pre>#main-window[title*="| Mozilla Support"] notification[value="refresh-blocked"]{ visibility: collapse !important; } </pre> (using title*= matches the text anywhere in the title) Et cetera. A good site to get advice on trickier custom style rules is: https://www.reddit.com/r/FirefoxCSS/

提出問題者

jscher2000 said

Now... what about doing that only for one site? It's difficult. You can limit that rule to pages that contain a certain phrase in the title, but not with a particular address. So as an example with title: Firefox marks the test page as title="Reload Every 10 Seconds - Mozilla Firefox" That's the title on the tab plus " - Mozilla Firefox" So to limit the rule to that page, for example:
#main-window[title="Reload Every 10 Seconds - Mozilla Firefox"] notification[value="refresh-blocked"]{
  visibility: collapse !important;
}

If there is a pattern to the titles that varies from page to page, such as this site having "| Mozilla Support" in each title:

#main-window[title*="| Mozilla Support"] notification[value="refresh-blocked"]{
  visibility: collapse !important;
}

(using title*= matches the text anywhere in the title)

Et cetera.

A good site to get advice on trickier custom style rules is: https://www.reddit.com/r/FirefoxCSS/

MEGA MEGA COOLD :D I now have this:

#main-window[title*="NRK.no – nyheter, tv og radio fra Norge og hele verden"] notification[value="refresh-blocked"]{
  visibility: collapse !important;
}
#main-window[title*="Reload Every 10 Seconds"] notification[value="refresh-blocked"]{
  visibility: collapse !important;
}

ant it works on https://www.jeffersonscher.com/res/reload.html

But it doe not work on this site:

NRK.no – nyheter, tv og radio fra Norge og hele verden


If I understand this right, the problem is the "-" in the title!

I prefer to go rule by site, I have much more control that way :D

''jscher2000 [[#answer-1137779|said]]'' <blockquote> Now... what about doing that only for one site? It's difficult. You can limit that rule to pages that contain a certain phrase in the title, but not with a particular address. So as an example with title: Firefox marks the test page as title="Reload Every 10 Seconds - Mozilla Firefox" That's the title on the tab plus " - Mozilla Firefox" So to limit the rule to that page, for example: <pre>#main-window[title="Reload Every 10 Seconds - Mozilla Firefox"] notification[value="refresh-blocked"]{ visibility: collapse !important; } </pre> If there is a pattern to the titles that varies from page to page, such as this site having "| Mozilla Support" in each title: <pre>#main-window[title*="| Mozilla Support"] notification[value="refresh-blocked"]{ visibility: collapse !important; } </pre> (using title*= matches the text anywhere in the title) Et cetera. A good site to get advice on trickier custom style rules is: https://www.reddit.com/r/FirefoxCSS/ </blockquote> MEGA MEGA COOLD :D I now have this: <pre>#main-window[title*="NRK.no – nyheter, tv og radio fra Norge og hele verden"] notification[value="refresh-blocked"]{ visibility: collapse !important; }</pre> <pre>#main-window[title*="Reload Every 10 Seconds"] notification[value="refresh-blocked"]{ visibility: collapse !important; }</pre> ant it works on ''[https://www.jeffersonscher.com/res/reload.html https://www.jeffersonscher.com/res/reload.html]'' But it doe not work on this site: ''[https://www.nrk.no/ NRK.no – nyheter, tv og radio fra Norge og hele verden] '' If I understand this right, the problem is the "-" in the title! I prefer to go rule by site, I have much more control that way :D
jscher2000
  • Top 10 Contributor
8950 個解決方法 73363 個答案

The - in the title is – (an "n-dash") which is a different character from a hyphen. If you go to the Console section of the developer tools (Ctrl+Shift+k) and type

document.title

and press Enter, you can copy the title and then paste it into your style rule. Then it should match exactly.

Alternately, you can combine two title attribute selectors to match two word portions so that the dash isn't considered:

#main-window[title*="NRK.no"][title*="nyheter, tv og radio fra Norge og hele verden"] notification[value="refresh-blocked"]{

The - in the title is &ndash; (an "n-dash") which is a different character from a hyphen. If you go to the Console section of the developer tools (Ctrl+Shift+k) and type <code>document.title</code> and press Enter, you can copy the title and then paste it into your style rule. Then it should match exactly. Alternately, you can combine ''two'' title attribute selectors to match two word portions so that the dash isn't considered: <code>#main-window[title*="NRK.no"][title*="nyheter, tv og radio fra Norge og hele verden"] notification[value="refresh-blocked"]{</code>

選擇的解決方法

jscher2000 said

The - in the title is – (an "n-dash") which is a different character from a hyphen. If you go to the Console section of the developer tools (Ctrl+Shift+k) and type document.title and press Enter, you can copy the title and then paste it into your style rule. Then it should match exactly. Alternately, you can combine two title attribute selectors to match two word portions so that the dash isn't considered: #main-window[title*="NRK.no"][title*="nyheter, tv og radio fra Norge og hele verden"] notification[value="refresh-blocked"]{


document.title I did not know that :D or the: n-dash

  • #main-window[title*="NRK.no"][title*="nyheter, tv og radio fra Norge og hele verden"] notification[value="refresh-blocked"]{

This worked, the first one did not :D


my situation: see added picture for windows 10 or go to file explorer options in older windows, then view then find something about showing/hiding the file extension (check/uncheck)

  • In your explorer window, go to View and check (File name extensions)

X:\Users\Windows log in user name\AppData\Roaming\Mozilla\Firefox\Profiles\XXXXXXXX.default\Chrome

Create a TXT (text) file and call it:

userChrome.css

yes to changing the file type!

See "Finish product:" or keep reading!


I mark these as the solutions:

Get the sites exact name: Console section of the developer tools (Ctrl+Shift+k) and type document.title


For a website that has an; "n-dash" IN THE TITLE nrk.no who's title is: NRK.no – nyheter, tv og radio fra Norge og hele verden use:

#main-window[title*="NRK.no"][title*="nyheter, tv og radio fra Norge og hele verden"] notification[value="refresh-blocked"]{

 visibility: collapse !important;

}


for a website with a simple title like: reload every 10 seconds who's title is: "Reload Every 10 Seconds" use:

#main-window[title*="Reload Every 10 Seconds"] notification[value="refresh-blocked"]{

 visibility: collapse !important;

}


ALL the answers was provided by: Mr. jscher2000

And a million thanks to you :D


Finish product: /* remove allow to refresh */ /*01 check site name: (Ctrl+Shift+k) and type: document.title*/

/*Sites with "n-dash" in title*/

#main-window[title*="NRK.no"][title*="nyheter, tv og radio fra Norge og hele verden"] notification[value="refresh-blocked"]{

 visibility: collapse !important;

}

/*Sites with simpler titles*/

#main-window[title*="Reload Every 10 Seconds"] notification[value="refresh-blocked"]{

 visibility: collapse !important;

} #main-window[title*="Bergensavisen"] notification[value="refresh-blocked"]{

 visibility: collapse !important;

}

''jscher2000 [[#answer-1137986|said]]'' <blockquote> The - in the title is &ndash; (an "n-dash") which is a different character from a hyphen. If you go to the Console section of the developer tools (Ctrl+Shift+k) and type <code>document.title</code> and press Enter, you can copy the title and then paste it into your style rule. Then it should match exactly. Alternately, you can combine ''two'' title attribute selectors to match two word portions so that the dash isn't considered: <code>#main-window[title*="NRK.no"][title*="nyheter, tv og radio fra Norge og hele verden"] notification[value="refresh-blocked"]{</code> </blockquote> <code>document.title</code> I did not know that :D or the: n-dash * <code>#main-window[title*="NRK.no"][title*="nyheter, tv og radio fra Norge og hele verden"] notification[value="refresh-blocked"]{</code> This worked, the first one did not :D my situation: see added picture for windows 10 or go to file explorer options in older windows, then view then find something about showing/hiding the file extension (check/uncheck) *In your explorer window, go to View and check (File name extensions) X:\Users\Windows log in user name\AppData\Roaming\Mozilla\Firefox\Profiles\XXXXXXXX.default\Chrome Create a TXT (text) file and call it: userChrome.css yes to changing the file type! See "Finish product:" or keep reading! I mark these as the solutions: Get the sites exact name: Console section of the developer tools '''(Ctrl+Shift+k)''' and type <code>document.title</code> For a website that has an; "n-dash" IN THE TITLE [http://nrk.no nrk.no] who's title is: <code>NRK.no – nyheter, tv og radio fra Norge og hele verden</code> use: <code>#main-window[title*="NRK.no"][title*="nyheter, tv og radio fra Norge og hele verden"] notification[value="refresh-blocked"]{ visibility: collapse !important; }</code> for a website with a simple title like: [https://www.jeffersonscher.com/res/reload.html reload every 10 seconds] who's title is: "Reload Every 10 Seconds" use: <code>#main-window[title*="Reload Every 10 Seconds"] notification[value="refresh-blocked"]{ visibility: collapse !important; }</code> '''ALL''' the answers was provided by: Mr. '''[https://support.mozilla.org/en-US/user/jscher2000 jscher2000]''' And a million thanks to you :D Finish product: <code>/* remove allow to refresh */</code> <code>/*01 check site name: (Ctrl+Shift+k) and type: document.title*/</code> <code>/*Sites with "n-dash" in title*/</code> <code>#main-window[title*="NRK.no"][title*="nyheter, tv og radio fra Norge og hele verden"] notification[value="refresh-blocked"]{ visibility: collapse !important; }</code> <code>/*Sites with simpler titles*/</code> <code>#main-window[title*="Reload Every 10 Seconds"] notification[value="refresh-blocked"]{ visibility: collapse !important; }</code> <code>#main-window[title*="Bergensavisen"] notification[value="refresh-blocked"]{ visibility: collapse !important; }</code>

由 S47 於 修改