X
點擊此處開啟此網站的行動版。

技術支援討論區

Netflix won't play since Firefox 61 update installed

已張貼

I've been following the post concerning this topic "Since upgrade to FF 61.0.1 Netflix stopped streaming" and tried the proposed solutions suggested . . . all without success. I've been a long time FF user but if no solution soon, will move to something else. As per Loyall's post, netflix works fine in Edge.

I've been following the post concerning this topic "Since upgrade to FF 61.0.1 Netflix stopped streaming" and tried the proposed solutions suggested . . . all without success. I've been a long time FF user but if no solution soon, will move to something else. As per Loyall's post, netflix works fine in Edge.

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 30.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; rv:61.0) Gecko/20100101 Firefox/61.0

更多資訊

Wesley Branton
  • Top 10 Contributor
644 個解決方法 5241 個答案

Are you getting the same error code as the person in the other thread that you have referenced or something different?

Are you getting the same error code as the person in the other thread that you have referenced or something different?

提出問題者

Netflix error code is F7121-1331-P7. Not sure if this is the same. Google results suggest this is a browser problem and suggests reinstalling browser. Thus I came to this forum.

Netflix error code is F7121-1331-P7. Not sure if this is the same. Google results suggest this is a browser problem and suggests reinstalling browser. Thus I came to this forum.
Wesley Branton
  • Top 10 Contributor
644 個解決方法 5241 個答案

If you sure that you have set privacy.resistFingerprinting to false, then your issue could be something to do with DRM in Firefox.

Try the following:

  1. Open the Firefox settings
  2. Find the Digital Rights Management (DRM) Content section under the General tab
  3. Uncheck Play DRM-controlled content
  4. Restart Firefox
  5. Open the Firefox settings
  6. Find the Digital Rights Management (DRM) Content section under the General tab
  7. Check Play DRM-controlled content
  8. Restart Firefox
If you sure that you have set <code>privacy.resistFingerprinting</code> to <code>false</code>, then your issue could be something to do with DRM in Firefox. Try the following: #Open the Firefox settings #Find the ''Digital Rights Management (DRM) Content'' section under the ''General'' tab #Uncheck ''Play DRM-controlled content'' #Restart Firefox #Open the Firefox settings #Find the ''Digital Rights Management (DRM) Content'' section under the ''General'' tab #Check ''Play DRM-controlled content'' #Restart Firefox

提出問題者

did that earlier today . . . without success. Just tried it again . . . no gain. Double checked the privacy.resistFingerprinting setting . . . it is false. Problem remains. Also tried unchecking "enable Adobe flash protected mode" as per an earlier version solution to this problem . . . no luck.

did that earlier today . . . without success. Just tried it again . . . no gain. Double checked the privacy.resistFingerprinting setting . . . it is false. Problem remains. Also tried unchecking "enable Adobe flash protected mode" as per an earlier version solution to this problem . . . no luck.
Wesley Branton
  • Top 10 Contributor
644 個解決方法 5241 個答案

Go to the Firefox addons page, select Plugins from the sidebar and make sure that the Widevine Content Decryption Module provided by Google Inc. plugin in set to Always Active.

Go to the Firefox addons page, select ''Plugins'' from the sidebar and make sure that the ''Widevine Content Decryption Module provided by Google Inc.'' plugin in set to ''Always Active''.
Wesley Branton
  • Top 10 Contributor
644 個解決方法 5241 個答案

I was discussing the issue with some of the other volunteers on this forum and there seems to be a bug that appeared starting in Firefox 60 with Netflix (see bug 1447085). Apparently, if you have your History setting in the Privacy & Security tab of the Firefox settings set to Never remember history, then Netflix will not work properly.

Please check your settings to see if that's what is causing your problem.

I was discussing the issue with some of the other volunteers on this forum and there seems to be a bug that appeared starting in Firefox 60 with Netflix ([https://bugzilla.mozilla.org/show_bug.cgi?id=1447085 see bug 1447085]). Apparently, if you have your ''History'' setting in the ''Privacy & Security'' tab of the Firefox settings set to ''Never remember history'', then Netflix will not work properly. Please check your settings to see if that's what is causing your problem.

提出問題者

Widevine set always active and history set as remember history. No change. Thanks for all the effort . . .

Widevine set always active and history set as remember history. No change. Thanks for all the effort . . .
cor-el
  • Top 10 Contributor
  • Moderator
17578 個解決方法 158993 個答案

You can check for problems with preferences.


You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

You can check for problems with preferences. *delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases *http://kb.mozillazine.org/preferences_not_saved *http://kb.mozillazine.org/resetting_preferences ---- You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
AliceWyman
  • Moderator
240 個解決方法 2597 個答案

Your User Agent, Mozilla/5.0 (Windows NT 10.0; rv:61.0) Gecko/20100101 Firefox/61.0 indicates Firefox 61 (32-bit) Windows 10.

For users running the 32-bit version of Firefox: A solution reported in an earlier question is to turn off Flash protected mode in Firefox:

  1. Click on the menu button Fx57menu and then click Add-ons.
  2. Click on the Plugins panel and select Options next to Shockwave Flash.
  3. Remove the check mark next to Enable Adobe Flash protected mode.
    Fx57FlashProtectedMode
  4. Click the menu button Fx57menu and then click Exit to close Firefox completely, so that the change can take effect.

When you reopen Firefox, Flash protected mode will be disabled.

The article Adobe Flash protected mode in Firefox has more information.

Your User Agent, Mozilla/5.0 (Windows NT 10.0; rv:61.0) Gecko/20100101 Firefox/61.0 indicates Firefox 61 (32-bit) Windows 10. [[How do I tell if I have the 32-bit or 64-bit Firefox?|For users running the 32-bit version of Firefox]]: A solution reported in [https://support.mozilla.org/en-US/questions/1157003 an earlier question] is to turn off Flash protected mode in Firefox: #Click on the menu button [[Image:Fx57menu]] and then click ''Add-ons''. #Click on the '''Plugins''' panel and select Options next to ''Shockwave Flash''. #Remove the check mark next to ''Enable Adobe Flash protected mode''. #;[[Image:Fx57FlashProtectedMode|width=500]] # Click the menu button [[Image:Fx57menu]] and then click Exit to close Firefox completely, so that the change can take effect. When you reopen Firefox, Flash protected mode will be disabled. The article [[Adobe Flash protected mode in Firefox]] has more information.
cor-el
  • Top 10 Contributor
  • Moderator
17578 個解決方法 158993 個答案

Note that the OP already wrote above about protected mode.

Quote:

did that earlier today . . . without success. Just tried it again . . . no gain. Double checked the privacy.resistFingerprinting setting . . . it is false. Problem remains. Also tried unchecking "enable Adobe flash protected mode" as per an earlier version solution to this problem . . . no luck.
Note that the OP already wrote above about protected mode. [/questions/1226333#answer-1134643 Quote]: <blockquote>did that earlier today . . . without success. Just tried it again . . . no gain. Double checked the privacy.resistFingerprinting setting . . . it is false. Problem remains. Also tried <u>unchecking "enable Adobe flash protected mode"</u> as per an earlier version solution to this problem . . . no luck.</blockquote>