搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox on iMac considers all web-pages unsafe

more options

Firefox on my iMac has developed a new problem. It warns me that web-pages are unsafe, and this warning seems to be for all web-pages, including major ones like google and yahoo. In an attempt to solve this problem, I completely removed Firefox from my iMac, downloaded the latest version and installed. The same problem immediately showed up, also for Firefox and Mozilla web-pages, including the initial page after installation. By the way, since Firefox is not connecting to any web-site, I send this question using Safari. Chrome is also working fine. Three screenshots attached. That was the idea, but for some reason my screenshots do not upload. It has been uploading for an hour or two without getting threw the first upload.

Firefox on my iMac has developed a new problem. It warns me that web-pages are unsafe, and this warning seems to be for all web-pages, including major ones like google and yahoo. In an attempt to solve this problem, I completely removed Firefox from my iMac, downloaded the latest version and installed. The same problem immediately showed up, also for Firefox and Mozilla web-pages, including the initial page after installation. By the way, since Firefox is not connecting to any web-site, I send this question using Safari. Chrome is also working fine. Three screenshots attached. That was the idea, but for some reason my screenshots do not upload. It has been uploading for an hour or two without getting threw the first upload.

被選擇的解決方法

ok, perhaps these instructions from their support article come closer: https://support.kaspersky.com/11550 - you'd want to untick the "check secure connections" box there...

從原來的回覆中察看解決方案 👍 1

所有回覆 (8)

more options

hi, first please make sure that the date, time & timezone are set correctly set correctly on your system. if this doesn't solve the issue (or it is already set properly), a solution depends on the individual circumstances:

  • what is the error code shown when you click on advanced on that error page?
  • please also give us more information about the error by clicking on the error code, copying the text to the clipboard and then pasting it here into a reply in the forum like it's shown in the screenshot.

thank you!

more options

Error code: SEC_ERROR_UNKNOWN_ISSUER

https://www.google.co.uk/?gws_rd=ssl

Peer’s Certificate issuer is not recognized.

HTTP Strict Transport Security: false HTTP Public Key Pinning: true

Certificate chain:


BEGIN CERTIFICATE-----

MIIDiDCCAnCgAwIBAgIMOTcmFqHMi6JxfpkRMA0GCSqGSIb3DQEBCwUAMFYxGTAX BgNVBAoMEEFPIEthc3BlcnNreSBMYWIxOTA3BgNVBAMMMEthc3BlcnNreSBXZWIg QW50aS1WaXJ1cyBDZXJ0aWZpY2F0aW9uIEF1dGhvcml0eTAeFw0wODA3MjAxNzAw NThaFw0yODA3MTUxNzAwNThaMGoxCzAJBgNVBAYTAlVTMRMwEQYDVQQIDApDYWxp Zm9ybmlhMRYwFAYDVQQHDA1Nb3VudGFpbiBWaWV3MRMwEQYDVQQKDApHb29nbGUg TExDMRkwFwYDVQQDDBB3d3cuZ29vZ2xlLmNvLnVrMIIBIjANBgkqhkiG9w0BAQEF AAOCAQ8AMIIBCgKCAQEAup3XK3/E3Vto8Y3/7E+LYcattZQx58SSyjni9yxFCBHb MAYgihXG+VOUAAT6dZZRPhZclCPf2YAh4+PVZdUzLHaPgCXOgKNrOqE6XNgVLTcZ +Kj3Q7QkaNAVekiXTsuMjsxYJrgR2NPznBY8T3u5jyL/xnNPnReCCOXfFMDdQtdQ wQ/twggR89iU+3tR8M+FA8ocg0Jhc7Ontfp6W9PboY+DYDbOzigIziAH3J0/V8iu PyDI1zLw9lgcwUpxCZzvG+jZqmq5rDNNSqSy9O8bgs3UUn6iB0q086Yr+XzKdQsh GI45h+EGdSgyqttf/t8EodCsjnDOs76Y3PhXS+GNtQIDAQABo0IwQDAbBgNVHREE FDASghB3d3cuZ29vZ2xlLmNvLnVrMAwGA1UdEwEB/wQCMAAwEwYDVR0lBAwwCgYI KwYBBQUHAwEwDQYJKoZIhvcNAQELBQADggEBAEmuy7is5yM2VnrgRINwUBio0MGc AwWFaUPBVbTuP4CjPL6wEPWhXS8u90kc4LOuKpDMF5AWtnWK9bNdKSBEwA8z1Lsm QO/b3swHgF49qVM4GABJAcWJdnODulAGSAQc+aVzuruSJMUsn4K8aVhJpzCr85Tn WTlBu3bgGLk6z716uV0tbg9g0zMDBlHrnxX6xBP5VTe298+uow/joe6Sygj9k85I y4LaGaoEMKvxwDxEUzofp2EusxMAFwO5EKbmLEEKLA7M07zpSjO3ssCIMhRGX/+W ymk0h24az1CYopvS/NZ6fZbx5JKmnKuvMQlXix74Tub8eUj5xeGcOK9C/d4=


END CERTIFICATE-----
BEGIN CERTIFICATE-----

MIIDZDCCAkygAwIBAgIJANRn31opTuNCMA0GCSqGSIb3DQEBCwUAMFYxGTAXBgNV BAoMEEFPIEthc3BlcnNreSBMYWIxOTA3BgNVBAMMMEthc3BlcnNreSBXZWIgQW50 aS1WaXJ1cyBDZXJ0aWZpY2F0aW9uIEF1dGhvcml0eTAeFw0wODA0MjYxNzIyMjha Fw0yODA0MjExNzIyMjhaMFYxGTAXBgNVBAoMEEFPIEthc3BlcnNreSBMYWIxOTA3 BgNVBAMMMEthc3BlcnNreSBXZWIgQW50aS1WaXJ1cyBDZXJ0aWZpY2F0aW9uIEF1 dGhvcml0eTCCASIwDQYJKoZIhvcNAQEBBQADggEPADCCAQoCggEBALqd1yt/xN1b aPGN/+xPi2HGrbWUMefEkso54vcsRQgR2zAGIIoVxvlTlAAE+nWWUT4WXJQj39mA IePj1WXVMyx2j4AlzoCjazqhOlzYFS03Gfio90O0JGjQFXpIl07LjI7MWCa4EdjT 85wWPE97uY8i/8ZzT50Xggjl3xTA3ULXUMEP7cIIEfPYlPt7UfDPhQPKHINCYXOz p7X6elvT26GPg2A2zs4oCM4gB9ydP1fIrj8gyNcy8PZYHMFKcQmc7xvo2apquawz TUqksvTvG4LN1FJ+ogdKtPOmK/l8ynULIRiOOYfhBnUoMqrbX/7fBKHQrI5wzrO+ mNz4V0vhjbUCAwEAAaM1MDMwDwYDVR0TAQH/BAUwAwEB/zALBgNVHQ8EBAMCAgQw EwYDVR0lBAwwCgYIKwYBBQUHAwEwDQYJKoZIhvcNAQELBQADggEBAHC7W3Gix6vK lSeSV/+GonQnG6gTieCxu9AHwiwyuvkTdlhorbRNX1XKmuxEvlUxS9Pd1iKQsbux M6zk0yWpZg5xjbYOWA02OVbjsHfbiOKBph9+WsARizb8m+h5YgdB3QEVdIroeCKO 2eTne39KeiU6SWbr7KmS449hNdBzjwar5vnOUxGu8ZdTnnNgm4NCdVQbOcBWBUex jYSuGOT+i+dUKCcwprN7S6FQVc59Fjoj+S9Iw8rgER3vgAy10LuonzVtVoyR+KO5 lf0x+NDQT4zk37gUDr4qo4lvbOsBP0Ww6o99hT1WN86NhlwKzkLifM/wCimDj2BN YkbWUMdHEQ8=


END CERTIFICATE-----
more options

thank you. so it appears that your kaspersky security software is tampering with and intercepting secure connections. please try to configure it like described at https://support.mozilla.org/en-US/kb/error-codes-secure-websites#w_kaspersky (i hope the steps on mac are fairly similar as on windows)

more options

Thank you for your suggestion. Unfortunately the interface of my Kaspersky for Mac seems to be different from the instructions in your link. My version is 18.0.1.35a.b. Looking around on my Kaspersky interface, I noticed that a Security Extension for Firefox is not installed, while it is installed on my wife's iMac where Firefox works fine. Trying to install this Kaspersky extension for Firefox, I am taken to a Firefox Kaspersky web-page with the same security error. If Kaspersky is the culprit for my Firefox not working, I may have to contact Kaspersky support.

more options

選擇的解決方法

ok, perhaps these instructions from their support article come closer: https://support.kaspersky.com/11550 - you'd want to untick the "check secure connections" box there...

more options

Thank you again. Unticking the Check secure connections (HTTPS) seemingly solved my problem. However, I am still left with questions: (1) Are my connections now less secure? (2). Why should I need to untick this on my iMac when Firefox works fine on my wife's iMac with the tick in place? I have now sent a request also to Kaspersky, so I'll see what comes back from them. Thank you very much for your assistance, as I now seems to be able to use my Firefox as before.

more options

this "scanning" depends on a kaspersky certificate being injected into firefox' trust store. something probably went wrong there which makes it look like a unknown/untrusted third-party is manipulating your network traffic and that's why the error messages are displayed.

i think it's more marketing than providing real security. in the past there were numerous incidents where letting av software break up https connections made users less secure: http://www.cbc.ca/news/technology/antivirus-software-1.3668746 https://blog.vpn.ac/disable-https-scanning.html https://www.scmagazineuk.com/updated-kaspersky-leaves-users-open-freak-attack/article/1478879 https://bugs.chromium.org/p/project-zero/issues/detail?id=978

to be honest, personally i would not use any full fledged security suite at all, especially on osx...

由 philipp 於 修改

more options

Thank you, just perusing that article removed any security worries I might have had with the solution that made Firefox work again.