X
點擊此處開啟此網站的行動版。

技術支援討論區

How to STOP Firefox from updating older versions even when set to NOT auto update in Preferences!

已張貼

Okay,

Two parts to this issue.... 1: Part One - Snagit Plugin Autoscroll Helper - the reason I need an older version of Firefox available 2: Part Two - Part one will only work if Part Tow can be retained on older version.


I use a plugin tool called SNAGIT autoscoll helper by TechSmith (or rather used to). The latest Firefox does not support one of the it's primary features, this stopped working approx 2 years ago and Mozilla have disabled it being installed on current versions . TechSmith are just as disengaged and do nothing to resolve or provide an alternative for MAC on any browser.

I thought if I could install two versions of Firefox the latest plus a legacy version (so I can simply autoscoll web page capture), I MAY be able to somehow limp through life in this less that okay way.

Technically the following suggestion works. https://www.haykranen.nl/2011/08/04/howto-run-multiple-versions-of-firefox-side-by-side-on-mac-os-x-lion/

BUT (the big BUT)...even though I download version v50.0 (which allows the plugin) and set to 'not' autoupdate. I get everything running, as soon as I close the older version of Firefox and relaunch it does what it likes and updates this old version to v57.0...this is so not cool!

How do I prevent this and how can I get multiple versions functioning? I have left messages on TechSmiths site as well but as the two seems to be blaming each other for the disconnect...maybe someone in the community has a work around?

Ideas greatly appreciated....and Mozilla if there is 'anything' you can do to get the plugin reinstated and integrated with your latest version, that would be fantastic!

Thanks

Okay, Two parts to this issue.... 1: Part One - Snagit Plugin Autoscroll Helper - the reason I need an older version of Firefox available 2: Part Two - Part one will only work if Part Tow can be retained on older version. I use a plugin tool called SNAGIT autoscoll helper by TechSmith (or rather used to). The latest Firefox does not support one of the it's primary features, this stopped working approx 2 years ago and Mozilla have disabled it being installed on current versions . TechSmith are just as disengaged and do nothing to resolve or provide an alternative for MAC on any browser. I thought if I could install two versions of Firefox the latest plus a legacy version (so I can simply autoscoll web page capture), I MAY be able to somehow limp through life in this less that okay way. Technically the following suggestion works. https://www.haykranen.nl/2011/08/04/howto-run-multiple-versions-of-firefox-side-by-side-on-mac-os-x-lion/ BUT (the big BUT)...even though I download version v50.0 (which allows the plugin) and set to 'not' autoupdate. I get everything running, as soon as I close the older version of Firefox and relaunch it does what it likes and updates this old version to v57.0...this is so not cool! How do I prevent this and how can I get multiple versions functioning? I have left messages on TechSmiths site as well but as the two seems to be blaming each other for the disconnect...maybe someone in the community has a work around? Ideas greatly appreciated....and Mozilla if there is 'anything' you can do to get the plugin reinstated and integrated with your latest version, that would be fantastic! Thanks

提出問題者

Actually - I have just tested again on Chrome, and Autoscoll now works.

So question to Mozilla is why can't we get this working on Firefox?

Actually - I have just tested again on Chrome, and Autoscoll now works. So question to Mozilla is why can't we get this working on Firefox?
Shadow110 1072 個解決方法 14836 個答案

There are several auto scroll Extensions available for 57+

https://addons.mozilla.org/firefox/search/?platform=linux&q=Autoscroll&type=extension

This is why the Developer does not have time to convert Snagit to the API format, his Homepage goes here : https://www.techsmith.com/

Find in the Mozilla folders Updater.exe and rename it to Updater-old.exe

If you want yes can run a 2nd version but ask before you do as there are ways to do it so it does not screw things up.

The Developer Edition can be run in compatibility mode but it is a always a beta program.

Please let us know if this solved your issue or if need further assistance.

There are several auto scroll Extensions available for 57+ https://addons.mozilla.org/firefox/search/?platform=linux&q=Autoscroll&type=extension This is why the Developer does not have time to convert Snagit to the API format, his Homepage goes here : https://www.techsmith.com/ Find in the Mozilla folders Updater.exe and rename it to Updater-old.exe If you want yes can run a 2nd version but ask before you do as there are ways to do it so it does not screw things up. The Developer Edition can be run in compatibility mode but it is a always a beta program. Please let us know if this solved your issue or if need further assistance.