搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Secure Connection Failed

  • 1 回覆
  • 1 有這個問題
  • 416 次檢視
  • 最近回覆由 jscher2000

more options

22.12 2018 06 27 pst usa

after the update to 62 we have been getting alot of this error: the below is from just going to www.google.com but we get this at ANY time on most any page.

Secure Connection Failed

An error occurred during a connection to www.google.com. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

Learn more…

Report errors like this to help Mozilla identify and block malicious sites

system info from the troubleshooting page would not all fit here so it has been pasted UNDER the Share Data info below.

所有回覆 (1)

more options

Hi d.bede, thank you for the detailed information.

"SSL_ERROR_RX_RECORD_TOO_LONG" is occurring when Firefox and a website try to negotiate a connection using the latest TLS protocol (version 1.3) and a "man-in-the-middle" -- typically Avast Web Shield or AVG Web Shield -- somehow messes it up.

Until this is sorted out, I think your two workarounds are either:

(1) Remove the man in the middle (disable Web Shield for secure connections).

See the Avast section of: How to troubleshoot security error codes on secure websites.

(2) Disable TLS 1.3 in Firefox so it connects using an older protocol. To do that:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste TLS and pause while the list is filtered

(C) Double-click the security.tls.version.max preference to display a dialog where you can change the value from 4 to 3 (this corresponds to TLS 1.2) and then click OK