X
點擊此處開啟此網站的行動版。

技術支援討論區

In firefox search, neither enter nor cursor click works

已張貼

For at least two days, I have been unable to use the search bar in firefox. I am using the most current version of firefox. When I enter a term, neither hiting the enter (return) key, nor clicking in the green arrow with my cursor will initiate a search. There is no problem using the address bar. I have at least one suggestion enabled in privacy settings. I am using a MAC. Help! Thanks, Debbie

For at least two days, I have been unable to use the search bar in firefox. I am using the most current version of firefox. When I enter a term, neither hiting the enter (return) key, nor clicking in the green arrow with my cursor will initiate a search. There is no problem using the address bar. I have at least one suggestion enabled in privacy settings. I am using a MAC. Help! Thanks, Debbie

被選擇的解決方法

Hi Debbie, you are Welcome. As of version 60 some userChrome does not work any more or is subtle issues now like what you are experiencing , may get worse later.

Some of these am sure you have but useful and as said some do not work any more, might find the last url if not have what you can post in or see if there is new code :

  • Please select the answer that solves the problem*.

This will help other users with similar problems find the solution more easily.

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 29.0 r0

應用程式

  • Firefox 60.0.1
  • 使用者代理:Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:60.0) Gecko/20100101 Firefox/60.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/60.0.1/Darwin/en-US/

擴充套件

  • Adblock Plus 3.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Search Site WE 2.5 (searchsite-we@DW-dev)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription:
  • adapterDeviceID: 0x6741
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • crashGuards: []
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'TileHeight': 512, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 512, u'AzureCanvasAccelerated': 1, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 3
  • usesTiling: True
  • webgl1DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: ATI Technologies Inc. -- AMD Radeon HD 6750M OpenGL Engine
  • webgl1Version: 4.1 ATI-1.24.39
  • webgl1WSIInfo: CGL
  • webgl2DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
  • webgl2Renderer: ATI Technologies Inc. -- AMD Radeon HD 6750M OpenGL Engine
  • webgl2Version: 4.1 ATI-1.24.39
  • webgl2WSIInfo: CGL
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL
  • windowUsingAdvancedLayers: False

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
Shadow110 1072 個解決方法 14836 個答案

有幫助的回覆

Please see if this Search Site WE is the issue : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

Please see if this Search Site WE is the issue : SAFE MODE *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit) *hardware acceleration is disabled (Options > Advanced > General) *plugins are not affected *preferences are not affected TEST'''''''''is issue still there ?

提出問題者

Thanks. Yes, in safe mode, no problem. I have the Adblock Plus and Search Site WE enabled. I had disabled them separately before writing my first problem, and it did not seem to effect the problem, but I had not restarted firefox. Do you think I should disable THEN try?

Thanks. Yes, in safe mode, no problem. I have the Adblock Plus and Search Site WE enabled. I had disabled them separately before writing my first problem, and it did not seem to effect the problem, but I had not restarted firefox. Do you think I should disable THEN try?
Shadow110 1072 個解決方法 14836 個答案

Yes please, disable Site WE then restart.

Yes please, disable Site WE then restart.

提出問題者

Hmmm...I did that, but no luck. I also disabled AdBlock Plus and restarted but still have the problem, even though safe mode was successful. What else could it be tht needs to be disabled?

Hmmm...I did that, but no luck. I also disabled AdBlock Plus and restarted but still have the problem, even though safe mode was successful. What else could it be tht needs to be disabled?
Shadow110 1072 個解決方法 14836 個答案

That blows the sails out. Ya, have you any userChrome that you have made ? ? If do not know prob do not but should know as 235 million ways to customize Firefox :

A theme ? I can not see hardware acceleration as the issue but stranger things have happened.

Check the above and will try to get some help on this, Thanks.

That blows the sails out. Ya, have you any userChrome that you have made ? ? If do not know prob do not but should know as 235 million ways to customize Firefox : *https://www.howtogeek.com/334716/how-to-customize-firefoxs-user-interface-with-userchrome.css/ A theme ? I can not see hardware acceleration as the issue but stranger things have happened. Check the above and will try to get some help on this, Thanks.

提出問題者

Yeah, I do have a userchrome.css; it allows tabs on bottom. When I start in safe mode, the tabs go to the top, so it must be that. Damn! Now I have to decide which is more important, and search bar or the tabs! Thanks for helping me figure this out. If you have any further info on being able to have tabs on bottom AND the search bar active, let me know.

Debbie

Yeah, I do have a userchrome.css; it allows tabs on bottom. When I start in safe mode, the tabs go to the top, so it must be that. Damn! Now I have to decide which is more important, and search bar or the tabs! Thanks for helping me figure this out. If you have any further info on being able to have tabs on bottom AND the search bar active, let me know. Debbie
FredMcD
  • Top 10 Contributor
4220 個解決方法 58912 個答案

It could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

It could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}
Shadow110 1072 個解決方法 14836 個答案

選擇的解決方法

Hi Debbie, you are Welcome. As of version 60 some userChrome does not work any more or is subtle issues now like what you are experiencing , may get worse later.

Some of these am sure you have but useful and as said some do not work any more, might find the last url if not have what you can post in or see if there is new code :

  • Please select the answer that solves the problem*.

This will help other users with similar problems find the solution more easily.

Hi Debbie, you are Welcome. As of version 60 some userChrome does not work any more or is subtle issues now like what you are experiencing , may get worse later. Some of these am sure you have but useful and as said some do not work any more, might find the last url if not have what you can post in or see if there is new code : *http://techdows.com/2017/09/classic-theme-restorer-userchrome-css-modify-firefox-57-photon-ui.html *https://github.com/Aris-t2/CustomCSSforFx/issues/1 *https://www.accessfirefox.org/Theme-Font-Size-Changer.php *https://www.userchrome.org/ *https://www.accessfirefox.org/Firefox_Accessibility_Themes.php *https://www.userchrome.org/what-is-userchrome-css.html *http://kb.mozillazine.org/UserChrome.css *https://github.com/axydavid/FirefoxUI/blob/master/README.md *https://github.com/wilfredwee/photon-australis *https://www.reddit.com/r/FirefoxCSS/ *https://www.reddit.com/r/FirefoxCSS/comments/6xyyy5/request_tabs_on_the_bottom_of_the_entire_firefox/ *Please select the answer that solves the problem*. This will help other users with similar problems find the solution more easily.

提出問題者

Thanks, Pkshadow. Followed this link https://github.com/Aris-t2/CustomCSSforFx/issues/1 and updated the userChrome.css file from 1.28 to 1.89.

Now I have tabs below AND a funtioning search bar.

You made my day! Debbie

Thanks, Pkshadow. Followed this link https://github.com/Aris-t2/CustomCSSforFx/issues/1 and updated the userChrome.css file from 1.28 to 1.89. Now I have tabs below AND a funtioning search bar. You made my day! Debbie