X
點擊此處開啟此網站的行動版。

技術支援討論區

Can't turn off two factor authentication (though bank site says it's off)

已張貼

Every time I log into TD bank using Firefox, it insists that I use two factor authentication, i.e., enter a code sent to my phone into the web interface. I explicitly indicated that I don't want this on TD Bank's web page settings. Nonetheless this keeps happening. I've tried clearing the cache and cookies, with no luck. I contacted TD Bank support and they are stumped. Please help.

Notes: This happened since I upgraded to Firefox Quantum (60.0.1). It did not used to happen before. This happens in Private windows as well. Windows 8.1 system, Avast antivirus, no encryption or other safety tools.

Thanks in advance for your help!

Every time I log into TD bank using Firefox, it insists that I use two factor authentication, i.e., enter a code sent to my phone into the web interface. I explicitly indicated that I don't want this on TD Bank's web page settings. Nonetheless this keeps happening. I've tried clearing the cache and cookies, with no luck. I contacted TD Bank support and they are stumped. Please help. Notes: This happened since I upgraded to Firefox Quantum (60.0.1). It did not used to happen before. This happens in Private windows as well. Windows 8.1 system, Avast antivirus, no encryption or other safety tools. Thanks in advance for your help!

被選擇的解決方法

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.


It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

從原來的回覆中察看解決方案 0
FredMcD
  • Top 10 Contributor
4220 個解決方法 58899 個答案

I called for help.

Firefox is just a browser. It displays what websites tell it to. I don't see how it could trigger two-factor authentication. But let's try this;

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

I called for help. Firefox is just a browser. It displays what websites tell it to. I don't see how it could trigger two-factor authentication. But let's try this; Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * '''Cookies; ''' [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * '''Cache; ''' [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}
the-edmeister
  • Top 25 Contributor
  • Moderator
5395 個解決方法 40083 個答案

security.webauth.u2f is the preference for that in Firefox 60 which is disabled = false by default, Currently a user would need to enable it if they wish to use that feature.

'''security.webauth.u2f''' is the preference for that in Firefox 60 which is disabled = false by default, Currently a user would need to enable it if they wish to use that feature.

提出問題者

Thank you for your replies. Changing the about:config security settings did not work. (see attached screen capture). Changing U2F default from false to true or back didn't work. Neither did changing the webauthn setting to false or to true...

Tired clearing cache and removing bookmarks, didn't work.

However, in safe mode, it did not require 2fa. I don't want to have to start in safe mode every time for this, though, and I check the bank frequently.

I'd really appreciate any further suggestions or comments.

Thanks!

Thank you for your replies. Changing the about:config security settings did not work. (see attached screen capture). Changing U2F default from false to true or back didn't work. Neither did changing the webauthn setting to false or to true... Tired clearing cache and removing bookmarks, didn't work. However, in safe mode, it did not require 2fa. I don't want to have to start in safe mode every time for this, though, and I check the bank frequently. I'd really appreciate any further suggestions or comments. Thanks!
FredMcD
  • Top 10 Contributor
4220 個解決方法 58899 個答案

選擇的解決方法

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.


It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else. ---------------- It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.
cor-el
  • Top 10 Contributor
  • Moderator
17407 個解決方法 157253 個答案

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox

提出問題者

Turned out the problem was with one of the Firefox add-ons, namely UBlockOrigin. Changed the Filter Lists - Privacy - Easy Privacy setting (unchecked it), and now TD Bank is no longer demanding 2FA.

Thanks to all for their help.

Turned out the problem was with one of the Firefox add-ons, namely UBlockOrigin. Changed the Filter Lists - Privacy - Easy Privacy setting (unchecked it), and now TD Bank is no longer demanding 2FA. Thanks to all for their help.
FredMcD
  • Top 10 Contributor
4220 個解決方法 58899 個答案

That was very good work. Well done.

You should contact UBlock support and let them know.

That was very good work. Well done. You should contact UBlock support and let them know.