X
點擊此處開啟此網站的行動版。

技術支援討論區

recaptcha not working in firefox on any version new or older tried reinstall loads of times no success

已張貼

I have no captcha at all in firefox on any version new or old either 32bit or 64bit i am on windows 10x64 and not showing anything but IE and chrome are ok showing it i even tried this https://patrickhlauke.github.io/recaptcha/ and nothing i only get Google reCAPTCHA test

Adds the vanilla reCAPTCHA widget, for testing...

and nothing below i have no idea of how to get it working tried all the suggestions about this issue and nothing fixed it

I have no captcha at all in firefox on any version new or old either 32bit or 64bit i am on windows 10x64 and not showing anything but IE and chrome are ok showing it i even tried this https://patrickhlauke.github.io/recaptcha/ and nothing i only get Google reCAPTCHA test Adds the vanilla reCAPTCHA widget, for testing... and nothing below i have no idea of how to get it working tried all the suggestions about this issue and nothing fixed it
附加的畫面擷圖

被選擇的解決方法

Ok seems that after the win10 april update the FF recaptcha issue was solved so this means it was a really a OS issue as i thought but the weird is why it would affect FF only and not all browsers again microsoft at their best lol

從原來的回覆中察看解決方案 0

提出問題者

What's really weird is that on my win7 x32 the captcha is working fine on FF seems to me this is a windows 10 FF issue or something

What's really weird is that on my win7 x32 the captcha is working fine on FF seems to me this is a windows 10 FF issue or something

由 xapim 於 修改

FredMcD
  • Top 10 Contributor
4189 個解決方法 58498 個答案

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

提出問題者

Already tried that same issue

Already tried that same issue
FredMcD
  • Top 10 Contributor
4189 個解決方法 58498 個答案

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Secure''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

提出問題者

its the same in safe mode nothing changed this is a brand new Acer Predator Helios 300 dunno why i'm having this issue like i said seems to me its win 10 related as my other laptops on win7 all work fine with FF (captcha)

its the same in safe mode nothing changed this is a brand new Acer Predator Helios 300 dunno why i'm having this issue like i said seems to me its win 10 related as my other laptops on win7 all work fine with FF (captcha)
cor-el
  • Top 10 Contributor
  • Moderator
17344 個解決方法 156782 個答案

Did you check the Web Console for error messages and warnings?

Did you check the Web Console for error messages and warnings?

提出問題者

as far as i can see no errors at all in the console i just have this :


         GET 

https://patrickhlauke.github.io/recaptcha/ [HTTP/2.0 304 Not Modified 230ms] GET https://www.google.com/recaptcha/api.js [HTTP/2.0 200 OK 63ms] GET https://www.gstatic.com/recaptcha/api2/v1526338122299/recaptcha__en.js [125ms

as far as i can see no errors at all in the console i just have this : GET https://patrickhlauke.github.io/recaptcha/ [HTTP/2.0 304 Not Modified 230ms] GET https://www.google.com/recaptcha/api.js [HTTP/2.0 200 OK 63ms] GET https://www.gstatic.com/recaptcha/api2/v1526338122299/recaptcha__en.js [125ms
PavelkoT 4 個解決方法 96 個答案

xapim check that js is enabled for gstatic.com

'''xapim''' check that js is enabled for gstatic.com

提出問題者

if i go to http://www.gstatic.com/ i get Corrupted Content Error

how and where do i check if js is enabled ?

cheers

if i go to http://www.gstatic.com/ i get Corrupted Content Error how and where do i check if js is enabled ? cheers
cor-el
  • Top 10 Contributor
  • Moderator
17344 個解決方法 156782 個答案

Do you see the reCaptcha iframe in the Inspector on the test page?

Do you see the reCaptcha iframe in the Inspector on the test page?

有幫助的回覆

no no iframe there

no no iframe there
cor-el
  • Top 10 Contributor
  • Moderator
17344 個解決方法 156782 個答案

So it sounds that the JavaScript that creates the iframe is blocked.

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

So it sounds that the JavaScript that creates the iframe is blocked. You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

提出問題者

Hi just tried it and no changes in the new profile i created i get the same in the inspector no iframe at all

Hi just tried it and no changes in the new profile i created i get the same in the inspector no iframe at all

提出問題者

this is the main reason i hate windows 10 it has so many issues prefer win 7 1000x but XP rules

this is the main reason i hate windows 10 it has so many issues prefer win 7 1000x but XP rules

提出問題者

well seems my issue cant be solved at all :( even after deleted all the mozilla folders in appdata folders and removing firefox loads of times with youruninstaller (removing all the registry keys associated) the issue remains just tested this link from google (https://www.google.com/recaptcha/api2/anchor?ar=1&k=6Le-wvkSAAAAAPBMRTvw0Q4Muexq9bi0DJwx_mJ-&co=aHR0cHM6Ly93d3cuZ29vZ2xlLmNvbTo0NDM.&hl=en&v=v1526338122299&size=normal&cb=mxbctw1legzy#d1jbdgeq1gfs) and blank page all ok on chrome and IE seems i wont be able to use firefox on this laptop (regarding the captcha issue) will have to use IE or Chrome instead its really a shame

well seems my issue cant be solved at all :( even after deleted all the mozilla folders in appdata folders and removing firefox loads of times with youruninstaller (removing all the registry keys associated) the issue remains just tested this link from google (https://www.google.com/recaptcha/api2/anchor?ar=1&k=6Le-wvkSAAAAAPBMRTvw0Q4Muexq9bi0DJwx_mJ-&co=aHR0cHM6Ly93d3cuZ29vZ2xlLmNvbTo0NDM.&hl=en&v=v1526338122299&size=normal&cb=mxbctw1legzy#d1jbdgeq1gfs) and blank page all ok on chrome and IE seems i wont be able to use firefox on this laptop (regarding the captcha issue) will have to use IE or Chrome instead its really a shame
PavelkoT 4 個解決方法 96 個答案

xapim said

this is the main reason i hate windows 10 it has so many issues prefer win 7 1000x but XP rules

So, use Windows 7. What is problem. :) I use Windows 7 and it's works well.

''xapim [[#answer-1114749|said]]'' <blockquote> this is the main reason i hate windows 10 it has so many issues prefer win 7 1000x but XP rules </blockquote> So, use Windows 7. What is problem. :) I use Windows 7 and it's works well.

提出問題者

Because this predator helios is the 128gb ssd version not much space left for win 7 and dont want mess up the warranty as it's brand new maybe after ill upgrade the ssd to a larger one :)

Because this predator helios is the 128gb ssd version not much space left for win 7 and dont want mess up the warranty as it's brand new maybe after ill upgrade the ssd to a larger one :)
cor-el
  • Top 10 Contributor
  • Moderator
17344 個解決方法 156782 個答案

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10

提出問題者

that was one of the first options i tested :) and no success same issue which is very weird can't get my head on it and why is this only happening on FF even got rid of all norton software that came with it and got the usual i use in all my laptops nod 32 still no go :(

that was one of the first options i tested :) and no success same issue which is very weird can't get my head on it and why is this only happening on FF even got rid of all norton software that came with it and got the usual i use in all my laptops nod 32 still no go :(

由 xapim 於 修改

選擇的解決方法

Ok seems that after the win10 april update the FF recaptcha issue was solved so this means it was a really a OS issue as i thought but the weird is why it would affect FF only and not all browsers again microsoft at their best lol

Ok seems that after the win10 april update the FF recaptcha issue was solved so this means it was a really a OS issue as i thought but the weird is why it would affect FF only and not all browsers again microsoft at their best lol

由 xapim 於 修改