搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Why is 32 bit Firefox slow on 32 bit Windows 7?

  • 8 回覆
  • 1 有這個問題
  • 250 次檢視
  • 最近回覆由 anderci

more options

I have been thinking my DELL Latitude Laptop PC (Windows 7 32 bit) was wearing out. When using Firefox (59.0.3) (32), Checking email or any other web activity is very sloooow. Out of curiosity, I tried Internet Explorer. It was fast! Why should Firefox be so unbearably slow? I use it 99.9% of the time.

被選擇的解決方法

How I love these G4x chipsets...

I would do this:

  1. Create a new profile, launch Firefox with that profile, disable hardware acceleration first, restart Firefox and see how that performs.
  2. Update your graphics driver to version 8.15.10.2869, to be found here, or even 8.15.10.2993 currently offered.

Did the performance improve in both cases?

If you are happy with the new profile and driver, you could consider copying important data from the old profile to the new profile.

Side note: Firefox once was pretty fast with that driver up to Firefox 37 until parts of hardware acceleration were blocked. Using that version is of course not recommended, but you may need to disable hw acceleration in Options after all in any profile to prevent other issues, though your mileage may vary.

從原來的回覆中察看解決方案 👍 1

所有回覆 (8)

more options

Hi, please be aware that your Video card Mobile Intel(R) 45 Express Chipset Family (Microsoft Corporation - WDDM 1.1) driverDate: 5-6-2009 has multiple errors and these can cause a wide range of issues with Firefox. u'unavailable = bad u'#BLOCKLIST_FEATURE_FAILURE_BUG_1074378_1', u'type': u'env'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'blacklisted', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'#BLOCKLIST_FEATURE_FAILURE_BUG_1074378_1'

Please go to Options --> General --> Performance and uncheck the box for Use Recommended Settings and try changing the Process count to 2 and can also go up but note more cpu and ram will be used. You will need to reboot after makng any changes.

Then go to Privacy & Security and down to Permissions. Please ensure that the box for Prevent Accessibility Services from accessing your browser is checked.

Please note Firefox current version is 60.0.1 https://support.mozilla.org/en/kb/update-firefox-latest-version

more options

Thank you for your response.

I followed the setting steps, then updated to version 60.0.1 and repeated the option settings. With all of the new settings, it takes almost 1 and a quarter to one and a half minutes to bring up a website (e.g.: Gmail, GMaps) When that is open, I can open a new tab and bring up another page in ~ 5 seconds. (e.g.: AccuWeather)

I had not tried this timing approach before making the setting changes. I had not compared first website, then second website timings.

由 anderci 於 修改

more options

That is slow. Please check : Firefox would create a new default profile if there is a problem with the profiles.ini file that register the profiles.

Is there currently only one profile present or are there profiles that aren't listed in profiles.ini ?

You can find the profiles.ini file in a hidden location in AppData\Roaming. You can find a button on the about:profiles page to go to the current profile folder*Windows: %AppData%\Mozilla\Firefox\ C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\

You can also create a new Profile to see if there are other issues : If there is : you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem. Never work with original files.

more options

Also please try from a DOS Prompt Right Click it and Run as Administrator and type this in SFC /SCANNOW (sfc<space>/scannow) Reboot after.

more options

Thank you for your response. The scan did not find any violations. I did the reboot. This morning, it took 2 minutes : 45 seconds to bring up G Maps; in a second tab Accuweather came up in several seconds. It also took ~ 2 and a half minutes to bring up Accuweather in a fresh Firefox window. I checked, and the settings from the previous process were still in place.

more options

In c:\Program Files\Mozilla Firefox\ I found: application.ini, crashreporter.ini, platform.ini, updater.ini and update-settings.ini In c:\Users\,user>\AppDate/Roaminf\Mozilla\Firefox\ I found profiles.ini It contained: [General] StartwithLastProfile=1 [Profile0] Name=default IsRelative=1 Path=Profiles/8ndl9n0r.default

I do not know what to do with this latest response.

more options

選擇的解決方法

How I love these G4x chipsets...

I would do this:

  1. Create a new profile, launch Firefox with that profile, disable hardware acceleration first, restart Firefox and see how that performs.
  2. Update your graphics driver to version 8.15.10.2869, to be found here, or even 8.15.10.2993 currently offered.

Did the performance improve in both cases?

If you are happy with the new profile and driver, you could consider copying important data from the old profile to the new profile.

Side note: Firefox once was pretty fast with that driver up to Firefox 37 until parts of hardware acceleration were blocked. Using that version is of course not recommended, but you may need to disable hw acceleration in Options after all in any profile to prevent other issues, though your mileage may vary.

more options

Creating the new profile fixed the slow speed problem.