搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Print preview is not the same as print emulate

  • 3 回覆
  • 1 有這個問題
  • 8 次檢視
  • 最近回覆由 WestEnd

more options

Hello, I have no problems printing with all browsers.... except FireFox. In Firefox, I can only print the first page, and I get a blank page1 and blank page3 (with page2 containing the first page). I try to emulate the print view, but it shows ok. I am not sure how I can resolve my issue as the CSS is enormous. I would have to visit refactoring a bunch of css and that is a project on it's own.

This is frustrating, as I'm currently letting people know they should use other browsers.

All other browsers print properly, but when they don't, I use the emulate print view (css) and I can then debug it. But I can not do anything with this. Here is an example page I found that shows the problem. Print,.. issue, print emulate... no problem...

What's going on ??? http://www.simcoemuskokahealth.org/Topics/Environment/airwebreathe/mould/cleaningafteraflood.aspx

所有回覆 (3)

more options

Hi, please see these for any info you can glean from them :

Please check the Printers Website for any Firmware Flashes and or Updated drivers and software for Windows 10. Also please know that Win10 can and will change any and all hardware drivers. Should search for Device Manager and check :

Please let us know if this solved your issue or if need further assistance.

more options

Pkshadow said

Hi, please see these for any info you can glean from them : Please check the Printers Website for any Firmware Flashes and or Updated drivers and software for Windows 10. Also please know that Win10 can and will change any and all hardware drivers. Should search for Device Manager and check : Please let us know if this solved your issue or if need further assistance.

Hello, Thank you for your feedback. I managed to derive one outcome.. that is, by adjusting the fontsize or anything related to the page 2,... it simply shows more or less on the 2nd page. But I'm still getting a blank page 1, and a blank page 3 (which appears to cut off the 2nd page. The page should be about 6 pages (depending I suppose one your printing settings.

I believe this has to do with styles, how it is translated. I tried the page above http://www.simcoemuskokahealth.org/Topics/Environment/airwebreathe/mould/cleaningafteraflood.aspx but it still does the same thing.

Problem again is, typing 'media emulate print' shows my page properly. But print preview (or print) does not.

Can you try the page I keep including in this thread? http://www.simcoemuskokahealth.org/Topics/Environment/airwebreathe/mould/cleaningafteraflood.aspx

I'm sure you'll find it pretty quick that something is wrong ... between the media emulate print and the print preview. If media emulate print worked properly, it would show me the page and I would be able to start debugging my page. Orrrrrrrrr..... if the print preview showed the same thing as emulate, I wouldn't have any problems.

Problem I'm having, is every browser shows/emulates the page properly. But FireFox is the only browser that doesn't show the print preview the same as the media print emulate.

Can you have a look at the page?

more options

I went to the page and did some options after doing a PP and here is my screen shot did you do the same settings as my print options.