Search Support

Security privacy and history.

  • 35 回覆
  • 2 有這個問題
  • 114 次檢視
  • 最近回覆由 Hendrawna

more options

In the Security page under privacy and history, I'm unable to answer the question "Have I visited this website prior to today ?" as there's nothing to click on. So it's stuck at No whereas I've been into the page for ages....

Appreciate any help what to do thanks

被選擇的解決方法

Hendrawna said

Just entered https in manually again and it's all ok....??

You could bookmark this site, so you won't have to add the 'https' all the time ...... (?)

https://poldark.activeboard.com/

從原來的回覆中察看解決方案 👍 1

All Replies (20)

more options

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

Screenpic attached.

I've also got an https. green padlock as well which isn't appearing in the top address box of the forum.

Hope you can help....

Thanks :)

more options

I see. That is a poor choice of wording. That should have read; 'Have you visited this site before today'

All that means is were you there before.

more options

I clearly understand what you're saying but as it's asking a question "Was I here before ?" where's the button allowing me to reply saying "Yes or No" as I'm only seeing "No"....??

Also as I said earlier I still can't find my green padlock icon in the top address bar, so could you help with this problem please as well as the site is already https ?

more options

Hendrawna said

I clearly understand what you're saying but as it's asking a question "Was I here before ?" where's the button allowing me to reply saying "Yes or No" as I'm only seeing "No"....??

There is no button, because you should see "No" change to "Yes, xxx times" at least one day after you first visited the page.

The only reason I can think of why this stays on "No" for you, is because maybe you don't allow third party cookies (?)

Also as I said earlier I still can't find my green padlock icon in the top address bar, so could you help with this problem please as well as the site is already https ?

Would you please take a look at this article :

https://support.mozilla.org/en-US/kb/what-does-your-connection-is-not-secure-mean

more options

How to allow third party cookies ?

Not a techie so no idea about the green padlock icon will ask the forum owners....

more options

It is not meant as a question, but merely as an indication whether you have visited this web page in the past or not. If this is the case then Firefox will answer as 'Yes' and vice versa with 'No' if this is your first visit. For this website I see, so I regularly do some cleanup regularly to keep the visit count within limits. "Have I visited this website prior to today ?" Yes, 3,477 times


Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security -> Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"
more options

Hendrawna said

How to allow third party cookies ?

Go to the 3-bar menu (or 'Tools') => Options => Privacy & Security

Under 'History' choose 'Use custom settings for history' and check 'Accept third party cookies'.

But I'm only guessing that this is why you get "No" instead of "Yes, xxx times" - as you mentioned that you've visited this page for ages.

more options

Under History I can't see anything about "custom settings for history" ?

more options

What is the current setting as shown for "Firefox will"?

more options

This screenshot may help in accessing the detailed settings -- that first line has a little drop-down you can use to view the details.

more options

Never remember history

more options

Ok I clicked on remember history and finally found the setting cookies et.c details. As there's a lot of options what do I click on to resolve it all ?

more options

Hendrawna said

Under History I can't see anything about "custom settings for history" ?

A lot of people have that same problem .....

由 Murphy 於 修改

more options

Hendrawna said

cor-el said
What is the current setting as shown for "Firefox will"?

Never remember history

The "Never remember history" option triggers automatic private browsing mode, which keeps cookies only in memory for the current session. So that would explain why you had these issues. I think with almost any other settings, you'll be back on track.

由 jscher2000 於 修改

more options

Hendrawna said

Ok I clicked on remember history and finally found the setting cookies et.c details. As there's a lot of options what do I click on to resolve it all ?

Oops, missed your follow-up. I think you are familiar with how sites set cookies to keep you logged in. If you have these settings, Firefox will be most compatible with sites:

☑ Accept cookies from websites (selected)
Accept third-party cookies: Always
Keep until: they expire
☐ Clear history when Firefox closes (not selected)

Many users make adjustments to these settings, or use cookie-related add-ons, or anti-tracking add-ons, to reduce tracking. That's a separate discussion about how you want to handle that.

more options

Still have a final problem with an https: on the same web page forum, as the green padlock sometimes comes on but all the icons down the left hand column grey out. And vice versa the green padlock disappears and the left hand column icons appear....

How to keep all the icons showing at the same time ?

more options

If a site wasn't designed for HTTPS, some of its pages may end up having a mix of resources, some using secure HTTPS addresses and some using insecure HTTP addresses. Firefox allows insecure images in a secure page, but may block other insecure resources.

Do you know whether the forum was intended to be accessed using HTTPS? If so, please mention the problem to them (i.e., some addresses need to be fixed).

more options

Sparklit/ Activeboard based in Vancouver who are an exceptionally good and highly professional hosting company and forum providers, started out as an ordinary http forum back in about 2002/3. I joined them in about 2004 and have never had any problems with them at all finally upgrading to https just before Christmas.

They already know about the problems I've been having also suggesting that the cookies might be the cause, other than that they suggested contacting yourselves. Alternatively someone from Firefox contacting their help desk, either way not being a techie I've no idea what is causing the icons to appear and disappear in turn....

more options

Can you paste the URL of a page that looks normal when you access it using the HTTP address, but has problems when you change it to an HTTPS address?

  1. 1
  2. 2